Jump to content

Kernel panic dopo stop + black screen con 15.4


Go to solution Solved by iCanaro,

Recommended Posts

Ciao ragazzi da quando ho installato Catalina, mi capita che il sistema si riavvii e vada in kernel panic dopo essere andato in stop. Dopo diverse prove con i vari kext mi sono accorto che dipende dal kext Audio AppleALC, in fatti rimuovendolo il problema non si pone. Avevo risolto i problema con la versione precedente di Catalina aggiungendo una patch tramite clover, ma dopo aver aggiornato alla 10.15.1, il problema si è ripresentato, qualcuno di voi ha lo stesso problema? come avete risolto?

Link to post
Share on other sites
  • Support Team

Per la firma, devi andare nel tuo profilo

 

Immagino che di questa EFI postata in cui hai lasciato inutilmente dentro la cartella microsoft, che non ci serve se non ad appesantire in file, di farina del tuo sacco ci sia non molto... dico questo perché vedo soluzioni complesse che attuerebbe un utente esperto, abbinata a pivellate immani del tipo che hai un SSDT per il power management poi anche plugintype flaggato nel config

 

aggiungi il rename SAT0 to SATA

 

drop tables completamente vuota

 

il DSDT è stato fatto con le ACPI del tuo hardware o preso in giro?

 

si inietti audio e grafica da properties, poi non serve fare la stessa cosa in devices --> audio e graphics --> ig-platform-id + inject intel flaggato

 

poi per hack_info non intendo l'app di headkaze, clicca sul FAQ e supporto che ho in firma che poi capirai meglio

Link to post
Share on other sites
  • Support Team

questa è la tua mobo

https://www.asrock.com/mb/Intel/Z370M-ITXac/index.asp

 

nell'audio hai iniettato layout 1 e poi 99 in properties.... vediamo che codec hai:

 

[TABLE=width: 710]

[TR=bgcolor: #F6F8FA]

[TD]Realtek[/TD]

[TD]ALC892[/TD]

[TD]0x100302, layout 1, 2, 3, 4, 5, 7, 12, 15, 16, 17, 18, 28, 31, 90, 92, 97, 99[/TD]

[/TR]

[/TABLE]

 

 

OK bene anche 99

 

l'USBports.kext che hai creato con HT hai impostato 18 porte, vedi di rifarlo meglio

 

prova su pendrive questa EFI

EFI.zip

Link to post
Share on other sites

Si infatti non è proprio tutta farina del mio sacco, non sono affatto competente in materia, ho scaricato la efi da un'utente che aveva il mio stesso hardware qualche altra modifica l'ho fatta io.

Ok provo la tua efi vediamo che succede.

Link to post
Share on other sites
  • Support Team

ma ovviamente la cartella l'ho eliminata perché non mi serve, e per tenere i file che girano sul forum più leggeri tralasciando il superfluo, ma poi se vuoi avviare windows la devi rimettere in EFI nel tuo hack.. questa cosa mi pareva talmente banale che ho omesso di menzionarla... a parte il problema dello stop, questa EFI è molto migliorativa rispetto alla precedente, se guardi il config e il contenuto dei fil medesimi, te ne accorgi da solo, quindi dopo un periodo iniziale di test la puoi anche usare continuativamente...

 

avvia con questa EFI e fai il famoso hack_info che avevo richiesto

Link to post
Share on other sites
  • Support Team

@Rosarioxx da hack_info si vede che:

 

aggiorna il driver intelmausi, puoi usare l'ultima release di Mieze

 

hai 2 applicativi con relativi kext che fanno la stessa roba.... mi riferisco a paragon e tuxera, scegli quello che preferisci e rimuovi l'altro

 

Schermata 2019-11-09 alle 17.47.14.png

 

poi se ricordo, l'USBPorts.kext che hai non è stato creato correttamente, posta ioreg che vediamo quante porte USB hai

 

PS: per ora non importa ioreg, sei oltre il limite porte imposto da apple

Schermata 2019-11-09 alle 17.51.38.png

 

secondo me è meglio che fai così:

 

togli USBPorts e metti USBInjectall + port limit patch

 

avviii ioreg e HT ed inserisci ed espelli da tutte le porte pendrive USB 2 e 3

 

salvi l'output di ioreg + elimini tutte le porte inutilizzate da HD ed esporti

 

poi vediamo che salta fuori

Edited by iCanaro
Link to post
Share on other sites

@foskvs Non utilizzo chiavetta Wfi è integrata alla mobo.

@iCanaro

il kextintelmausi mi pare si riferisca alla seconda lan per questo non ho dato molta importanza, tuxera e paragon sono due applicativi che non svolgono la stessa funzione (non è paragon ntfs per capirci). Appena ho 2 minuti provo a sistemare le usb, ma non credo che sia quello che manda in kernel panik, perchè con la versione precedente di catalina non ho avuto problemi.

Edited by Rosarioxx
Link to post
Share on other sites

Allora ho provato ad effettuare il porting usb ma non ho ancora finito, ho collegato e scollegato le usb 2.0 3.0, salvato il log di ioreg che ho allegato, poi tramite HT ho eliminato le porte non utilizzate, e salvato i 3 file di esportazione nella cartella allegata. Ora che faccio?

usb porting 2.zip

Link to post
Share on other sites
  • Supervisor.

Fossi in te, le mapperei seguendo la guida. Avrai un solo file e ti funzionerà anche con versioni future di macOS.

 

---------- Post Merged at 08:40 PM ----------

 

L'ioreg con la mappatura c'è già, quindi allega le tabelle originali come da guida, o, se vuoi, prova tu.

Link to post
Share on other sites

Allora ragazzi ho provato a rimappare le porte usb con il metodo consigliato da @foskvs, esattamene con il secondo metodo, ma qualcosa è andato storto e non mi ha rimosso le usb, quindi ho pensato di vincere facile e usare i file di hakintool, così ha funzionato. Ma il problema del kernel panic dopo lo sleep  non è stato risolto, cosa mi consigliate a questo punto?

Schermata 2019-11-13 alle 12.11.01.png

Schermata 2019-11-13 alle 12.10.12.png

Link to post
Share on other sites
  • Support Team

certo che AppleHDA ti faccia andare il KP dopo lo stop, è strana, ma sono hack.... cose strane se ne vedono....

 

se hai voglia di fare alcune prove, ti posso elencare che mi è venuto in mente... se hai voglia 🙂 @Rosarioxx

Link to post
Share on other sites
  • Support Team

ti posto cmq quello che mi è venuto in mente, la SADAE è sempre dietro l'angolo 😱🤣

 

1) metti AppleALC compilato ora, così siamo sicuri di usare quello più recente

2) metti i flag a reset HDA come già consigliato poi se ancora non ci siamo flagga anche AFGLoowPowerState

 

fai un paio di riavvii e poi vedi se ha funzionato o meno...

3) se ancora non ci siamo prova cambiando il layout, non ricordo se usi 1 o il 7 comunque sia prova a cambiarli

4) siamo con l'acqua alla gola... prova a inserire codeccommander nei kext in EFI 

 

CF --> 🤞

AppleALC.kext_15_11_1138.zip

Link to post
Share on other sites

Grazie per l'aiuto.. Cercando in giro tra i forum, ho potuto constatare che è un problema dell'audio hdmi, se si riesce a disattivare solo quello non da problemi, nel frattempo ho optato per l'opzione più semplice in attesa del nuovo aggiornamento, ho fatto un downgrade a 10.15 così funziona tutto.

Edited by Rosarioxx
Link to post
Share on other sites
  • iCanaro changed the title to Kernel panic dopo stop + black screen con 15.4

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.