TRIAL/DUAL BOOT a EFI Separate

Rispondi
Avatar utente
Non connesso

netgear
Moderatori
Moderatori
Reactions:
Messaggi: 1777
Iscritto il: ven feb 16, 2018 10:18 pm
Grazie dati: 178 volte
Grazie ricevuti: 447 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#121

Messaggio da netgear » gio set 05, 2019 10:10 pm

Temo di non aver capito...

Avatar utente
Non connesso

XCLele72
Utente
Reactions:
Messaggi: 62
Iscritto il: mar ago 06, 2019 3:24 pm
Grazie dati: 7 volte
Grazie ricevuti: 3 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#122

Messaggio da XCLele72 » gio set 05, 2019 10:20 pm

QUI hai scritto quello che dovevo fare e che ho quotato nel messaggio precedente...

EDIT:
al vediamo che fà ti rispondo che il sistema è partito al primo avvio (e dal quale sto scrivendo ora) ma non ho ancora riavviato perchè vorrei capire meglio cosa ho fatto seguendo il tuo consiglio...
O meglio, credo di aver capito ma non ne sono sicuro...
Case: Thermaltake View22 TG - PSU: Sharkoon Silent Storm Cool Zero 750w Plus Gold - Scheda madre: Asus Prime Z390-A CPU: Intel i5 9600K @3700mhz - Cooler: Corsair H45 - Ram: 16GB Vengeance 3000Mhz - Scheda Video: MSI Radeon RX Vega 56 - Hard Disk: Kingdian S280 240Gb - Hard Disk: Silicon Power SSD PCIe M.2 NVMe 512GB Gen3x4 (da installare presto)

Avatar utente
Non connesso

netgear
Moderatori
Moderatori
Reactions:
Messaggi: 1777
Iscritto il: ven feb 16, 2018 10:18 pm
Grazie dati: 178 volte
Grazie ricevuti: 447 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#123

Messaggio da netgear » gio set 05, 2019 11:05 pm

Cioè si è avviato ma hai paura a riavviare...?

Avatar utente
Non connesso

XCLele72
Utente
Reactions:
Messaggi: 62
Iscritto il: mar ago 06, 2019 3:24 pm
Grazie dati: 7 volte
Grazie ricevuti: 3 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#124

Messaggio da XCLele72 » ven set 06, 2019 12:01 am

Avevo, si. Poi l'ho fatto :-)
E a parte qualche piccolo problemino funziona anche riavviando.

Ma non capisco perchè, mi spiego meglio:

se così facendo abbiamo caricato dalla cartella efi di ripristino il file per il ripristino del sistema e gli abbiamo fatto credere di dover partire da quello...come mai non tenta un ripristino ad ogni riavvio?
Perchè un conto (credo) è quando qualcosa non va e automaticamente W10 va a prendere il file dentro EFI/recovery ecc...ecc...e un conto è avere sempre lo stesso file (avendolo sovrascritto a quello dentro EFI/boot ecc...ecc.. sono uguali)

dove sbaglio?
Case: Thermaltake View22 TG - PSU: Sharkoon Silent Storm Cool Zero 750w Plus Gold - Scheda madre: Asus Prime Z390-A CPU: Intel i5 9600K @3700mhz - Cooler: Corsair H45 - Ram: 16GB Vengeance 3000Mhz - Scheda Video: MSI Radeon RX Vega 56 - Hard Disk: Kingdian S280 240Gb - Hard Disk: Silicon Power SSD PCIe M.2 NVMe 512GB Gen3x4 (da installare presto)

Avatar utente
Non connesso

netgear
Moderatori
Moderatori
Reactions:
Messaggi: 1777
Iscritto il: ven feb 16, 2018 10:18 pm
Grazie dati: 178 volte
Grazie ricevuti: 447 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#125

Messaggio da netgear » ven set 06, 2019 7:17 am

Non carichiamo la partizione di ripristino, gli abbiamo solo detto dove si trova.

Avatar utente
Non connesso

XCLele72
Utente
Reactions:
Messaggi: 62
Iscritto il: mar ago 06, 2019 3:24 pm
Grazie dati: 7 volte
Grazie ricevuti: 3 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#126

Messaggio da XCLele72 » ven set 06, 2019 11:42 am

Ah ecco, grazie del chiarimento.
Ora posso andare avanti... :-)
Case: Thermaltake View22 TG - PSU: Sharkoon Silent Storm Cool Zero 750w Plus Gold - Scheda madre: Asus Prime Z390-A CPU: Intel i5 9600K @3700mhz - Cooler: Corsair H45 - Ram: 16GB Vengeance 3000Mhz - Scheda Video: MSI Radeon RX Vega 56 - Hard Disk: Kingdian S280 240Gb - Hard Disk: Silicon Power SSD PCIe M.2 NVMe 512GB Gen3x4 (da installare presto)

Avatar utente
Non connesso

XCLele72
Utente
Reactions:
Messaggi: 62
Iscritto il: mar ago 06, 2019 3:24 pm
Grazie dati: 7 volte
Grazie ricevuti: 3 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#127

Messaggio da XCLele72 » mar set 10, 2019 7:49 pm

Ciao a tutti,
piccolo aggiornamento della mia situazione

Sono riuscito a trasferire con successo sia Windows che macOS su ssd ed ho i due sistemi perfettamente funzionanti.
Ho fatto alcune prove usando lo stesso procedimento (clonazione) con successo anche con Ubuntu sulla macchina con MBR (con l'aiuto di Supergrub2, che mi ha dato accesso alla distro per poter reinstallare grub2 visto che lo avevo su un disco diverso).
Con quella UEFI Ubuntu non vuol saperne di partire...

Ora, @netgear mi hai suggerito di provare a lavorare da una live e sono pronto a seguirti.
Dal wiki di ubuntu mi sembra di aver capito che le cose importanti siano:
avere la partizione EFI in fat32;
utilizzare grub-efi (ma non ho capito come potrei installarlo senza accedere alla distro)
modificare fstab puntando il boot su /EFI/Boot
presenza della cartella /sys/firmware/efi (se non c'è la creo dalla live?)

Sbaglio?
Mi aiuti?

Grazie
Case: Thermaltake View22 TG - PSU: Sharkoon Silent Storm Cool Zero 750w Plus Gold - Scheda madre: Asus Prime Z390-A CPU: Intel i5 9600K @3700mhz - Cooler: Corsair H45 - Ram: 16GB Vengeance 3000Mhz - Scheda Video: MSI Radeon RX Vega 56 - Hard Disk: Kingdian S280 240Gb - Hard Disk: Silicon Power SSD PCIe M.2 NVMe 512GB Gen3x4 (da installare presto)

Avatar utente
Connesso

iCanaro
Support Team
Support Team
Reactions:
Messaggi: 7080
Iscritto il: ven feb 16, 2018 8:41 pm
Località: Bologna & Dintorni
Grazie dati: 1199 volte
Grazie ricevuti: 2115 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#128

Messaggio da iCanaro » mar set 10, 2019 8:00 pm

la partizione EFI in FAT32 già l'hai, altrimenti come faresti ad avviare macOS con Clover?

io non so bene che distro usi, con mageia avvii da live USB scegli ripristina GRUB

altrimenti, visto che se usi linux lo dovresti ben sapere, che la partizione Utente è separata da quella di sistema, quindi dopo aver clonato tutto, avvii per una nuova installazione, formatti poi le partizioni tranne quella utente (home) poi quando richiesto immetti stesso nome utente e stessa password, alla fine accedi a tutti i tuoi dati, dovrai solo reinstallare le applicazioni
My HackFAQ & Support USB InstallerMacOSUpdater OC guida Temi
► Mostra testo

Avatar utente
Non connesso

XCLele72
Utente
Reactions:
Messaggi: 62
Iscritto il: mar ago 06, 2019 3:24 pm
Grazie dati: 7 volte
Grazie ricevuti: 3 volte

Re: TRIAL/DUAL BOOT a EFI Separate

#129

Messaggio da XCLele72 » mar set 10, 2019 10:50 pm

Sono su dischi separati...ogni disco ha la sua partizione EFI in fat32.
Clover parte dal disco dove è installato macOS (clonato da disco meccanico su ssd UEFI);
Windows parte dal suo disco (clonato da ssd MBR su disco meccanico MBR poi riclonato e convertito GPT su ssd)
Ubuntu sono riuscito a clonarlo e mbr su mbr funziona ma vorrei riuscire a clonarlo UEFI e farlo partire proprio per evitare di reinstallare (tutte) le applicazioni... (ovviamente so che le partizioni utente/sistema sono separate esattamente come so che ci sono applicazioni che fanno ciò che dici in maniera semplicissima ma non è ciò che mi serve al momento...)

EDIT
per essere più precisi sto tentando di aggiornare grub con questa guida ma ad un certo punto il sistema live mi dice che non posso montare / e quindi sono punto e daccapo...
Case: Thermaltake View22 TG - PSU: Sharkoon Silent Storm Cool Zero 750w Plus Gold - Scheda madre: Asus Prime Z390-A CPU: Intel i5 9600K @3700mhz - Cooler: Corsair H45 - Ram: 16GB Vengeance 3000Mhz - Scheda Video: MSI Radeon RX Vega 56 - Hard Disk: Kingdian S280 240Gb - Hard Disk: Silicon Power SSD PCIe M.2 NVMe 512GB Gen3x4 (da installare presto)

Rispondi

Torna a “[Guide] "Trick&Tips"”