Jump to content

Asus Rog Strix z590-e + i9 11900K + 6900xt (come si crea un "Hachintosh"?)


Recommended Posts

Buon pomeriggio, finalmente mi sono deciso: voglio un hackintosh. Ma so poco e niente su come configurarlo. al momento sono riuscito solo ad installare Monterey. Non ho idea di come configurare le usb, il wifi, il bluetooth e via dicendo. 

Qualcuno può darmi gentilmente una mano?  Massimiliano

Link to post
Share on other sites

Bella macchinina, per come vanno le cose da un paio di settimane a questa parte tuttavia avrei osato di Alder Lake, vanno meglio anche del mio Ryzen 5950x ahimè sotto macOS ^^

Link to post
Share on other sites
  • Supervisor

ciao @emmegi2001

benvenuto prima di tutto

leggi un po' nel forum e vedi quello che puo' servire agli altri per darti una mano:

Se ti e' possibile metti nella tua firma la tua configurazione hardware

ho spostato il tuo thread in una sezione piu' appropriata

Poi se vuoi posta la EFI che stai utilizzando (se presa da siti Brasiliani rifalla che qui non si da supporto a quei prodotti)

Comunque se ti parte e' già un buon punto 🙂

 

Edited by fabiosun
Link to post
Share on other sites
16 minutes ago, emmegi2001 said:

Va bene, fatto.  Sì, parte e "qualche" Usb funziona ma niente Bluetooth o WiFi. (la MB ha la intel AX210 per il BT e WiFi) e sicuramente le prestazioni non sono ottimizzate.

Ecco la mia EFI.EFI - Massimiliano.zip

 

Certamente ti aiutiamooo, benvenuto

Link to post
Share on other sites

Te lo spiego volentieri:

Le EFI che ho trovato qui purtroppo non fanno neanche partire il mio HW. Ne ho scaricata una altrove che non attiva il 100% delle risorse HW ma almeno l'ha fatto partire e posso andare avanti con il mio lavoro. Nel frattempo ho per l'appunto chiesto supporto proprio qui per cucinare una EFI ad hoc

Edited by emmegi2001
Link to post
Share on other sites
  • Supervisor
9 hours ago, emmegi2001 said:

Te lo spiego volentieri:

Le EFI che ho trovato qui purtroppo non fanno neanche partire il mio HW. Ne ho scaricata una altrove che non attiva il 100% delle risorse HW ma almeno l'ha fatto partire e posso andare avanti con il mio lavoro. Nel frattempo ho per l'appunto chiesto supporto proprio qui per cucinare una EFI ad hoc

Ciao , la tua EFI ti avrà pure fatto partire, ma ' una EFI che al suo interno ha almeno diversi kext di rete che tu non hai come hardware

E' la EFI generica di un noto sito che frega lavori altrui...

in particolare se controlli il tuo SSDT c'e' una sezione che il nostro admin Gengik84 aveva prodotto tempo fa e fornito al team di acidanthera

 

Questo SSDT e' parte integrante di un SSDT che trovi nella nostra area download (SSDT basic 2.1)

 

Ripeto, la tua EFI serve per poi ricevere birre a chi l'ha fornita tramite donazioni paypal

 

Noi dello staff, non supportiamo quel sito poiche' hackintosh e' libertà e gratis 🙂

 

Non forniamo mai (o quasi mai) inizialmente EFI prefatte, speriamo che l'utente ne produca una da se con i metodi documentati nel nostro sito

Per poi aiutarlo a portare a termine e affinare al meglio la sua EFI

 

Se hai voglia di farlo troverai qui tutto cio' che ti serve

 

Di nuovo benvenuto

Edited by fabiosun
aggiunto link a SSDT basic
Link to post
Share on other sites

Buongiorno, non solo ho voglia di farlo ma ti dico che fondamentalmente non sono una persona polemica e mi spiace che ne sia nata una anche se di piccola entità. Non avevo idea di questi retroscena riguardo l'ambiente Hackintosh. Ho zero cultura riguardo la programmazione a tal punto che per per la mia concezione becera, la EFI è una cartella che contiene files che opportunamente posizionata fa miracolosamente partire (o blocca) un hackintosh. 

Questo per dire che non ho idea di cosa sia o a cosa serva un SSDT e di conseguenza non ho idea di come procedere con i tre SSDT che mi hai gentilmente allegato.

Prima di utilizzare l'EFI "incriminata", come ti dicevo, ho provato a scaricarne una qui su un blog macos86 ma non ha fatto al caso mio. Allora ho scaricato sempre da qui il tool OC EFI Maker per realizzarne una ma una volta creata e messa nella partizione, è andata anche peggio di prima. Purtroppo le mie conoscenze stanno a zero per cui credo che oltre ad un più che apprezzato benvenuto mi serva una gran bella forte mano (se possibile).

(ho allegato la EFI appena ricreata con il maker rispondendo N al boot legacy e N al filevault) Come devo procedere e/o dove esattamente devo andare a leggere "come fare" qui tra le pagine qui dedicate?

e... a questo punto, grazie per la pazienza 🙂

EFI da oc maker.zip

Link to post
Share on other sites
  • Supervisor

Ciao, nessuna polemica da parte mia, ti ho solo spiegato la "policy" del sito e detto alcune cose in quanto per tua stessa ammissione sei un neofita del mondo HAckintosh

 

ora un aiuto piu' concreto.

 

OC EFI Maker e' uno strumento che consente la creazione di una EFI base, ma senza nessun tipo di personalizzazione per la propria configurazione

Devi scaricarti un Plist editor e modificare il sample.plist di conseguenza

 

Ad esempio puoi copiare nella cartella ACPI il file SSDT basic2.1 che e' ottimizzato per la tua piastra madre

Non basta solo la copia, va anche dichiarato nella sezione ACPI del sample.plist

 

Il consiglio e' di prendere il config.plist che hai ora, aprirlo e vedere come sono fatte le dichiarazioni

riproporle (non tutte) nel sample.plist

Rinominare il sample.plist in config.plist e poi provare a vedere che accade

Sicuramente all'inizio non ti partirà ma piano piano sistemerai tutto avrai un hackintosh calibrato per la tua macchina (a proposito complimenti, bel PC)

 

Poi, se hai meno pazienza, puoi provare il tool OCAT (sul sito trovi una guida preparata da @antuneddu) ed un thread dove si discute

Ottima app che ha all'interno un database Di EFI dal quale partire...

Insomma basta avere pazienza..

 

  • +1 1
Link to post
Share on other sites

Sì penso che OCAT faccia al caso tuo perché studiare tutto OC da zero è abbastanza impegnativo imho, anche se prima o poi va fatto se vuoi un Hackintosh "perfetto"

Link to post
Share on other sites

Dunque, ho seguito il consiglio di Tomnic, scaricato OCAT e creato una EFI partendo dal database per 11th Gen iMac 7.1.  Poi come ha suggerito Fabiosun, ho aggiunto SSDT-Basic (2.1)  e l'ho dichiarato nella lista ACPI. Ma già non ho idea se partendo da un database, questa aggiunta è utile, inutile o addirittura rischio qualche conflitto. Tra qualche minuto testo il pc e vi faccio sapere com'è andato il prima avvio con questa EFI da database con OCAT. (Intanto vi ringrazio ancora per la disponibilità)

Link to post
Share on other sites

Prova con questo config almeno vediamo dove si blocca 😉

Ho attivato il verbose che significa che vedrai a schermo ben scritto cosa sta tentando di fare macOS, posta foto!

 

P.s.: prova ad applicare SSDT-basic da solo inoltre, su suggerimento di @fabiosun

Config.plist.zip

Link to post
Share on other sites
  • Supervisor

Io ti avevo suggerito di usare ssdt basic nella tua vecchia efi al posto del ssdt che c’era li

cmq vedi dove si ferma

le efi di OCAT non sono tutte valide 

🤞

Link to post
Share on other sites

In alternativa ho pronta l'EFI che ti faceva partire il sistema "ripulita" e con SSDT-basic attivo come dice Fabio, aggiornaci appena puoi, da un verso o da un altro devi bootare😉 

EFI - Max ripulita.zip

2 minutes ago, emmegi2001 said:

ok, ecco la foto20220116_202912_resized.thumb.jpg.dfe619114f032d20fe5f62d85cf142d4.jpg

 

Se si blocca lì pare un problema del controller nvme, prova la EFI che ti ho postato sopra che include il driver che lo dovrebbe fixare

Link to post
Share on other sites

C'è stata una netta miglioria: ora mi porta fino alla schermata di accesso di Monterey ma non posso inserire la password d'accesso perchè non funzionano più le USB. Ho provato a mettere ovunque l'antenna USB di tastiera e mouse ma non fungono 

Link to post
Share on other sites

ottimo! Ora alcune USB funzionano e sono riuscito ad entrare. Audio funziona via DP port del monitor (ma non mi fa regolare il livello), wifi non rilevato e bluetooth non rilevato.

  • +1 1
Link to post
Share on other sites
  • Supervisor

Il volume non c’è in dp e hdmi

le usb vanno mappate

 audio interno da verificare e scheda di rete anche

per Wi-Fi e bt servono dei kext se usi quello integrati 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.