Jump to content

Upgrade Ram genera freeazing al loop


Recommended Posts

Salve,

in preparazione all'aggiornamento di sistema che vorrei fare per passare a monterey ho acquistato 2 nuovi banchetti di ram da 16GB l'uno da aggiungere al già presente banchetto da altrettanti 16GB.

Inutile dirvi che salvo imbrogli, i banchetti sono tutti e tre identici per marca,cicli e Mhz.

Bene......se li metto tutti e 3 il sistema arriva al logo della mela e li rimane.

Dopo svariati tentativi ho scoperto che con 2 banchetti, se pur inizialmente con qualche difficoltà, il sistema parte lo stesso e la rasm viene correttamente visualizzata.

Qualcuno ha idea cosa dovrei cercare o che soluzione dover adottare per farli funzionare tutti e tre ?

Io ho smanettato un po' con l'smbios, dichiarando gli slot, la frequenta e il tipo attraverso clover configurator ma nulla da fare. Tra l'altro per le mie modestissime conoscenze so che impostare quei dati è forse una questione più di facciata, per vedere le cose corrette nelle info di sistema ma che hanno poca valenza dal punto di vista dell'operatività del sistema stesso.

Ho anche pensato che le mie conoscenze siano così scarse da non avermi fatto pensare che magari per lavorare bene devo necessariamente avere tutti e 4 gli slot occupati, e che quindi 3 banchetti non possano funzionare, ma vado a tentoni nel buio, sono solo mie ipotesi.

 

Avreste qualche dritta?

Grazie in anticipo

 

Link to post
Share on other sites
10 minuti fa, Fasullo ha scritto:

Non ci metterei la mano sul fuoco ma credo che il problema sia il fatto che la apple non ha banchetti dispari

Concordo, ti consiglio in ogni caso di passare ad OpenCore e di smettere di usare Clover che ormai siamo nel 2022 e non più nel 2018... @Madsex

Link to post
Share on other sites

Ciao,

quindi compro unaltro banchetto e vedo se va. Esistono comunque delle cose da fare per un aggiornamento ram o di norma le aggiungi e tutto procede ?

 

@damiandrake quando ho creato la mia macchina era il 2020, la guida che ho seguito era su clover e, magari perchè si capiva che non sono ferratissimo, nessuno mi ha suggerito opencore che ancora veniva visto come una novità.

Approfitto per chiedere cosa posso seguire, come guida o roba simile per passare da clover a opencore e che migliorie visibili porta ? Considerando che all'epoca mi fu data una mano da Gengik per il DSDT (che custodisco tipo reliquia perchè non saprei fare da solo).

 

Grazie in anticipo

Link to post
Share on other sites

Cmq a prescindere mai dispari...i banchi di ram per essere usati dalla piastra madre al meglio delle loro possibilità e senza incasinarsi sempre in coppia , 2 / 4.

Anche sotto win .

Edited by Giaccaz
Link to post
Share on other sites
2 ore fa, Madsex ha scritto:

Ciao,

quindi compro unaltro banchetto e vedo se va. Esistono comunque delle cose da fare per un aggiornamento ram o di norma le aggiungi e tutto procede ?

 

@damiandrake quando ho creato la mia macchina era il 2020, la guida che ho seguito era su clover e, magari perchè si capiva che non sono ferratissimo, nessuno mi ha suggerito opencore che ancora veniva visto come una novità.

Approfitto per chiedere cosa posso seguire, come guida o roba simile per passare da clover a opencore e che migliorie visibili porta ? Considerando che all'epoca mi fu data una mano da Gengik per il DSDT (che custodisco tipo reliquia perchè non saprei fare da solo).

 

Grazie in anticipo

Ciao, allora di norma le aggiungi e tutto dovrebbe andare normalmente senza toccare nulla a livello software

Per OC puoi iniziare studiando da qui (c'è sia "teoria" sia tutorial veri e propri su come iniziare per creare una EFI funzionante nel 99% dei casi) https://dortania.github.io/
OC a differenza di Clover è molto più pulito e "più vicino" alla sequenza di avvio di un Mac vero e proprio, inoltre, usa gli SSDT* e non i DSDT custom

*Per iniziare puoi usare gli SSDT Prebuilt che trovi nello zip di OpenCore (usa tranquillamente la versione release)

Edited by damiandrake
Link to post
Share on other sites
  • Supervisor

@Giaccaznon sempre e' cosi

dipende dal chipset e dai canali supportati

doppio triplo o quadruplo..e anche piu' in alcuni casi

cmq il problema dell'utente non e' relativo a questo come già avete detto

se non e' un banco di memoria potrebbe essere uno slot

in alcuni casi anche la cpu reagisce male se ha dei problemi nella gestione delle memorie al suo interno

 

pS

ho 8 moduli installati

se ne tolgo uno tutto funziona di conseguenza bene senza pero' 32Gb dei totali 256

 

poi concordo che e' meglio seguire le specifiche

ma le memorie su diverse piastre possono anche essere montate non seguendo lo schema consigliato

di solito, io che ne uso tanta, faccio un test su ogni slot con ogni singolo banco

poi..se tutto va come penso che sia giusto...le monto tutte

 

Link to post
Share on other sites

io farei una prova ulteriore, su slot 1 e 3 accendi il pc, intanto vai nella bios e imposta

support 2933/2800/2666/2400/2133 natively, come dice la casa 

poi riavvii e spegni, poi metti altri 2 banchi su slot 2/4 riaccendi e vedi.

 

ps: fai sempre molta attenzione a montare i banchetti, a volte sembra che siano in sede ma non fino in fondo

e prima di montare, dai sempre una pulita, basta del pulviscolo che le ram facciano le bizze, ()con aria compressa sarebbe ideale

 

Link to post
Share on other sites

Controlla anche che il dissipatore abbia pressione uniforme sul socket della cpu, alle volte se lo stringi troppo da una parte e poco da un'altra generi problemi ai canali di memoria. Semmai togli e rimetti dissipatore e CPU stando attento a non stringere esageratamente le viti e a stringerle tutte alla stessa maniera.

 

L'uso di più banchi di RAM in numero dispari abilita una modalità che si chiama asymmetric dual channel mode, prova e facci sapere 😉

 

P.s.: nel bios potresti avere opzioni per massimizzare la compatibilità delle RAM in configurazioni atipiche... prova anche ad alzare il Command Rate da 1T a 2T e/o alzare latenze e ridurre la frequenza.

  • Like 1
Link to post
Share on other sites

Ciao a tutti,

ho fatto diverse prove cercando di seguire tutti i vostri suggerimenti, di cui vi ringrazio sentitamente.

Purtroppo nulla da fare.

La sitauzione è questa.

Con 2 banchetti su 3 in mio possesso il sistema funziona, parte e i 32 GB di ram vengono correttamente caricati. Ho provato anche ad incrociare i banchetti tra loro per scongiurare che ci fosse un banchetto che non funzionava, ma tutto va se ne uso solo 2. Ho provato tutti gli slot 1/3 e 2/4 e anche qui con 2 banchetti tutto regolare. La problematica nasce quando inserisco il terzo. Con 3 arrivo al logo dell'apple e tutto finisce li, non compare nemmeno la barra di caricamento.

 

Ho giocato un po' nel bios senza spingermi tanto viste le mie scarse competenze e diciamo che la cosa più significativa che ho fatto è stata spostare la frequesnza da AUTO  a 2400Mhz. Niente da fare. con 3 banchetti non funge.

La scelta di portare a 2400Mhz è stata data da una cosa che ho notato nel bios di cui vi carico la foto:

 

IMG_0686.thumb.jpg.8fdb7b5faddd6b2d40afc36845ae1ec4.jpg

 

Come vedete dall'immagine, sembra che nonostante le ram siano a 3600Mhz il bios sembra vederle a 2400Mhz. Magari è na cazzata che dipende dalla mia ignoranza ma mi pareva strano.

Francamente non saprei come procedere, sono tentato di comprare un'altro banchetto per vedere se si sblocca la cosa ma allo stesso tempo mi pare na cavolata e mi pare di capire che non dovrebbe fare differenza se 2 o 3 o 4 banchetti vengono utilizzati.

 

Ho ovviamente fatto pulizia con aria compressa (il pc più pulito del mondo ormai) e controllato gli agganci mille volte....che poi con tutte le prove che ho fatto almeno una volta per sbaglio avrebbe dovuto funzionare.

 

Per altri settaggi consigliati, francamente non ho trovato riscontro nel bios, magari li chiama in altra maniera e io non me ne rendo conto.

 

Se avete altre idee sono tutto orecchie, anche perchè ora ho un banchetto di ram in più da 16Gb e non so che farmene......che poi ho una scheda madre che può arrivare a 128GB, così mi metto pure paura di tentare di salire ulteriormente diciamo.

 

Può essere qualche cosa che va settato dentro clover? O nell'SSDT ?

Magari c'è una sorta di blocco a 32GB e io manco lo so.

 

Grazie in anticipo a tutti come sempre.

 

Link to post
Share on other sites

intanto quel processore supporta ram fino a 2666ghz

imposta le ram cosi, poi sei al massimo con il turbo boost, mettilo a 3800/4000ghz

Anzi:

salva queste impostazioni prima, poi metti la bios di default e setta queste impostazioni

consigliate per hackintosh, le altre cose lasciale in auto

vedi asus, quindi metti il bios di default, monta le ram e setta le cose che vedi

lascia stare overclock di ram e cpu

Link to post
Share on other sites

Ciao a tutti,

ho provato al meglio delle mie capacità.

Ho resettato il bios alle impostazioni di default, ho seguito la guida (che tra l'altro è la stessa che seguii all'epoca per la prima configurazione), ho messo la terza ram e niente.

Ho poi spostato voce DRAM su 2666Mhz e riavviato. Niente.

 

Con la terza ram resta inchiodato al logo della mela senza nemmeno far partire la barra di caricamento.

 

Altre idee in merito? Perchè io proprio non ho più tentativi da testare, non so cosa poter provare.

 

Grazie in anticipo

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.