Jump to content

Opencore - Skylake - installer BS da USB


Recommended Posts

Salve a tutti, mi sto cimentando con OC e ho preparato una USB con installer di BS la EFI in allegato seguendo la guida ufficiale oc.

Ho anche fatto la validazione oc della EFI ed è ok.

Purtroppo ho i primi errori di boot che trovate nello screenshot allegato.

In particolare questo:

 

02:862 00:021 OC: Plist Kexts\Lilu.kext\Contents\Info.plist is missing for injected kext Lilu.kext (Patch engine)

 

A me risulta presente il file Info.plist è presente nel package di Lilu.kext

 

Fatemi sapere su come procedere, grazie.

 

 

Schermata 2021-11-13 alle 18.23.34.png

EFI.zip

Link to post
Share on other sites
  • Support Team

Ciao, dimentica per un attimo Clover  🙂   con OC non serve creare la sottocartella  " Other " metti i kext direttamente in OC/Kext , mettili nel plist in questo ordine AppleAlc prima di WeG, ti manca il kext di rete ( Puoi aggiungere anche dopo , come anche USBInjectAll se hai problemi con le usb )

1668502874_Schermata2021-11-14alle01_09_55.png.01c7a7e437f9b0d88c91cd0b9634308b.png

 

Come SSDT se vuoi  puoi usare SSDT-Basic ( vers.2.0 ) lo trovi in download ( rimuovi i 2 attuali anche dal plist ) 

Nel plist in ACPI > Quirks > ResetLogoStatus = NO

Link to post
Share on other sites
9 ore fa, antuneddu ha scritto:

Ciao, dimentica per un attimo Clover  🙂   con OC non serve creare la sottocartella  " Other " metti i kext direttamente in OC/Kext , mettili nel plist in questo ordine AppleAlc prima di WeG, ti manca il kext di rete ( Puoi aggiungere anche dopo , come anche USBInjectAll se hai problemi con le usb )

1668502874_Schermata2021-11-14alle01_09_55.png.01c7a7e437f9b0d88c91cd0b9634308b.png

 

Come SSDT se vuoi  puoi usare SSDT-Basic ( vers.2.0 ) lo trovi in download ( rimuovi i 2 attuali anche dal plist ) 

Nel plist in ACPI > Quirks > ResetLogoStatus = NO

 

Ok grazie procedo solo una cosa posso chiederti quale app utilizzi per la compilazione del plist ?

 

Quale kext di rete dovrei mettere?

 

Ho fatto la validazione del plist e mi da questi errori

 

OCS: Missing key PointerSpeedDiv, context <AppleInput>!

OCS: No schema for PointerSpeedDiv at 0 index, context <Audio>!

Serialisation returns 2 errors!

 

Cosa dovrei modificare?

OC.zip

Edited by iovlui
Link to post
Share on other sites
  • Support Team

Cerca nel Sample.plist.zip la chiave " PointerSpeedDiv " la copi e la aggiungi al tuo config stessa posizione 

Sotto la chiave  Audio rimuovi invece " PointerSpeedDiv "    rifai il check con ocvalidate

Il kext di rete quello che usavi con Clover

 

858811590_Schermata2021-11-14alle11_25_37.png.f27b65735fd1523e183acf870174f336.png

Link to post
Share on other sites
6 ore fa, antuneddu ha scritto:

Cerca nel Sample.plist.zip la chiave " PointerSpeedDiv " la copi e la aggiungi al tuo config stessa posizione 

Sotto la chiave  Audio rimuovi invece " PointerSpeedDiv "    rifai il check con ocvalidate

Il kext di rete quello che usavi con Clover

 

858811590_Schermata2021-11-14alle11_25_37.png.f27b65735fd1523e183acf870174f336.png

 

 

Ti ringrazio tutto è andato liscio.

Dovrei fare un controllo particolare alle porte USB che risultano funzionanti?

Volendo fare upgrade a Monterey da app store dovrei fare qualche modifiche al plist?

Grazie

  • +1 1
Link to post
Share on other sites
  • Support Team

Per le usb se vuoi poi fare la mappatura https://www.macos86.it/topic/9-mappatura-porte-usb/

Per l upgrade il plist va bene , anzi hai seguito bene la guida 👍  OC per mantenerlo aggiornato in seguito puoi usare OCAT anche per apportare modifiche al plist   https://www.macos86.it/topic/5238-aggiornare -opencore-e-kexts-con-ocat/?tab=comments#comment-121408

 

 

Link to post
Share on other sites
23 minuti fa, antuneddu ha scritto:

Per le usb se vuoi poi fare la mappatura https://www.macos86.it/topic/9-mappatura-porte-usb/

Per l upgrade il plist va bene , anzi hai seguito bene la guida 👍  OC per mantenerlo aggiornato in seguito puoi usare OCAT anche per apportare modifiche al plist   https://www.macos86.it/topic/5238-aggiornare -opencore-e-kexts-con-ocat/?tab=comments#comment-121408

 

 

 

 

Grazie!

 

Link to post
Share on other sites
Il 14/11/2021 at 19:28, antuneddu ha scritto:

Per le usb se vuoi poi fare la mappatura https://www.macos86.it/topic/9-mappatura-porte-usb/

Per l upgrade il plist va bene , anzi hai seguito bene la guida 👍  OC per mantenerlo aggiornato in seguito puoi usare OCAT anche per apportare modifiche al plist   https://www.macos86.it/topic/5238-aggiornare -opencore-e-kexts-con-ocat/?tab=comments#comment-121408

 

 

 

 

Ciao una volta alla settimana c'è l'EFI Check Dump si può disabilitare?

 

 

Link to post
Share on other sites
54 minuti fa, antuneddu ha scritto:

??? 

 

 

Praticamente è un check sul firmware che parte una volta a settimana e a me da finestra con errore con l'invito ad inviare ad Apple...

ovviamente io chiudo la finestra e faccio finta di nulla ma volevo sapere se in qualche modo si può risolvere.

Grazie

 

 

"La nuova utility eficheck, che si trova in /usr/libexec/firmwarecheckers/eficheck, viene eseguita automaticamente una volta alla settimana. Controlla il firmware del Mac rispetto al database di Apple di ciò che è noto per essere corretto. Se passa, non vedrai nulla di ciò, ma se ci sono discrepanze, sarai invitato a inviare una segnalazione ad Apple."

 

https://discussions.apple.com/thread/250310046

 

 

Edited by iovlui
Link to post
Share on other sites
21 ore fa, antuneddu ha scritto:

??? 

 

 

Potrebbe essere la mancanza della cartella Apple nella EFI ?

Quando ho installato Big Sur su SSD formattato non ho trovato alcuna cartella Apple nella EFI ma ricordo che in Catalina c'era.

In tal caso come dovrei procedere?

 

Link to post
Share on other sites
  • Supervisor

molto probabilmente e' sbagliato qualcosa nel tuo SMBios all'interno nel config

personalmente non conoscevo nemmeno quel check settimanale

 

Link to post
Share on other sites
  • Support Team

si infatti idem,  potrebbe essere qualche software non gradito o kext ... leggendo in giro , come anche FW Version: obsoleto 

proverei a generare un nuovo smbios ( stesso dell attuale in uso , presumo iMac17,1 ) e rimettere poi gli stessi seriali 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.