Jump to content

Matlab 2021b fixes for AMD based Hackintosh


Recommended Posts

The fix is divided in two parts, as a prerequisite disable SIP for now:

 

1. Fix the installer

A. Download pacifist https://www.charlessoft.com/cgi-bin/pacifist_download.cgi?vers=3.6.2&type=zip install it and after mounting the matlab_R2021b_maci64.dmg go inside the icon InstallForMacOSX.app -> Show package contents -> Contents -> MacOS, open InstallForMacOSX with Pacifist;

B. Drag the InstallForMacOSX root folder to your desktop and rename it to InstallForMacOSX;

C. Overwrite the two files libtbb.dylib and libtbbmalloc.dylib inside Desktop -> InstallForMacOSX -> bin -> maci64 with my two patched revisions attached here;

D. Launch InstallForMacOSX.app inside your extracted desktop InstallForMacOSX folder and install whatever component you want.

 

2. Fix the actual installed app

A. Go inside your Applications folder -> MATLAB_R2021b.app -> sys -> os -> maci64 and replace the libiomp5.dylib with my patched revision attached here;

B. Again go inside the Application folder -> MATLAB_R2021b.app -> bin -> maci64 and replace libtbb.dylib, libtbbmalloc.dylib, mkl.dylib, blas.spec and lapack.spec too;

 

Launch MATLAB_R2021b.app and issue the command t=bench to execute a functional test and a benchmark for the most common functions.

 

Feel free to post your screenshots here for comparison, this is mine:

 

ML.thumb.png.b13ec51c8072e5e62e79fbdcf3f4cc18.png

 

Notes:

 

1. The patched libs are the original libs supplied with this particular version of Matlab but patched to only redirect properly the Intel Fastmem / Fastmemcpy routines on AMD Hackintoshes and to mimic a "true" Intel CPU;

2. The new fixes make this function perfectly working, even when A is a 3x3 matrix: 

 

[Q, T] = schur(A);

 

 libtbb.dylib.zipblas.spec.zipmkl.dylib.ziplibiomp5.dylib.ziplibtbbmalloc.dylib.zip

lapack.spec.zip

  • Like 1
Link to post
Share on other sites

@tomnic I can start the installer, but once I enter the license key number, it gives an error that the installer is run (using File Installation Key), saying "Unable to locate the required files. To use a File Installation Key, you must run the installer from a directory that contains the installation files." 

 

Are you installing using an e-mail and password rather than installation file?

Link to post
Share on other sites
11 hours ago, Jaidy said:

does it work for 2021a?

 

I'll post its patched files in another thread

6 hours ago, Jaidy said:

@tomnic I can start the installer, but once I enter the license key number, it gives an error that the installer is run (using File Installation Key), saying "Unable to locate the required files. To use a File Installation Key, you must run the installer from a directory that contains the installation files." 

 

Are you installing using an e-mail and password rather than installation file?

 

Trial with email and password

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

@fabiosun

 

Does anyone have got a clue what may be going on with my scores? This is 64x 4.0GHz @ 1.2V, 128GB DDR4-3600C16, tested stable and scores ~62-65K CB23 (macOS vs. Windows).

 

It seems FFT and 2-D aren't scoring great.

 

I didn't see proper power draw either in the AMD app (excpecting ~330W instead of ~150W).

Screenshot 2021-11-23 at 18.56.17.png

Link to post
Share on other sites

@fabiosun

 

I applied all patches in order to get it running. I re-applied patches just to make sure since you asked, but no difference. I ran it multiple times, also after restarts. Getting consistent scores:

 

 

    LU             FTT           ODE          Sparse       2-D          3-D    

    0.1440    1.1058    0.3241    0.4290    0.2912    0.1954

    0.1385    1.1485    0.3212    0.4314    0.2897    0.2252

    0.1392    1.1248    0.3326    0.4283    0.2882    0.2050

    0.1386    1.1351    0.3186    0.4245    0.2806    0.1924

    0.1389    1.0581    0.3295    0.4331    0.2833    0.2006

    0.1396    1.1424    0.3208    0.4263    0.2829    0.2023

    0.1388    1.1568    0.3225    0.4290    0.2827    0.1989

 

I assume the massive score loss is in the 0.1x factor of FFT score compared to the stock 3970X. 2-D and 3-D could potentially do better, looking at others, but it may be due to higher single-core clock speeds.

Edited by Allubz
  • +1 1
Link to post
Share on other sites
On 11/23/2021 at 9:25 PM, Allubz said:

@fabiosun

 

I applied all patches in order to get it running. I re-applied patches just to make sure since you asked, but no difference. I ran it multiple times, also after restarts. Getting consistent scores:

 

 

    LU             FTT           ODE          Sparse       2-D          3-D    

    0.1440    1.1058    0.3241    0.4290    0.2912    0.1954

    0.1385    1.1485    0.3212    0.4314    0.2897    0.2252

    0.1392    1.1248    0.3326    0.4283    0.2882    0.2050

    0.1386    1.1351    0.3186    0.4245    0.2806    0.1924

    0.1389    1.0581    0.3295    0.4331    0.2833    0.2006

    0.1396    1.1424    0.3208    0.4263    0.2829    0.2023

    0.1388    1.1568    0.3225    0.4290    0.2827    0.1989

 

I assume the massive score loss is in the 0.1x factor of FFT score compared to the stock 3970X. 2-D and 3-D could potentially do better, looking at others, but it may be due to higher single-core clock speeds.

 

If you have a resized resolution for HiDpi disable it for better 2D/3D plot results. Matlab in macOS is very IPC dependent.

  • +1 2
Link to post
Share on other sites

Hi tomnic, thanks for getting back to me.

 

I have a standard 24" 1080p which I'm testing on, without scaling or HiDpi

 

What do you mean by "IPC"? I only know this term as "increased performance (per) core", between CPU generations.

 

What strikes me as odd is that only FFT is off. When I look at what FFT encompasses, it directs to memory usage. My memory (128GB DDR4-3600 C16) is rather tight and tuned so should deliver in that regard.

Link to post
Share on other sites
3 minutes ago, Allubz said:

Hi tomnic, thanks for getting back to me.

 

I have a standard 24" 1080p which I'm testing on, without scaling or HiDpi

 

What do you mean by "IPC"? I only know this term as "increased performance (per) core", between CPU generations.

 

What strikes me as odd is that only FFT is off. When I look at what FFT encompasses, it directs to memory usage. My memory (128GB DDR4-3600 C16) is rather tight and tuned so should deliver in that regard.

 

I meant Instructions Per Cycle, proportional to Single Core performance (proportional to CPU Clock Frequency), which is not the best both on the 3990x and on the 3970x... you should try to enable PBO if possible just to run this test to see if your results are similar to those of Fabiosun.

Link to post
Share on other sites

Ah, we are basically talking the same thing, then.

 

To be fair I'm at 4GHz which is about 10% off the single core boost. I'd excpect scores within those margins, rather than a 0.1x difference. I'll try some stock and PBO settings as well and post back 🙂 In the end this machine will run 4GHz allcore, as that's the design scenario.

Link to post
Share on other sites
34 minutes ago, Allubz said:

Ah, we are basically talking the same thing, then.

 

To be fair I'm at 4GHz which is about 10% off the single core boost. I'd excpect scores within those margins, rather than a 0.1x difference. I'll try some stock and PBO settings as well and post back 🙂 In the end this machine will run 4GHz allcore, as that's the design scenario.

 

4 GHz for all the 64 cores is an absolute monster 😉 Don't mind about Matlab benchmarks! Your system rocks

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...
On 11/13/2021 at 3:20 AM, Jaidy said:

@tomnic I can start the installer, but once I enter the license key number, it gives an error that the installer is run (using File Installation Key), saying "Unable to locate the required files. To use a File Installation Key, you must run the installer from a directory that contains the installation files." 

 

Are you installing using an e-mail and password rather than installation file?

 

If you have the full dmg with all the complete licensed Matlab setup files just copy archive folder replacing the same one into the InstallForMacOSX patched installer folder and it will work.

Link to post
Share on other sites
12 hours ago, tomnic said:

 

 

thank you so much. It turns out that the only problem was having a local license file that required entering an activation key to move to installation. I used my credentials from the Mathworks website and they worked perfectly. Thanks a lot. I now have Matlab running on my machine 🙂

  • Like 1
  • +1 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.