Jump to content

Ultime configurazioni e problema opencore


Recommended Posts

Buongiorno

Sono riuscito ad installare Big Sur e nel complesso direi che va abbastanza bene però sono rimaste alcune cose da sistemare.

 

Il processore, scheda video e mappatura porte USB dovrebbero essere ok

 

Spoiler

Informazioni_su_questo_Mac.jpg.cc1b1c91ac029e52671ba7427a98e434.jpg1249658973_AccelerazioneHW.thumb.jpg.7e6f5a2ccbed48a0a4e81d038704a5b8.jpgUSB.thumb.jpg.111fd871d383ecd517fff93ab602cfca.jpg

 

I problemi invece sono questi:

 

- Quando spegno il sistema il pc si riavvia invece di rimanere spento invece, se faccio riavvia tutto ok

- La risoluzione del monitor e HDR ok però non mi fa scegliere la frequenza o la luminosità

- Prima di arrivare alla schermata di scelta del boot mi compare questo

 IMG_6225.thumb.png.697f27ce8eacc70376b3f4eb0bfefed1.png

- Il problema più grande è che se provo ad aggiornare opencore o anche semplicemente inserire un ssdt in ACPI non si avvia più rimanendo bloccato così

 IMG_6228.thumb.png.496e8bc7f50c820ec65d581c26f64630.png

 

 

Grazie in anticipo 😁

 

EFI.zip Marco’s iMac.ioreg.zip

Edited by pucc89
Link to post
Share on other sites
  • Support Team

Ciao, be con una EFI Olas 😱 

Comincerei con il cestinare gli SSDT che hai nella cartella ACPI  , puoi usare SSDT-Basic  lo trovi in dowload 

Riguardati la configurazione https://macos86.github.io/config.plist/coffee-lake.html#punto-d-inizio 

Quale vers. di OC stai usando ? Controlla il plist con ocvalidate e correggi i warnings confrontandolo con il Sample.plist (ocvalidate e Sample.plist li trovi all interno della release di OC )

Personalmente scaricherei BS da apple store( non contaminato )  , rifarei un installazione pulita 

Link to post
Share on other sites
39 minuti fa, antuneddu ha scritto:

Quale vers. di OC stai usando ?

La versione è 0.6.8

 

39 minuti fa, antuneddu ha scritto:

Comincerei con il cestinare gli SSDT che hai nella cartella ACPI  , puoi usare SSDT-Basic  lo trovi in dowload 

Niente andando a toccare gli SSDT scompare la Gui grafica di OC e rimane bloccato sulla schermata che ho allegato prima, 

forse sbaglio io qualcosa, ho fatto così:

- montato partizione

- andato in ACPI eliminato quello che c'era e messo SSDT-Basic 

- aperto OC Configurator tolto e selezionato il nuovo

config_plist_-_for_Official_OpenCore__0_7_3_Release_Configuration_.thumb.jpg.0a269bd2dcec81c40201f3f4d709b427.jpg 

 

 

 

Link to post
Share on other sites

fai come suggerito da antuneddu.

Sistema il config.plist con ocvalidate confrontandolo con Sample.plist che trovi nella cartella di Opencore/docs. Facendo cosi intanto togli tutti i warningsIMG_6225.thumb.png.697f27ce8eacc70376b3f4eb0bfefed1.png.e6bb352758136eb72dadbe84aee6dc44.png

Link to post
Share on other sites

poi il ssdt.basic sei sicuro di averlo validato nel config.plist?

Posta la tua cartella efi dopo che hai inserito il ssdt nuovo e tolto i vecchi.

Altra cosa come hai fatto a  far riconoscere a  Bigsur la nvidia ? gia che non e piu supportata .

Link to post
Share on other sites
1 minuto fa, Giaccaz ha scritto:

poi il ssdt.basic sei sicuro di averlo validato nel config.plist?

Posta la tua cartella efi dopo che hai inserito il ssdt nuovo e tolto i vecchi.

Non lo so, se per validato si intende mettere la spunta su "enable" si altro non ho fatto 😅

la efi EFI.zip

 

3 minuti fa, Giaccaz ha scritto:

Altra cosa come hai fatto a  far riconoscere a  Bigsur la nvidia ? gia che non e piu supportata .

Non credo di averla fatta riconoscere, gli ho fatto riconoscere la HD630 no?

Link to post
Share on other sites

ok...acpi e  apposto.

Hai un casino di kext, che probabilmente non ti servono.

Se ti e partito sicuramente  stai utilizzando la igpu.

Verifica andando in informazioni su questo mac/panoramica

1920998978_Schermata2021-09-13alle15_44_41.png.febd8797216896b99cd177a24ad724ec.png

 

sei sicuro che ti servono tutti quest kext?

 

216920954_Schermata2021-09-13alle15_47_19.png.a1e15bcb9087768d168f7fe4892912d7.png

 

 

 

si hai impostato il config.plist per far riconoscere igpu

 

 

Edited by Giaccaz
Link to post
Share on other sites
1 minuto fa, Giaccaz ha scritto:

ok...acpi e  apposto.

Hai un casino di kext, che probabilmente non ti servono.

Se ti e partito sicuramente sara che stai utilizzando la igpu.

Verifica andando in informazioni su questo mac/panoramica

1920998978_Schermata2021-09-13alle15_44_41.png.febd8797216896b99cd177a24ad724ec.png

 

L'ho allegata nello spoiler al primo post 

 

3 minuti fa, Giaccaz ha scritto:

 

 

sei sicuro che ti servono tutti quest kext?

 

216920954_Schermata2021-09-13alle15_47_19.png.a1e15bcb9087768d168f7fe4892912d7.png

 

no allora il wifi integrato sulla scheda madre non è supportato quindi tutto quello legato al wifi si potrebbe togliere 

come ethernet ho una scheda intel

Così meglio o posso togliere altro?

tipo restrictevent non so cos'è

Kexts.jpg.8e298a54dc2847a48d04a945d5447de2.jpg

3 minuti fa, Giaccaz ha scritto:

 

 

Link to post
Share on other sites

a si scusa non avevo visto 😬

 

devi sistemare i divres in config.plist 

Quello a sinistra  e il sample quello a destra e il tuo , come vedi i driver con opencore 0.7.3 han cambiato sistema , ricordati di abilitarli con yes.

prova ad  usare  PlistEdit Pro che forse e piu semplice ....per fare la comparazione tra il sample e il config.

 

552543055_Schermata2021-09-13alle15_56_02.thumb.png.4921901add12347959b2014a3ee4d94d.png

Link to post
Share on other sites

per i kext intanto devi capire quali realmente ti servono per la tua scheda madre/cpu/periferiche che hai realmente e togliere tutti quelli che non servono o che credi che non ti servano......

tipo BrightnessKey ti serve? hai una tastiera retroilluminata da portatile? che usi con la build?

Edited by Giaccaz
Link to post
Share on other sites
  • Support Team
5 minuti fa, Giaccaz ha scritto:

a si scusa non avevo visto 😬

 

devi sistemare i divres in config.plist 

Quello a sinistra  e il sample quello a destra e il tuo , come vedi i driver con opencore 0.7.3 han cambiato sistema , ricordati di abilitarli con yes.

prova ad  usare  PlistEdit Pro che forse e piu semplice ....per fare la comparazione tra il sample e il config.

 

552543055_Schermata2021-09-13alle15_56_02.thumb.png.4921901add12347959b2014a3ee4d94d.png

 Sorry, ma sta usando la 0. 6.8 e non c era quella disposizione dei driver, con ocvalidate avra' sempre errori 

Quindi ho aggiorna OC alla 0.7.3 o usa il Sample e ocvalidate della  OC-0.6.8.zip

Link to post
Share on other sites

Aaah....bhe dai ormai già che ci sei aggiorni al 0.7.3 già che devi sistemare tutto ehehe

 

 

P.s. la vecchiaia si sta avvicinando sempre più e.la.vista non è più quella di una volta

Edited by Giaccaz
  • Like 1
  • Haha 1
Link to post
Share on other sites
1 ora fa, Giaccaz ha scritto:

Aaah....bhe dai ormai già che ci sei aggiorni al 0.7.3 già che devi sistemare tutto ehehe

 

 

P.s. la vecchiaia si sta avvicinando sempre più e.la.vista non è più quella di una volta

ahah intanto grazie mille😁

 

Come mi hai suggerito ho aggiornato OC e rifatto il config.plist ora non ci sono più errori (anche ocvalidate ok) e funziona bene, ho anche sfoltito i kext

ho notato solamente che mi sembra un filo più lento a far compare la GUI con la scelta dei boot e mi salva un txt con i log dell'avvio nella partizione della EFI.

 

Questa è la nuova EFIEFI.zip

Link to post
Share on other sites

Per la gui di Opencore chiedi a @antuneddu che e lui il guru...probabilmente si sapra dare qualche dritta giusta.

Un altra cosa per  le porte usb dovresti seguire la guida di @Gengik84  

 cosi metteresti la "ciliegina sulla torta" per completare a dovere hack

Edited by Giaccaz
  • Like 1
Link to post
Share on other sites

allora per la lentezza nel comparire il boot era il driver OpenHfsPlus rimettendo HfsPlus è tornato veloce, 

per i log avevo attivato la modalità debug 😅  ora ok

 

invece per le usb ho sistemato il kext per le porte usb, prima con i problemi che avevo con OC c'era il limite delle porte disattivato

ora se mi escono così dovrei essere apposto giusto?

 Hackintool_v3_6_2.thumb.jpg.d189a61cd5fec03ae201a7b43a969291.jpg

 

 

 

Link to post
Share on other sites

Grazie ragazzi 😁 

 

3 minuti fa, antuneddu ha scritto:

Sembra ok ,puoi ottimizzare ancora di piu' eliminando il kext per le usb creare il relativo SSDT  E DEFINIRE I CONNETTORI SEGUI ...SE VUOI LA GUIDA CHE TI HA LINKATO @Giaccaz

perfetto proverò anche questa allora.

 

Invece per questi altri 2 problemi avete delle idee? 

Cita

- La risoluzione del monitor e HDR ok però non mi fa scegliere la frequenza o la luminosità

- Prima di arrivare alla schermata di scelta del boot mi compare questo

 

Link to post
Share on other sites
3 minuti fa, Giaccaz ha scritto:

per questo dovresti aver risolto aggiornando opencore e sistemandolo con ocvalidate...non dovrebbe comparire piuIMG_6225.thumb.png.697f27ce8eacc70376b3f4eb0bfefed1.png.226d080a418e65fd96a8a53365d334af.png

 

sisi quello si, scusa mi riferivo ai 2 problemi che ho citato sotto, il pc che quando premo arresta si riavvia invece di spegnersi e la possibilità di regolare il refresh rate e la luminosità del monitor.

 

 

Link to post
Share on other sites

qui mi cogli impreparato.....per il refresh usando una gpu  me permette di settare le 2 impostazioni del mio monitor.

per la luminosita del monitor non saprei dirti non mi son mai interessato della cosa, prova a vedere qua 

.

E per lo spegnimento bisogna chiedere a qualche guru .

Mi spiace.

 

 

 

P.S.

ehehe provata ora.... la piccola app di qualche anno fa e a me funziona premento i tasti fn+f1 per diminuire e fn+f2 aumentare

non si finisce mai d'imparare

Edited by Giaccaz
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.