Jump to content

Ventole LED e sospensione | Domanda teorica


Go to solution Solved by goldbr,

Recommended Posts

Buongiorno a tutti,

ho una domanda da porre.

Il mio hackintosh funziona benissimo, anche lo sleep, che viene ripreso tranquillamente da tastiera (se non è collegata via USB al monitor, però).

La mia domanda è: è normale che durante lo sleep le ventole continuino a girare e i led colorati delle ventole restino accesi?

C'è bisogno di dissipazione durante lo sleep? E se no, come disattivarle?

Grazie

Link to post
Share on other sites
20 ore fa, Gengik84 ha scritto:

Di norma no perchè quando va in stop vengono disattivati i dischi, monitor, ventole etc

 

Allora dovrò fare un summit su come procedere per disattivare le ventole e le luci led...

Grazie per la risposta

Link to post
Share on other sites
  • Supervisor

le ventole si dovrebbero fermare

le USB rimangono alimentate e accade che ad esempio tastiere con retroulliminazione rimangano accese durante lo sleep, e forse e' lo stesso per i led

molto probabilmente se rimangono accese le ventole il sistema ha solo staccato i monitor

 

 

Link to post
Share on other sites

…facilmente non è mai entrato in sleep…solo risparmio energetico del monitor come dice @fabiosun… prova a fare “mela” -> “stop” e guarda se nel giro di 4/5 secondi si spegne tutto. Se si spegne e resta tutto spento ok, se si spegne e poi ripartono le ventole non è più tanto ok…se si spegne solo il monitor non è ok ugualmente…ora mi fermo visto che mi son sentita dire da alcuni che non capisco un c4220, non vorrei magari creare problemi 😊

Link to post
Share on other sites
  • Supervisor
5 minutes ago, SemanticA said:

…ora mi fermo visto che mi son sentita dire da alcuni che non capisco un c4220, non vorrei magari creare problemi 😊

qui da noi?

 

Link to post
Share on other sites
19 minuti fa, fabiosun ha scritto:

qui da noi?

 

 

no ma è gente che "gira" tutti i forum... ma non è un problema xD ...una volta chiarito che ce l'avevano palesemente piccolo, si sono ridimensionati 🙂  

  • Haha 1
  • whahahah 2
Link to post
Share on other sites
Il 26/8/2021 at 14:50, goldbr ha scritto:

Può essere che dipenda SOLO da qualche impostazione del risparmio energetico sul BIOS?

Ciao Goldbr, hai risolto? Nel caso controlla  in "impostazioni di sitema/risparmio energetico" e vedi se hai tolto il flag su "impedisci hai dischi di andare in stop".

 

Link to post
Share on other sites

no, non ancora. 

Mi avevano consigliato di ottimizzare le USB per lo scopo.

Cosa che sto facendo, ma nel contempo sto scoprendo anche un sacco di cose - tipo che mi escono le RAM Addressable per OpenRGB (ma che poi non funzionano) perché legate via USB internamente alla scheda madre. Finora ho usato l'ottimizzazione USB da Hackingtool, ma mi sa che finirò per il metodo nativo di @Gengik84, il cui risultato è sicuramente migliore, ma assai più ostico da raggiungere.

Link to post
Share on other sites
Il 31/8/2021 at 22:49, Ramirez71 ha scritto:

Ciao Goldbr, hai risolto? Nel caso controlla  in "impostazioni di sitema/risparmio energetico" e vedi se hai tolto il flag su "impedisci hai dischi di andare in stop".

 

no, non ho risolto.

Ho configurato le usb con Gengik, e sono perfette, ma per il resto lo sleep continua a fare:

SI spegne tutto, tranne i led delle ram per poi riaccendersi subito dopo in automatico tranne il monitor.

Se disabilito tutte le usb va in sleep perenne. Nel senso che non c'è verso di svegliarlo. Infatti mi chiedevo come fosse possibile se una volta spente le ventole e i led possa mai riaccendersi. E' lì che vogliamo andare a parare? O alla fine mettendo in hibernatemode = 3 si spegne il monitor e "va in sleep" con ventole accese e led ed è così che deve funzionare?

Link to post
Share on other sites
  • Supervisor

che device usb fisici hai attaccati al pc?

a me faceva uno scherzetto simile un rivcevitore usb per tastiera e mouse wireless

ho cambiato la port USB e va tutto bene di nuovo

 

Link to post
Share on other sites
11 ore fa, fabiosun ha scritto:

che device usb fisici hai attaccati al pc?

a me faceva uno scherzetto simile un rivcevitore usb per tastiera e mouse wireless

ho cambiato la port USB e va tutto bene di nuovo

 

lo fa sempre, a prescindere che stacchi tutto, anche tastiera e mouse.

Mi perseguita da Mojave, mai risolto.

Edited by goldbr
Link to post
Share on other sites

Allora ragazzi, credo di avere risolto.

Ho applicato il file SSDT-GPRW.aml come da guida dortania e la relativa patch.

Patch che ho inserito senza poche difficoltà perchè con l'OC Configurator mi fa uscire solo due caratteri nei 2 campi find e replace, in quanto i campi sono di tipo DATA che quindi ospita un esadecimale.

Alla fine ho fatto un copia incolla da propertree.

Il risultato è che le RAM soltanto rimangono accese e successivamente devo riaccendere con il tasto power. Non si accende con un tasto sulla tastiera, per intenderci.

E' così che deve andare? In ogni caso il problema l'ho risolto e il mio sistema adesso va in sleep! 

 

Link to post
Share on other sites
20 ore fa, Gengik84 ha scritto:

non funziona da tastiera se usi le patch che hai messo, funziona solo da tasto power

è proprio così @Gengik84 (come al solito :-)).

Addirittura ho notato che a me basta solo la patch per farlo mettere in standby (senza neppure il file SSDT-GPRW.aml).

Ma se si applica quella patch nessuno dei 3 metodi può funzionare, come giustamente tu dici.

La mia domanda è: non si può fare un'ulteriore patch che fa funzionare correttamente uno dei primi 2 metodi?

Ho provato a fare qualche modifica alla patch, per esempio per farla funzionare solo sulla lenght table di SSDT-GPRW.aml, ma senza alcun effetto (in questo caso la patch non funziona proprio).

Il mio obiettivo sarebbe quello di usare un tasto qualsiasi da tastiera per il wakeup.

GRAZIE

 

Link to post
Share on other sites
  • Administrators

Quello che è il tuo obbiettivo non è possibile.

SSDT-GPRW è abbinato alla relativa patch quindi devono essere presenti sia l'uno che l'altro.

Devi usare il tasto power del case in questo caso e non ci sono alternative anche se usassi la sola patch e relativo SSDT.

SSDT da solo non potrà mai funzionare, non verrà mai caricato.

Link to post
Share on other sites
2 ore fa, Gengik84 ha scritto:

Quello che è il tuo obbiettivo non è possibile.

SSDT-GPRW è abbinato alla relativa patch quindi devono essere presenti sia l'uno che l'altro.

Devi usare il tasto power del case in questo caso e non ci sono alternative anche se usassi la sola patch e relativo SSDT.

SSDT da solo non potrà mai funzionare, non verrà mai caricato.

Ciao @Gengik84,

sto provando a fare tutte le ottimizzazioni possibili al fine di far funzionare il wake da tastiera.

A questo fine, stando a quel che dici, ho disabilitato l'SSDT e la relativa patch (e quindi non va in sleep).

Poi ho attivato l'erp da bios su s5 come letto da qualche parte (era disabilitato).

In pratica mi accingo a fare andare nativamente in sleep il sistema... per poi farlo ripartire da tastiera.

Ho anche fatto l'ottimizzazione IRQ di dortania (risultato: un file eml e tre patch, tutte applicate).

Ovviamente continua ad andare in sleep e a riprendersi da solo qualche secondo dopo, come al solito... 

2021-09-12 13:54:18 +0200 Sleep               Entering Sleep state due to 'Software Sleep pid=161': Using AC (Charge:0%) 25 secs   

2021-09-12 13:54:43 +0200 DarkWake            DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 45 secs   

2021-09-12 13:55:28 +0200 Sleep               Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 29 secs   

2021-09-12 13:55:57 +0200 DarkWake            DarkWake from Normal Sleep [CDN] : due to XDCI/ Using AC (Charge:0%) 17 secs   

2021-09-12 13:56:14 +0200 Wake                DarkWake to FullWake from Normal Sleep [CDNVA] : due to HID Activity Using AC (Charge:0%)           

 

ti aggiorno se riesco a trovare una soluzione.

Qualsiasi spunto è apprezzato, anzi... apprezzatissimo! LOL

Link to post
Share on other sites
  • Administrators
22 minuti fa, goldbr ha scritto:

Ho anche fatto l'ottimizzazione IRQ di dortania (risultato: un file eml e tre patch, tutte applicate).

 

non ne avevi necessità, non serve a nulla su sistemi recenti.

  • Like 1
Link to post
Share on other sites
Adesso, Gengik84 ha scritto:

non ne avevi necessità, non serve a nulla su sistemi recenti.

GRAZIE PER L'INFO

adesso ho staccato la scheda grafica, voglio vedere da cosa dipende. Ma ovviamente non mi avvia più... (scrivo da win)

Link to post
Share on other sites
  • Solution
5 ore fa, Gengik84 ha scritto:

non ne avevi necessità, non serve a nulla su sistemi recenti.

 

ho trovato l'inghippo. Scollegando dalla scheda madre due cavetti USB lo sleep va come dovrebbe.

A questo punto controllo quale dei due non mi fa andare il pc in sleep e disabilito la relativa USB.

Oppure provo prima a settarla come internal.

 

Edited by goldbr
  • +1 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.