Jump to content

[AMD] Clover Vanilla patches


Recommended Posts

  • 2 months later...
On 7/31/2021 at 12:43 PM, fabiosun said:

also about this

if you read well

only few users need of this patch.

newer one has a problem with clover masking system , and you can also see in AMD OSX Github why they left Clover without an official patches support..

Then is it possible to have it working well..and we have this from months

 

Hi, fabiosun:

I need your help to fix my Ryzen 1700X's Clover 5140.1 config.plist which can boot 10.13.6/10.14.6/10.15.7/12.0beta9, but always got freeze after +++++++++++++ for Big Sur 11.5.2 or 11.6.1.

Using old config-working-Ryzen-5138.plist which can boot Big Sur, but always got hang after running for 1~2 minutes.

No such an issue by OpenCore 0.7.2 or 0.7.4 with similar kernel patches.

config.plist.zip config-working-Ryzen-5138.plist.zip

Edited by jsl2000
Link to post
Share on other sites
  • Supervisor

@jsl2000clover dev is trying to port new feature to install correctly new Montereys beta, I will wait they finish their work

for now is a bit confused in my opinion

 

I am using latest clover as my second bootloader and I have no problem on BS 11.6.1 and on MR beta 10 (installed with Opencore I mean for beta 10)

 

Your working config is a bit...very confusing me

you beat record of used patches there 🙂

You mix new patches with old patches..I have to read it better to understand

Have you a working clover config for 1700x for all OSX you need?

without freeze I mean

 

Link to post
Share on other sites
  • Supervisor

for problem on old (and bad one for patches imho) config.plist...try to enable Dummypowermanagement quirk

I attached also here my working kernel patches for BS 11.6.1 and MR beta 10

 

clover patches.plist.zip

 

maybe you have to add here only topology patch and Fix pat you use

  • Like 1
Link to post
Share on other sites
1 hour ago, fabiosun said:

for problem on old (and bad one for patches imho) config.plist...try to enable Dummypowermanagement quirk

I attached also here my working kernel patches for BS 11.6.1 and MR beta 10

 

clover patches.plist.zip 1.88 kB · 1 download

 

maybe you have to add here only topology patch and Fix pat you use

Thanks for your kind and prompt reply and help.

Unfortunately this config.plist can boot both Big Sur and Monterey past +++++++++++++, but unable to login desktop successfully.

I need figure out how to fix it or using my old config.plist temporarily because I can boot Ryzen and FX-6300 with old patches by OpenCore and Clover. The only disvantage is ProvideCurrentCpuInfo must be disabled to avoid red screen panic during booting.

Edited by jsl2000
  • +1 1
Link to post
Share on other sites
  • Supervisor
2 hours ago, jsl2000 said:

Using old config-working-Ryzen-5138.plist which can boot Big Sur, but always got hang after running for 1~2 minutes.

for this instead I mean you have to add Dummypowermanagement quirk in that config.plist

(should be mandatory for you also in opencore booloader)

Link to post
Share on other sites
10 minutes ago, fabiosun said:

@jsl2000you mean you have used these attached patches and add on it CPU topology patch and Shaneee fix pat (because I have not inserted it)

Thanks again !

After addition of Shaneee fix pat patch it works now for both Big Sur and Monterey !

config.plist.zip

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.