Jump to content

GPU compatibile Mojave


Recommended Posts

Sinceramente soddisfatto di aver scoperto l'esistenza di macos86,sarei felice se qualcuno potesse aiutarmi nella configurazione della mia scheda grafica AMD R9 380 su Mojave...!! La mia build è descritta nella firma..!!

Grazie a tutti..!

Link to post
Share on other sites

Per la precisione riesco ad avviare il sistema ma non ottengo l'accelerazione grafica e mi viene rilevata una memoria grafica di 7mb..!!

Link to post
Share on other sites
  • Administrators

Quale ID ha la scheda video?

scarica dpci manager e fai una foto alla parte PCI list

Whatevergreen.kext lo stai usando?

Link to post
Share on other sites

Ma come vedi nel resoconto di sitema non viene visualizzato perchè se nella congig plist metto il numero preciso ID e Vendor all'avvio vedo solo schermo nero..! Invece se inserisco nella sezione grafica numeri a caso lo schermo si avvia ma senza accelerazione grafica con 7mb..!

1983344034_Schermata2021-05-23alle20_25_29.png.11ec68a6193cf1f62f62b1f4fea22cb1.png1939240824_Schermata2021-05-23alle20_27_36.thumb.png.86ce24713b202b33521454031916128d.png

Link to post
Share on other sites

Ho provato a fare cose come ssdt patch ....anche kaxt patch nella conifg plist ...ma sicuramente ho sbagliato....visto he non sono un grande hacker..!! Ora stavo cercando di aggiustare DSDT che ho estratto con F4 da Clover...ma sicuramente nmon ci riuscirò..!!

 

SI IL FAKE ID è QUELLO..!

 

Link to post
Share on other sites

Ma se lo metto nella config ....mi si avvia a chermo nero..!! Se invece lo metto sbagliato si avvia con 7mb..!

Scusa l'ignoranza per ACPI intendi il

DSDT..??

Link to post
Share on other sites
  • Administrators

eh beh certo 🙂

metti come ti ho detto, metti anche injectATI e su FB scrivi Lagotto

se non va ancora aggiungi anche FixDisplay

Link to post
Share on other sites

Naturalmente ...certo che uso il Whatevergreen..!!

 

Già messo tutto Lagotto fixdisplay...e inject ATI..!

 

Sono 3 settimane che provo di tutto..!

927102243_Schermata2021-05-23alle20_43_02.thumb.png.7948b0e0b2599ce608d6585a5733c50e.png

Link to post
Share on other sites

1004045191_Schermata2021-05-23alle20_44_28.thumb.png.b1790b84bdcb75301ddf99511e049cee.png

Forse è un problema di BIOS ..da aggiornare..??

Forse c'entra il fatto che è una scheda madre di tanto tempo fa......!! Con la scheda grafica Nvidia gt 730 kepler va bene....ma volevo usare questa R9 380..!!

Perchè la GT 730 è supportata in modo nativo ...mentre la R9 380 è oob...giusto..??

Link to post
Share on other sites
  • Administrators
8 minuti fa, bufalo ha scritto:

mentre la R9 380 è oob...giusto..??

no, se lo fosse andrebbe senza minimamente mettere nulla

in caso quella che va oob è la versione X

quelle non X hanno sempre dato problemi e di fatto non hanno id nativi

 

altra prova che puoi fare è inserire l'ID tramite deviceproperties

Link to post
Share on other sites

Ho provato anche a patchare il kext secondo la guida di Insanely mac forum....e non va lo stesso ...anche se sicuramente avrò sbagliato qualcosa..!!

 

Link to post
Share on other sites
  • Administrators

quindi hai messo l'id della tua scheda nel kext di sistema?

se non va così allora c'è poco da fare

in caso dovresti provare a flashare il vbios con quello della 380X

Link to post
Share on other sites

Intendi dire ...in questa sezione..???

1990492269_Schermata2021-05-23alle20_58_41.thumb.png.da9d3d7fb2f440f73a25ff6a18cc1479.png

Si nel kexto ho messo un ID tramite il procedimento trovato su Insanely mac ...che dice di estrarre il bios con GPU-Z su windows e poi con 2 script sul mac trovare le porte dei connettori ...e poi cambiarle nel kext patch..!!

 

Link to post
Share on other sites
  • Administrators

e rifai prima le prove che ti ho detto sopra

injectati, fixdisplay etc

se non va passa a deviceproperties iniettando l'id

Link to post
Share on other sites

Ok...!! Ma quelle prove senza kext patch...le avevo già fatte prima...comunque le rifaccio...! Grazie..!! Se hai qualche link di come si fa a inserire i dati nel device properties ...magari sarebbe gradito..! Molte grazie..!!

Link to post
Share on other sites
  • Administrators

Per esempio

quello che vedi a sinistra è il percorso della mia GPU sul primo slot

lo puoi vedere anche da HackCheck o SystemSearch (tab DevicePath)  che trovi in download

in caso prova con solo l'ID e senza alcun altro fix

quindi niente FakeID, injectATI e fixDisplay

Schermata 2021-05-23 alle 21.18.27.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.