Jump to content

[post-installazione][10.13] a piccoli passi


Recommended Posts

bene, sono riuscito a installare Mac OS X 10.13, apparentemente funziona tutto, persino le usb 3.0 (almeno su carta) per ora sto testando tutto su un hd meccanico quindi magari mi fa da collo di bottiglia. allego tutto quello richiesto per capire se è andato tutto bene. non so soltanto se si risveglia dallo sleep. solitamente non ha mai funzionato, vedremo.

 

134960894_ScreenShot2021-04-28at11_27_57.png.92ce005384879ffcf77700044d016b5f.png

 

 

 

IORegistryExplorer-21.zipDPCIManager.zipHackInfo_Report.zip

 

Ora, a questo punto dovrei installare clover, sto usando l'ultima versione (2.5 r5133) correggetemi se sbaglio:

 

1) installare il pkg in modalita legacy bios (ed installare tutti i driver consigliati + apfs + ???NTFS??? vorrei bootare un hd windows successivamente)

2) montare la partizione

3) inserire il dsdt gentilmente corretto da @gengik84 (che vorrei tanto capire come e cosa ha fatto xD)

4) copiare il config.plist dalla partizione efi chiavetta usb alla partizione efi hdd highsierra (al massimo modificare nel config la partizione d'avvio)

5) copiare i kext nella cartella 10.13

6) arrestare la macchina, togliere la penna avviare, incrociare le dita

 

questa procedura è corretta? dò fuoco alle polveri?

 

PS vorrei capire come poter leggere i risultati dalle varie app di diagnostica pe capire cosa non va

 

 

Link to post
Share on other sites
1 ora fa, ITA.people ha scritto:

ed installare tutti i driver consigliati + apfs + ???NTFS??? vorrei bootare un hd windows successivamente)

questa con bios legacy non so se riesci, dovresti istallare windows in GPT, non so se si può, credo da come ricordo si può solo in MBR,

clover lo vede ma non so se riesce ad avviarlo

1 ora fa, ITA.people ha scritto:

4) copiare il config.plist dalla partizione efi chiavetta usb alla partizione efi hdd highsierra (al massimo modificare nel config la partizione d'avvio)

Questo se già istallato clover sull' Hdisk , seno ci istalli clover e poi sostituisci tutta la Efi con quella della chiavetta

Link to post
Share on other sites
37 minuti fa, carlo_67 ha scritto:

questa con bios legacy non so se riesci, dovresti istallare windows in GPT, non so se si può, credo da come ricordo si può solo in MBR,

clover lo vede ma non so se riesce ad avviarlo

Questo se già istallato clover sull' Hdisk , seno ci istalli clover e poi sostituisci tutta la Efi con quella della chiavetta

tutta la efi intendi la cartella bot e la cartella clover?

 

nella partizione efi dell'hd c'è anche la cartella apple, quello la lascio?

Link to post
Share on other sites

se reinstallo clover e lascio il config.plist standard (senza le modifiche consigliate nelle guida di @Gengik84) parte e mi riconosce tutto correttamente altrimenti mi si blocca su quella schermata. da usb nessun problema da hd freeze

Link to post
Share on other sites
  • Administrators

ma quali modifiche dici?

una efi con cui installi o avvii da usb, di norma fa la medesima cosa da disco.

Link to post
Share on other sites
2 ore fa, Gengik84 ha scritto:

ma quali modifiche dici?

una efi con cui installi o avvii da usb, di norma fa la medesima cosa da disco.

 

nello specifico:

 

Cita

 

"A questo punto montiamo la EFI della usb, selezionate il disco relativo.

Cliccate su import configuration, sulla prima icona in basso a sinistra, recatevi in EFI/Clover ed importate il config.plist.

Sezione ACPI:

  • disabilitiamo tutti i fix sia nel tab 1 sia nel 2
  • eliminiamo premendo - oppure disabilitiamo tutte le eventuali patch in dsdt patches"

 

 

ho seguito i passaggi nel primo post, ho installato la stessa versione clover della penna usb, copiato la cartella efi della usb, riavviato non mi vedeva gli hd.

 

ho inserito il driver apfs.efi, riconosce gli hd e si bloccava come in schermata.

 

poi questa mattina ho installato nella partizione efi clover 2.4 ho copiato dsdt e kext tranne (erroneamente) il config.plist ed è partito

 

se invece carico il config.plist della chiavetta si blocca come in schermata su pci configuration begin

Link to post
Share on other sites
  • Administrators
12 minuti fa, ITA.people ha scritto:

ho inserito il driver apfs.efi, riconosce gli hd e si bloccava come in schermata.

 

il driver apfs dovevi averlo da subito a meno che non usi un disco meccanico

 

Poi... stai installando la medesima versione di Clover sia su usb sia su disco?

Link to post
Share on other sites
1 minuto fa, Gengik84 ha scritto:

il driver apfs dovevi averlo da subito a meno che non usi un disco meccanico

 

clover installa direttamente ApfsDriverLoader.efi, ma da chiavetta va e da hdd non va così ho utilizzato apfs.efi

Cita

Poi... stai installando la medesima versione di Clover sia su usb sia su disco?

 

si, ho:

- installato il medesimo pkg ultima versione scaricabile

- copiato l'intera cartella efi (mantenendo la cartella apple)

- aggiunto il file apfs.efi

 

.... e ho il problema in foto al 6° post

 

QUESTA MATTINA: ho reinstallato clover 2.4, ho copiato tutti i file nelle rispettive cartelle e mi son scordato di riscrivere il config.plist (ora vi posto tutto)

Link to post
Share on other sites
  • Administrators

ah ok certo...

nella 5133 ossia l'ultima ci sono molti cambiamenti sul config che sono incompatibili con versioni precedenti alla 5122 quindi a maggior ragione con Clover V2.4

inoltre anche i driver stessi sono stati modificati

Link to post
Share on other sites
  • Administrators

Comunque se ti avvia in quel modo da HD, va bene quindi non modificare altro se non dichiarare il SMbios

è meglio averlo dichiarato sempre invece di lasciar fare a clover perchè potrebbe modificare il tutto in futuro, quindi se usi imac 12 dichiaralo sul config

Link to post
Share on other sites
1 minuto fa, Gengik84 ha scritto:

Comunque se ti avvia in quel modo da HD, va bene quindi non modificare altro se non dichiarare il SMbios

è meglio averlo dichiarato sempre invece di lasciar fare a clover perchè potrebbe modificare il tutto in futuro, quindi se usi imac 12 dichiaralo sul config

 

ma lasciare il config.plist standard non equivale a sporcare il codice come fanno i tool di tonymacx86? se li avessi usati dall'inizio avrei risparmiato giorni di madonne che volavano...sono confuso

 

per quanto riguarda l'SMbios sinceramente non so neanche da dove andare a prendere tutti i dati che richiede, faccio confusioni fra quelli reali della scheda madre e quelli fittizzi del mac

  • Confused 1
Link to post
Share on other sites
1 minuto fa, Gengik84 ha scritto:

Cosa centra Tony?

Assolutamente nulla.

Clover non è Tonymacx.

dite sempre che quei tool sono bannati perchè non fanno altro che sporcare il codice

 

e ora tu mi consigli di fare la stessa cosa :S?

  • Confused 1
Link to post
Share on other sites
  • Administrators
Adesso, ITA.people ha scritto:

dite sempre che quei tool sono bannati perchè non fanno altro che sporcare il codice

 

e ora tu mi consigli di fare la stessa cosa :S?

Ma cosa stai dicendo?

Tool????

Clover pkg non ha nulla a che vedere con i tool che pensi tu, ti stai veramente sbagliando

questo è clover https://github.com/CloverHackyColor/CloverBootloader

che prima era qui: https://sourceforge.net/projects/cloverefiboot/

Ma niente di Tony e relativi tools....

Link to post
Share on other sites
8 minuti fa, Gengik84 ha scritto:

Cosa centra Tony?

Assolutamente nulla.

Clover non è Tonymacx.

 

scusami, nella tua guida consigli di disabilitare tutti i fix (perchè magari superflui) mentre a me consigli di lasciare tutti i fix abilitati l'importante che parta,

 

che differenza c'è fra i tool di tony e questo consiglio?

  • Confused 1
Link to post
Share on other sites
  • Administrators
2 minuti fa, ITA.people ha scritto:

 

scusami, nella tua guida consigli di disabilitare tutti i fix (perchè magari superflui) mentre a me consigli di lasciare tutti i fix abilitati l'importante che parta,

 

che differenza c'è fra i tool di tony e questo consiglio?

 

Non capisco se mi stai prendendo in giro o cosa? 😅

Dopo anni che hai un hackintosh mi vieni a paragonare clover o dei fix abilitati sul config a Tonymacx? 🤯

Hai i fix abilitati? bene.. disabilitali.

ma non devi usare clover configurator perchè altrimenti ti inserisce e aggiorna il config per l'ultimo clover 5133

e questo non va bene perchè tu hai un vecchio clover e tal aggiunte di fatto corrompono il plist rendendolo ovviamente incompatibile

Se lo apri con un plist editor ti accorgerai che per esempio non hai la "sezione" chiamata Quirk che invece c'è e puoi trovare sul config dell'ultimo clover

etc etc

 

753481866_Schermata2021-04-29alle16_58_57.thumb.png.c2df10407fdd268380d9b35e531b1fb7.png

  • Like 2
Link to post
Share on other sites
Posted (edited)
12 minuti fa, Gengik84 ha scritto:

 

Non capisco se mi stai prendendo in giro o cosa? 😅

Dopo anni che hai un hackintosh mi vieni a paragonare clover o dei fix abilitati sul config a Tonymacx? 🤯

Hai i fix abilitati? bene.. disabilitali.

ma non devi usare clover configurator perchè altrimenti ti inserisce e aggiorna il config per l'ultimo clover 5133

e questo non va bene perchè tu hai un vecchio clover e tal aggiunte di fatto corrompono il plist rendendolo ovviamente incompatibile

Se lo apri con un plist editor ti accorgerai che per esempio non hai la "sezione" chiamata Quirk che invece c'è e puoi trovare sul config dell'ultimo clover

etc etc

 

753481866_Schermata2021-04-29alle16_58_57.thumb.png.c2df10407fdd268380d9b35e531b1fb7.png

 

se li disabilito si blocca.

 

da chiavetta nessun problema faccio l'installazione perfetto, nel post-installazione installo sull'hd stesso pkg di clover stessi file della chiaveta e....si blocca, non si blocca solamente quando lascio tutti i fix abilitati, gli stessi che suggerisci di disabilitare.

 

proverò a modificare con un editor

Edited by ITA.people
Link to post
Share on other sites
  • Administrators

puoi anche modificarli dalla gui, andando nelle opzioni

ti basta premere la lettera o

le modifiche sono solo per un avvio, con questo intendo che il config.plist di fatto rimane come era ma in caso puoi fare prove più velocemente per controllare il tutto

magari puoi anche trovare un unico fix che ti serve per il boot da HD

magari prova inizialmente lasciando solo FixRTC e FixRegion attivi

fai le prove con calma e a modo, poi fai sapere

Link to post
Share on other sites
15 minuti fa, Gengik84 ha scritto:

puoi anche modificarli dalla gui, andando nelle opzioni

ti basta premere la lettera o

le modifiche sono solo per un avvio, con questo intendo che il config.plist di fatto rimane come era ma in caso puoi fare prove più velocemente per controllare il tutto

magari puoi anche trovare un unico fix che ti serve per il boot da HD

magari prova inizialmente lasciando solo FixRTC e FixRegion attivi

fai le prove con calma e a modo, poi fai sapere

 

 ora sto provando a reinstallare tutto con 5133, sperando che mi riconosca gli hd. altrimenti ricomincio tutto da zero con clover 2.4.

 

sicuramente proverò la strada della modifica momentanea.

 

per quanto riguarda l'SMbios dove posso trovo tutti i valori da modificare e quelli invece da lasciare inalterati?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.