Jump to content

Problemi USB


Go to solution Solved by zeroverride,

Recommended Posts

Salve a tutti,

non so se è proprio un problema sulle porte USB ma mi trovo davanti ad una situazione strana.

Accedo al sistema operativo e riesco a digitare la psw, dopo circa 30sec. la tastiera non funziona più, devo scollegarla.

Una volta collegata non ho più problemi.

Ho mappato le porte USB con Hackintool, inserito nei kext il file generato, aggiornato opencore per la config. che allego.

qualcuno ha un idea per risolvere bug.

Grazie a tutti e buona giornata

USB Mapp.png

Link to post
Share on other sites

Mac Pro di Zero.zip

Ecco il file zippato,

utilizzo una gigabyte b365 aorus élite, ram ddr4 16Gbx2 crucial 2666Mhz, sud cruciai 256gb, ho collegato sulle porte usb Keyboard quickfire pro ultimate e mouse inferno della colore master, scheda video integrata intel 630.

Ho attivato Mac dopo aver avviato window, non ho dovuto staccare la tastiera. grazie dell'aiuto.

Allego anche EFI

EFI.zip

Edited by zeroverride
Link to post
Share on other sites
  • Administrators
8 minuti fa, zeroverride ha scritto:

Ho attivato Mac dopo aver avviato window, non ho dovuto staccare la tastiera. grazie dell'aiuto.

sa molto di problemi al bluetooth, il comportamento è tipico

riavviando da windows viene mantenuto il firmware

 

al tempo facendo questo si aveva il funzionamento di  un BT non supportato su MacOS

ovviamente la durata era limitata, nel caso si spengeva l'hack oppure si riavviava, il BT smetteva di funzionare

 

 

Link to post
Share on other sites
  • Administrators

le usb le hai mappate

HS08 l'hai messa definita interna, quindi presumo sia quella relativa a un BT della mobo

alcune sono 0x00 , una l'hai messa 0x09 e un altre 0x03

questo riferito alle usb 2 quindi HSxx

 

Perchè su un desktop usi VoodooInput.kext?

Link to post
Share on other sites

VoodooInput.kext l'ho installato per cercare di capire se riuscivo a risolvere il problema.

forse ho risolto, ho su una porta usb una chiavetta bluethoot per Wacom, ho installato ora i driver e sembra funzioni bene. Ho spento e riavviato da Mac e risponde tutto ok.

Ti aggiorno nei prossimi giorni se qualcosa non funzionasse.

Grazie mille per i consigli.

  • +1 1
Link to post
Share on other sites
  • Administrators

lo fa su tutte le porte usb?

Correggi  le porte che hai mappato con quel kext anche se penso che il problema è proprio quel dispositivo BT ma comunque devi migliorare la definizione dei connettori di quelle usb.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • Solution

ciao a tutti, sono riuscito a risolvere il problema con la tastiera. nelle impostazioni/tastiera/tasti modificatori, alla voce seleziona tastiera ho lasciato in bianco.

La tastiera ora funziona perfettamente.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.