Jump to content

AirPortOpenBSD Wi-FI INTEL BT


Recommended Posts

Buongiorno Carlo (e presenti!)

possiedo una wi fi/bluetooth card  Intel Ax200 su PCIe che utilizzavo sulla vecchia Hack usando però i kext presenti nella guida OpenIntelWireless (più precisamente bluetoothinjector, bluetoothfirmware, itlwm con wi fi attivato tramite heliport). Funzionava tutto con le limitazioni previste.

Adesso però sto configurando un nuovo hardware (in firma) e leggendo il topic, pensavo a una soluzione più elegante come questa. Quindi ho scaricato il kext per big sur direttamente da link, messo in cartella di OC e dichiarato nel config come al solito ma non si è attivato nulla: mi domandavo se c'è qualche operazione preliminare da svolgere prima, magari per un esperto ovvia (quindi non ripetuta in questa sede) oppure un prerequisito da accertare. 

Esiste un comando per capire se il kext è correttamente caricato?

Scusami ma ho fatto diversi tentativi e non capisco cosa non vada.  

 

Link to post
Share on other sites

Nel mio Hack Huawei funziona meglio rispetto  alla versione 2.0.6 beta ... ha ancora da migliorare perché, almeno nel mio caso, ogni tanto mi sgancia dalla rete e devo ricollegarlo ma molto migliorato ... sembra nella buona strada poi certo dipende dal modulo che si ha ....

 

Per ora grazie a tutti 

Link to post
Share on other sites
  • 1 year later...
14 minutes ago, AlexAMD said:

fare una prova non costa nulla .... 😀

Sono online con quello a differenza di quello per BigSur va il WIFI ma non il BT.

Si si li provo tutti figurati, grazie, per il BT che dici..?

Link to post
Share on other sites

Vedo che come per AirportItlwm.kext è duro a riconnettersi se gli chiedo di riconfermare la password, torno all'accoppiata itlwm.kext HeliPort, grazie Alex se hai altre info segnala 🙂

Link to post
Share on other sites

Ma le features AirPort funzionano o no su questo kext? Io avrei voglia di switchare dato che non riesco a usare Continuity. Poi, funziona solo per WiFi e BT? Niente Ethernet?

Link to post
Share on other sites
2 ore fa, Nyaomi ha scritto:

Niente Ethernet

In che senso? Per Ethernet si usano comunque gli atri kext tipo intelmausi etc.

comunque i servizi di continuità non dovrebbero essere i attivati  con schede Intel, salvo eccezioni. 

Link to post
Share on other sites
9 ore fa, netgear ha scritto:

Vedo che come per AirportItlwm.kext è duro a riconnettersi se gli chiedo di riconfermare la password, torno all'accoppiata itlwm.kext HeliPort, grazie Alex se hai altre info segnala 🙂

Purtroppo per ora non saprei che dirti ... hai provato anche  le versioni alpha di openintelwireless ???? io le sto testando e sembra andare meglio della stabile , almeno nel mio caso ....

  • Like 1
Link to post
Share on other sites
7 ore fa, Ramirez71 ha scritto:

Per Ethernet si usano comunque gli atri kext tipo intelmausi etc.

comunque i servizi di continuità non dovrebbero essere i attivati  con schede Intel, salvo eccezioni. 

 

Per la prima parte, mi illudevo che AirPortOpenBSD potesse avere uno spiraglio di senso per le schede ethernet Intel (sarebbe molto carino);
Per la seconda parte, mannaggia, sta AX200 è inutile.

Riconosco di aver sparato una baggianata con Ethernet, ma ormai sto cercando ogni spiraglio di speranza dopo la morte di SmallTree (e AppleIGB che non funziona per niente bene). Io purtroppo ho una I211.

Link to post
Share on other sites

Figurati @Nyaomi sapessi gli sfondoni che tirò io qua dentro🤣🤣🤣🤣

Capisco cosa intendi dire però Ax200 non è proprio inutile anche se da risultati alterni a seconda dei kext usati e della build, a me per esempio, con Openbsd non andava mentre con openintelitwlm (scusa se l’ho scritto male) andava bene, niente continuità però usavo AirDrop (cosa strana perché il dev afferma casomai il contrario!): questione di fortuna? 

Link to post
Share on other sites
20 hours ago, AlexAMD said:

Purtroppo per ora non saprei che dirti ... hai provato anche  le versioni alpha di openintelwireless ???? io le sto testando e sembra andare meglio della stabile , almeno nel mio caso ....

 Lo sto provando su BigSur, funziona tutto ma non viene visualizzato il pulsante per disabilitarlo, fa così anche BlueToolFixup.

2128637345_Schermata2022-05-03alle13_59_05.png.4f4d98bc58db498529af3db2c2aa842e.png

-

1374351748_Schermata2022-05-03alle14_03_13.thumb.png.06c4a81f7c0302affd3d5535d498545d.png

Link to post
Share on other sites

La versione Alpha non ce l'ho compilata, ma ora ritornando a BS, Monterey è a posto con l'altra combinazione, ho dei dubbi che mi faccia tornare il pulsante :)...

 

Lato WIFI su BS la rete negozia subito senza problemi.

1304176476_Schermata2022-05-03alle14_20_36.thumb.png.ae101079c1bb56f9d4da4a9187a02867.png

Link to post
Share on other sites

Provato la versione 2.0.6 ma fa uguale, visto che lo fa anche itlwm_v2.1.0_stable.kext orse la correzione sta da un altra parte..? Su BS parlo, su Monterey va bene.

 

Il Bluetooth Comunque funziona.

-

95779226_Schermata2022-05-03alle14_36_05.thumb.png.599c84eb7251e3013a8394fe94f0d1d5.png

Link to post
Share on other sites

Per avere tutto attivo devo aggiungere IntelBluetoothInjector.kext

 

Quindi IntelBluetoothInjector.kext + AirPortOpenBSD.kext

Oppure

IntelBluetoothFirmware.kext + IntelBluetoothInjector.kext + itlwm.kext + HeliPort

Oppure

IntelBluetoothFirmware.kext + BlueToolFixup.kext + itlwm.kext + HeliPort

 

EDIT: Le prestazioni sono comunque molto scarse.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.