Jump to content

Installazione Catalina Legacy X58


Recommended Posts

Ciao a tutti,

Vorrei provare ad installare Catalina sul mio vecchio hackintosh legacy con processore Xeon W3690 gulftown.

Ho cercato in rete ma non ho trovato nulla , quindi prima di provare volevo chiedere qui se la cosa è fattibile o meno

la macchina ha gia installati e funzionanti 3 diversi OS (mavericks , sierra , high sierra) con bootloader clover

la macchina e composta così :

 

MOBO Gigabyte GA-EX58-UD5

CPU INTEL XEON W3690

GPU GIGABYTE NVIDIA GTX 760 4GB

RAM CORSAIR DDR3 1600 12 GB

 

 

Link to post
Share on other sites
  • Support Team
8 minuti fa, audioman ha scritto:

 posso procedere usando la cartella EFI esistente oppure devo fare qualche modifica (quircks , patch , smbios, etc ) prima di iniziare ad installare ?

puoi usare Clover 5119 così non devi adeguare la sezione quirks etc che ancora non era introdotta

 

se posti EFI che usi ora, così uno si fa una idea di che usi e può eventualmente darti consigli più mirati

Link to post
Share on other sites
  • Support Team
14 minuti fa, audioman ha scritto:

(ho tolto la cartella Apple)

si ma allora ti sei dimenticato il nonno dentro 😄 o sono la sfilza di temi inutili

 

non capisco che drivers .efi usi, sono tutte vuote le cartelle.... appena capito questo, per il resto puoi provare anche così, kexts aggiornati, e magari tieni ogni macOS con i suoi kext dentro la relativa cartella 10.xx e non tutti in other

ora non ricordo se MacPro5,1 è supportato con catalina, al max cambi in 6,1 o iMacPro1,1

Link to post
Share on other sites
9 minutes ago, iCanaro said:

si ma allora ti sei dimenticato il nonno dentro 😄 o sono la sfilza di temi inutili

 

non capisco che drivers .efi usi, sono tutte vuote le cartelle.... appena capito questo, per il resto puoi provare anche così, kexts aggiornati, e magari tieni ogni macOS con i suoi kext dentro la relativa cartella 10.xx e non tutti in other

ora non ricordo se MacPro5,1 è supportato con catalina, al max cambi in 6,1 o iMacPro1,1

 

@iCanaro Hai perfettamente ragione , meglio rifare la cartella EFI da zero e installare solo i driver necessari ?? perchè non capisco come faccia a partire senza driver nelle cartelle ...

riguardo alle kext io avevo capito che lasciarli nella cartella other era la cosa migliore , cosi da non copiare piu volte gli stessi driver .

puo essere però che la cosa sia errata

Edited by audioman
Link to post
Share on other sites
  • Support Team
10 minuti fa, audioman ha scritto:

perchè non capisco come faccia a partire senza driver nelle cartelle ...

questa è una cosa che devi verificare bene... questi dischi sono in GPT UEFI con la partizione nascosta EFI o sono in mbr e hai una cartella EFI nella root del disco?

 

12 minuti fa, audioman ha scritto:

riguardo alle kext io avevo capito che lasciarli nella cartella other era la cosa migliore , cosi da non copiare piu volte gli stessi driver .

puo essere però che la cosa sia errata

sono scelte, diciamo che se usi una sola versione di macOS vanno bene anche lì, ma other è una cartella speciale che inietta i kext in modo prioritario.

Personalmente preferisco tenere ogni macOS con i suoi kext nella sua specifica 10.xx e usare other solo in qualche caso particolare... anche perché non è detto che un kext che va bene per elcapitan possa esserlo anche con catalina... poi avendo ogni macOS con i suoi kext posso fare esperimenti su uno e in caso di problemi avviare con altro macOS

Link to post
Share on other sites

 

38 minutes ago, iCanaro said:

questa è una cosa che devi verificare bene... questi dischi sono in GPT UEFI con la partizione nascosta EFI o sono in mbr e hai una cartella EFI nella root del disco?

 

sono scelte, diciamo che se usi una sola versione di macOS vanno bene anche lì, ma other è una cartella speciale che inietta i kext in modo prioritario.

Personalmente preferisco tenere ogni macOS con i suoi kext nella sua specifica 10.xx e usare other solo in qualche caso particolare... anche perché non è detto che un kext che va bene per elcapitan possa esserlo anche con catalina... poi avendo ogni macOS con i suoi kext posso fare esperimenti su uno e in caso di problemi avviare con altro macOS

i 3 Ssd dedicati ai sistemi operativi hanno la cartella EFI nascosta che apro solitamente con clover configurator

ti allego la schermata di diskutil list cosi da avere una precisa idea della situazione ( la EFi da dove parte l'hack e quella sul disco Ssd di sierra)

 

 

Schermata 2020-12-18 alle 14.25.53.png

Link to post
Share on other sites
  • 1 year later...
On 12/18/2020 at 2:49 PM, iCanaro said:

ok bene.... ora ti rimane il mistero dei driver .efi

 

Ciao @iCanaro

è venuto il momento di aggiornare la mia build legacy X58 , volevo un consiglio su come procedere e soprattutto su che versione di OSX installare.

Visto il problema dei driver "misteriosi" vorrei fare una installazione da zero cosi da fare tutto per bene , quindi mi chiedevo se puoi darmi assistenza dato che sono abbastanza arrugginito sulle procedure di installazione (soprattutto su legacy)

al momento ho installato clover versione 5145 con Sierra 10.12.6 e Mavericks 10.9.5

Se consigli di passare a opencore nessun problema.

La build è questa :

 

MOBO Gigabyte GA-EX58-UD5

CPU INTEL XEON W3690

GPU GIGABYTE NVIDIA GTX 760 2 GB

RAM CORSAIR DDR3 1600 12 GB

 

Grazie

Edited by audioman
Link to post
Share on other sites
  • Supervisor

Ciao @audiomansu cosa installare e' facile

Il supporto diretto della tua GPU finisce con BigSur

quindi al massimo Big Sur senza usare patches per i driver

Se sei con Clover per Big Sur serve la versione che hai ora (anche se dal thread sembrava che stessi su Catalina e da li il passaggio poteva essere indolore)

Se passa @carlo_67che ha una build x58 (anche in legacy mi pare) ti potrà dire meglio

  • Like 1
Link to post
Share on other sites
8 hours ago, fabiosun said:

Ciao @audiomansu cosa installare e' facile

Il supporto diretto della tua GPU finisce con BigSur

quindi al massimo Big Sur senza usare patches per i driver

Se sei con Clover per Big Sur serve la versione che hai ora (anche se dal thread sembrava che stessi su Catalina e da li il passaggio poteva essere indolore)

Se passa @carlo_67che ha una build x58 (anche in legacy mi pare) ti potrà dire meglio

Ciao @fabiosun @carlo_67 , ero intenzionato a installare Catalina appena aperto questo thread ,ma poi non l'ho fatto per mancanza di tempo.

Quindi mi consigli di rimanere su clover con la versione attuale e installare big sur come OS ? 

Vorrei fare una installazione ex novo, perché la cartella EFI che avevo postato ha qualche guaio con i driver, quindi meglio partire da zero, con le vostre indicazioni.

Fatemi sapere come procedere, così mi metto subito in moto.

Grazie

 

Edited by audioman
  • Like 1
Link to post
Share on other sites

EFI.zip questa è la mia EFI OpenCore lascia stare Clover

e installa BigSur

 

prepara prima il boot in legacy con OpenCore su una USB

scarica Opencore e segui la video guida

una volta fatta monti la sua EFI e ti troverai il file di boot dentro 

cosi

Schermata 2022-02-28 alle 22.05.46.png

a quel punto ci metti dentro la mia EFI postata

scarica BigSur da apple store

e con PowerTool (lo trovi in Download qui in forum) crei l'installer nella medesima USB

fai boot dalla medesima e prova ad installare

dovrebbe andare, 

PS: non usare USB3 ne  come chiavetta ne come porta

 

Link to post
Share on other sites
2 hours ago, carlo_67 said:

EFI.zip questa è la mia EFI OpenCore lascia stare Clover

e installa BigSur

 

prepara prima il boot in legacy con OpenCore su una USB

scarica Opencore e segui la video guida

una volta fatta monti la sua EFI e ti troverai il file di boot dentro 

cosi

Schermata 2022-02-28 alle 22.05.46.png

a quel punto ci metti dentro la mia EFI postata

scarica BigSur da apple store

e con PowerTool (lo trovi in Download qui in forum) crei l'installer nella medesima USB

fai boot dalla medesima e prova ad installare

dovrebbe andare, 

PS: non usare USB3 ne  come chiavetta ne come porta

 

Ciao @carlo_67 sto creando l'installer con PowerTool ..... seguendoo il video che hai postato , ho scaricatoo l'ultima vesrione di opencore (0.7.8), e ho notato che dentro la cartella utilityes/LegacyBoot non c'era il file BootInstall.command ma solo il file QemuBuild.command .

Quindi sono andato a prendere la versione di OpenCore del video (0.6.1) e ho creato il file di boot .

Fatto quello ho copiato la cartella EFI che hai postato

Ora aspetto che finisca e poi provo a farlo partire .

 

2 hours ago, carlo_67 said:

gia c'era un topic per la X58

cercando per gigabyte non l'ho trovato ....

 

Una curiosità , ho visto nel post che sei riuscito ad installare monterey con una scheda video Nvidia GT 710 , con il mio hardware è possibile oppure serve cambiare scheda video ?

Link to post
Share on other sites

@carlo_67 provato a fare il boot ma si blocca a questo punto ( allego screenshot ) e poi si riavvia con anche il reset del CMOS (poi il BIOS mi chiede di selezionare uno dei profili salvati)

 

Screenshot_2022-03-01-02-03-59-956_com.google.android_apps.photos.thumb.jpg.385f2361a4e6649736365209aa3efc07.jpg

Link to post
Share on other sites

@carlo_67 ho notato che prima del riavvio si blocca su AppleIntelCPUPowerManagement quindi sono andato sul sito di dortania e ho letto le possibili soluzioni , quindi ho scaricato ProperTree e ho modificato il tuo config.plist abilitando DummyPowerManagement sotto Kernel -> Emulate e sono arrivato alla schermata con il logo apple , poi schermata grigia e poi si riavvia

 

ce una ltro comportamento anomalo , quando si riavvia sembra si resetti il CMOS perche al riavvio parte con la pagina dei setaggi del BIOS .... potrebbe essere la batteria CR2032 da sostituire ?

Link to post
Share on other sites

ho visto che con clover usi il DSDT prova ad inserirlo

poi in Kernel/Quirk/DisableRtcCHeckSum prova true

per quano riguarda la schermata grigia e riavvo, può dipendere da fattori di flag al boot arg

intanto prova con nv_disable e i vari darkwake

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.