Jump to content

GIGABYTE TRX40 DESIGNARE (REV. 1.1) / AMD Ryzen Threadripper 3960 X


Recommended Posts

Hello, 

I simplified the kernel patch as much as possible on the advice of @fabiosun 

but I find myself with the obligation to keep the argument :

cpu_topology_sort -disable _x86_validate_topology

1261068138_Capturedcran2020-12-0317_34_12.thumb.png.988715b7a75b9bac9b3c7b34eb769b2d.png

Is it related to the AMD 3960 X processor or the motherboard ? 

 

EFI Open Core 0.6.4 / Big Sur 11.0.1

 

EFI.zip

Edited by Arrakis
  • Thanks 1
Link to post
Share on other sites
  • Supervisor

thank you @Arrakisfor this thread and your tests

Maybe some other users with a Gigabyte board could test..

in our testing I see also you have to use dummypowermangement quirk and rebuildapplememory quirk if I remember well..

I am curious also about this 🙂

 

  • Like 1
Link to post
Share on other sites

I'm waiting my new designare with 3970X cpu....i will start with your efi to see if with a different cpu BS will start too. Did you put in 1 slot the videocard, and thunderbolt? In 4th slot?

Can you insert pictures of bios settings?

Edited by thenightflyer
Link to post
Share on other sites
On 12/12/2020 at 1:15 AM, thenightflyer said:

@ArrakisOk i set up my system and i tried your EFI but maybe you did some mistake in packaging it because i've no image found so i tried to use 0.64 release with your config and kext and now i'm able to boot. Please can you upload again your updated EFI?

Hello,😀

I just replaced the EFI in my first post.

It is up to date with the official OpenCore 0.6.4 version

I haven't changed anything.

  • Like 1
Link to post
Share on other sites
  • Arrakis changed the title to GIGABYTE TRX40 DESIGNARE (REV. 1.1) / AMD Ryzen Threadripper 3960 X

@fabiosun

I tried your config.plist by removing the argument: cpu_topology_sort -disable _x86_validate_topology

It’s the same kind of mistake.

 

My EFI from the first post is working perfectly fine.

I'm just looking to simplify the kernel patch.

I have to keep the argument: cpu_topology_sort -disable _x86_validate_topology

Otherwise I get the kind of error message like the previous post: In memory Panic.....

 

 

1 hour ago, fabiosun said:

@arrakis

have you changed something in your pc?

Bios/Hardware?

 

I haven't changed anything in my setup, by the way my EFI can complete your TRX40 library.

Edited by Arrakis
Link to post
Share on other sites
  • Supervisor

ah kk

it is not a new problem...

🙂

 

8 minutes ago, Arrakis said:

@fabiosun

I tried your config.plist by removing the argument: cpu_topology_sort -disable _x86_validate_topology

It’s the same kind of mistake.

 

My EFI from the first post is working perfectly fine.

I'm just looking to simplify the kernel patch.

I have to keep the argument: cpu_topology_sort -disable _x86_validate_topology

Otherwise I get the kind of error message like the previous post: In memory Panic.....

 

 

I haven't changed anything in my setup, by the way my EFI can complete your TRX40 library.

 

if you can post also an IOREG

I will put it with the EFI togheter mine and @Ploddles ones 🙂

 

  • Like 1
Link to post
Share on other sites
  • 3 months later...
On 12/23/2020 at 4:27 PM, Arrakis said:

 

 

Hi, I am really in luck, I was looking for exactly these info, albeit I have a designare  V 1.0 and not the 1.1. Looking at  you configuration, I can see it is miles away from the one I was able to come up with, by following the opencore guide, in terms of drivers, kext and ACPI.  In relation to the latter,  did you create those SSDT by yourself ? did you find a guide? If so, could you provide me with the link of such guide?

 

Thanks.

Link to post
Share on other sites

@Renato

I modified none of the SSDTs in my configuration.

SSDT-TRX40-EC-USBX comes from the Dortonia site and the other two are from the configuration of Meina222 for the management of the TitanRidge card.

Link to post
Share on other sites
  • 4 weeks later...

I tried again to remove the same argument in kernel / patch ((cpu_topology_sort -disable _x86_validate_topology) ) with the new patch for Big Sur 11.3 and the 0.6.8 open core version is still the same.

I have to keep this argument enabled.😐

Link to post
Share on other sites
  • 5 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.