Jump to content
You are a guest user Click to join the site
Sign in to follow this  
fabiosun

[GUIDE] X299 DesignareEx-7980 Xe/9980 xe -128 Gb DDR4- macOS High Sierra Install/Post Install [Updated 01/26/2019]

Recommended Posts

IMPORTANT Update

 

Added here USB port mapping:

 

https://www.macos86.it/viewtopic.php?p=13032#p13032">viewtopic.php?p=13032#p13032">https://www.macos86.it/viewtopic.php?p=13032#p13032

 

 

 

X299 Gigabyte Ex (rev.1.0) used in this article is simple to configure in a basic way to have a working Hackintosh.

 

Follow this thread to have a fantastic a "powerful Hackintosh ever" © Steve! :)

 

One big difference you can find here from others guide you can find in the net is I use CSM enabled/disabled . boths setup are fine

 

 

 

I have choosen Gigabyte X299 motherboard because, Gigabyte is the only manufacture which gives support to RDIMM ECC (Registered Dimm ECC) disabling ECC as mandatory for Skylake X CPU intel specs

 

With X99 instead was possible to have an Extreme or Xeon CPU and using ram without problem (ECC or not)

 

With new Intel CPU Xeon and Extreme CPu need of a different CPU socket to work

 

Till F3 bios, Gigabyte supports DDR4 not supported by Intel definition and I would like also to know if it is possible to break 128 Gb limit with these motherboards (all gigabyte X299) as stated in Extreme Intel ark specs.

 

 

I have decided to start my rig always with clover boot loader , if I need to enter in Windows I press exit in boot clover menu and Windows Start

 

For this task it is important to have right order in harddrive priorities in Bios

 

GPT conversion adds an EFI partition on Windows drive which is visible in boot clover menu and, if selected it starts windows

 

 

 

This guide does not talk about thunderbolt setup because I have any TB drives or similar.

 

 

 

Prerequisites:

 

 

 

A working Hackintosh/Mac or a virtual machine with OSX installed

 

 

 

Software:

 

 

 

OS: macOS High Sierra 10.13.4 (17E199)

 

https://itunes.apple.com/us/app/macos-high-sierra/id1246284741?mt=12">https://itunes.apple.com/us/app/macos-h ... 4741?mt=12">https://itunes.apple.com/us/app/macos-high-sierra/id1246284741?mt=12

 

 

 

installation utility:

 

https://www.macos86.it/MacOS86_Downloads/?path=Applicazioni/Creazione%20USB%20per%20installare">MacOS86_Downloads/?path=Applicazioni/Cr ... installare">https://www.macos86.it/MacOS86_Downloads/?path=Applicazioni/Creazione%20USB%20per%20installare

 

 

 

clover boot loader (I have used R4369)

 

https://sourceforge.net/projects/cloverefiboot/files/Installer/Clover_v2.4k_r4369.zip/download">https://sourceforge.net/projects/clover ... p/download">https://sourceforge.net/projects/cloverefiboot/files/Installer/Clover_v2.4k_r4369.zip/download

 

 

 

Clover Configurator app (Global Edition)

 

https://mackie100projects.altervista.org/download/ccg/">https://mackie100projects.altervista.org/download/ccg/

 

 

 

Hardware:

 

 

 

case: Thermaltake Core X9

 

 

[/i]Philips Monitor, 27''

 

 

Screen Shot 2019-10-01 at 11.20.39.jpg[/i] LG 43UD79

 

 

Screen Shot 2019-10-01 at 12.19.56.jpg[/i] Enermax 1700w epm1700egt

 

 

melD0n.jpgmotherboard.png

 

CPU: Intel I9 7980 Xe

 

 

Schermata 2019-09-27 alle 16.30.00.jpgbequiet 360.jpg

 

Memory: 2x 64 Gb Kingston RDIMM ECC (128 Gb)

 

 

photo_2019-09-27_12-33-07.jpgstar-wars-jedi-order-nvidia-titan-xp-collectors-edition-u.jpg

 

NVME DIsk: Samsung 960 Pro 1 Tb (installed on PCIEXPRESS card)

 

 

melD0n.jpg850 pro 512 gb.jpg

 

SSD2: Intel 80 Gb

 

 

Schermata 2019-09-27 alle 11.18.29.jpgseagate 4tb.jpg

 

HDD3: Seagate Surveillance HDD SkyHawk 6TB

 

HDD4: Seagate Surveillance HDD SkyHawk 6TB

 

 

Cattura2.jpgpioneer.jpg

 

mouse and keyboard: Generic USB type

 

Peripherical positions on motherboard:

 

 

IMG_1302_ed.jpgsata slot.jpg

 

Backplate connections:

 

 

tt44tr.jpg

placement.jpg

backplate1.jpg

philips.jpg

LG.jpg

09 copy.jpg

versione bios.jpg

IMG_0804.jpg

IMG_0805.jpg

IMG_0806.jpg

IMG_0807.jpg

IMG_0808.jpg

IMG_0809.jpg

I9 7980 xe.jpg

enermax.jpg

bequiet 360.jpg

memoria.jpg

pioneer.jpg

6tb.jpg

seagate 4tb.jpg

intel 80 gb.jpg

850 pro 512 gb.jpg

star-wars-jedi-order-nvidia-titan-xp-collectors-edition-u.jpg

960 ro.jpg

sata slot.jpg

core X9.jpg

Share this post


Link to post
Share on other sites

Installation Steps

 

 

 

insert an USB pen (size 8Gb or more)

 

run installation utility and follow on screen instructions or follow detailed guide to create an USB pen by @Gengik84[/mention] at this link:

 

 

 

https://www.macos86.it/viewtopic.php?f=41&t=2">viewtopic.php?f=41&t=2">https://www.macos86.it/viewtopic.php?f=41&t=2

 

 

 

or in a short way do this steps:

 

 

 

Choose installer and then alternate method to install

 

Drag and drop usb pen in installer app when requested

 

Drag and drop instal macOS data app previously downloaded from App Store

 

Wait till process end

 

 

 

Install clover on USB clover (any version) as pictures below:

 

 

 

using a minimal EFI driver64UEFI installation

 

if you want you can change in Clover/Other this included kexts:

 

 

IMG_1029 (2).jpgconfig.plist.zip

Schermata 2019-09-28 alle 18.05.44.jpg[/b]

 

 

 

install clover on Install macOS High Sierra USB pen as picture previously posted

 

You must have selected Install for UEFI booting only and Install Clover in the ESP accordly

 

 

 

Now we can reboot.

 

 

 

During BIOS scan press F12 to choose boot drive

 

Select Uefi USB pen you have created you will see clover boot loader menu

Cattura2.jpgdisk utility.jpg

 

Select disk utility and format disk you want use for OSX install

 

 

Screen Shot 2019-09-28 at 17.17.23.jpg17E202 OSX version[/b]

 

 

 

If you have downloaded config.plist posted here you can reboot because Nvidia web drivers is active in it ,otherwis,e you have to flag it as you can see here:

 

 

Schermata 2019-09-26 alle 17.29.14.jpgDSDT.aml.zip

In this way you will achieve this in Pic tab in About my Mac:

hack.jpgALL Kext or utilities used here are available in Downloads Section

 

 

 

Sleep is not working by now (WIP)[/color]

 

 

 

Have fun :)

clover minimal settings.png

Other.zip

config.plist.zip

imacpro11 in CC.png

disk utility.jpg

choose all device in DU.jpg

choose scheme.jpg

choose disk to install.jpg

os language.jpg

keyboard selection.jpg

first install no driver video.jpg

Screen Shot 2018-05-31 at 5.31.00 AM.png

initial state.jpg

update available.jpg

Screen Shot 2018-05-31 at 3.53.57 PM.png

Screen Shot 2018-05-31 at 4.00.18 PM.png

Screen Shot 2018-05-31 at 6.51.30 PM.png

DSDT.aml.zip

Share this post


Link to post
Share on other sites

This is not a Hack...it is a MONSTER!

 

 

 

Congratulations

 

++++++++++ 1

 

:)

Share this post


Link to post
Share on other sites

You have a Wonderfull rig !

 

 

 

Very good guide ! default_wink_anim

 

 

 

So you know I'm trying to perform my install , i see your all yours PCis devices are implemented : did you performed that with the attached DSDT ?

Share this post


Link to post
Share on other sites

Thank you

 

Without DSDT I see only Nvidia related things in PCI. No others

 

https://postimg.cc/image/eew4leq47/">LINK_TEXT>

 

 

"Loloflat6" post_id="6412" time="1527791462" user_id="202">

You have a Wonderfull rig !

 

 

 

Very good guide ! default_wink_anim

 

 

 

So you know I'm trying to perform my install , i see your all yours PCis devices are implemented : did you performed that with the attached DSDT ?

Share this post


Link to post
Share on other sites

New Nvidia web drivers for 10.13.5 breaks DP audio on my rig

 

Reverting to previous drivers all is fine

Share this post


Link to post
Share on other sites

Just to add that thunderbolt 3 works (except hot plug) I've same rig (except ram and gpu), configuration file by fabiosun and Gengik84.

Share this post


Link to post
Share on other sites

emoticon_applausi2 emoticon_applausi2 excellent guide. emoticon_applausi2 emoticon_applausi2

Share this post


Link to post
Share on other sites

Stimolated from some @Gengik84[/mention] researches in my original dsdt I will try to apply to my rig USB mapping to stay within 15 port OSX limit and to have a more conformed Hackintosh to a real Mac

 

 

 

I will not use a complete real mapping method but I will use @PMheart[/mention] port limit kext patch disabler to see all USB ports available and used in my original dsdt, see pictures:

 

https://postimg.cc/image/5dgtf96xz/">LINK_TEXT>

 

In this pictures you can see how my USB situation is only using @PMheart[/mention] kext to patch also you can use it to see USB connected or used by Gigabyte motherboard

 

In my rig HS05,HS07, HS08,HS13,SS05 are taken in some way from my system (mouse, keyboard some gigabyte internal hub)

 

I know also I need to have HS01,HS02,HS03,HS04 and relative SP01,02,03,04 because I tested with usb pen and these ports are related to my External case USB ports I use

 

and this will be final result of ports mapping with a single ssdt:

 

https://postimg.cc/image/3ztrxmch3/">LINK_TEXT>

 

As you can see all port I want are there :)

 

 

 

Go on and you will learn "How to" for your system

 

 

 

Restart your system

 

Now we will populate our clover Origin folder

 

In clover bootmenu press F4 key to save our original dsdt files

 

Inside origin folder we will find an aml file with inside all our USB ports with their names

 

See file attached:

https://s15.postimg.cc/z9z9l5myv/Screen ... .14_AM.png">https://s15.postimg.cc/z9z9l5myv/Screen_Shot_2018-09-02_at_10.26.14_AM.png' alt='LINK_TEXT>'>

 

 

 

and to some values we have to edit to disable port we want to disable

 

 

 

As you can see X299 Designare Ex SSDT for USB has inside all USB and more available in this motherboard

 

Checking IOREG with @PMheart[/mention] port limit disabler enabled helps to verify which ports are in use or not (also for internal motherboard stuff as hub or similar.

 

 

 

Now see above picture we have HSXX ports (XX=from 01 to 14) and SSXX Ports (XX= from 01 to 10)

 

HSXX=USB 2.0 ports

 

SSXX=USB 3.0 Ports

 

USR1 and 2 are USB 3.1 ports[dropshadow=blue] (da controllare)[/dropshadow]

 

 

 

You have to use MaciASL app to analyze attached original ssdt above

 

Now we want to disable HS01 port underlined on pictures above (only for understanding method)

 

Check GUPC value on the left is 0x01, It means "port Enabled"

 

put it to Zero (written in this way, in letter with capital Z) and in this way you have disabled it

 

In the same way, to have a proper ssdt.aml files to put inside clover/ACPI/Patched folder we have also to do here a proper rename from PC00 to PCI0

 

You can do it using find and replace function from Edit MaciASL's menu and you should have something like picture below:

 

 

 

https://postimg.cc/image/h11oik1yf/">LINK_TEXT>

 

 

 

after replacing and disabling ports you want you should have an ssdt like this one :

 

 

 

https://postimg.cc/image/9t3tyayg7/">LINK_TEXT>

 

 

 

and this is file you can put in your clover/ACPI/PATCHED folder

 

Before reboot your system you have to apply some changes in your config.plist file

 

You can do easily with Clover Configurator and following this good guide here from @Gengik84[/mention]

 

https://www.macos86.it/viewtopic.php?p=346#p346">viewtopic.php?p=346#p346">https://www.macos86.it/viewtopic.php?p=346#p346

 

to summarize: extract origin and copy you ssdt- AMI.aml file on your desktop

 

Check value you can see on attached picture (2390 in this case)

 

https://postimg.cc/image/evl5sun3b/">LINK_TEXT>

 

and open your config .plist and do this two changements:

 

https://postimg.cc/image/og4sg1287/">LINK_TEXT>

 

SSDT-11.aml should be the same name of your ssdt in EFI ACPI/Patched folder

 

You should also disable port limits patch:

 

 

 

save and reboot

 

 

 

If you have done all in a right way for your system you should have a corrected USB mapping without using any port limit or old method to do it

 

If something is not correct you can disable ssdt and config.plist option in clover bootmenu option

 

and re test again

 

 

 

To have support here you must have in your signature your system definition, you have also to post your ioreg with all USB port you use (preferably using ports limit patch to see all USB available)

 

Your Origin (F4 press stuff)

 

 

 

Have a nice Hack!

SSDT-A M I.aml.zip

Share this post


Link to post
Share on other sites

New Guide Update

 

Add USB mapping

 

see also this post for further details:

 

 

 

Italian language

 

https://www.macos86.it/viewtopic.php?p=346#p346">viewtopic.php?p=346#p346">https://www.macos86.it/viewtopic.php?p=346#p346

 

 

 

English version

 

https://www.macos86.it/viewtopic.php?p=13143#p13143">viewtopic.php?p=13143#p13143">https://www.macos86.it/viewtopic.php?p=13143#p13143

Share this post


Link to post
Share on other sites

On SMBIOS iMacPro1,1 using a Radeon RX 580 8GB breaks Apple H264 / H265 API. Meaning exporting in those formats will hung Final Cut Pro and Da Vinci R15 or any other apps that uses that route to transcode files.

 

For VEGA video cards such API work fine as it works for Nvidia cards.

 

Simply put the RX 580/570/560 are not contemplated by the SMBIOS iMacPRo1,1.

 

Is there a way around the issue?

 

 

 

I'm running an X299 machine with SMBIOS MacPro5,5 and magically Radeon RX 580 8Gb can now decode and encode using H264 /H265 both in Final Cut Pro and Da Vinci R15

 

 

 

Some poeple say SMBIOS MacPro5,5 would have negative implications. So far such SMBIOS seem to work just as fine as iMacPro1,1.

 

Any idea how to make SMBIOS iMacPro1,1 render H265 / H265 on RX 580?

 

Thanks

Share this post


Link to post
Share on other sites

Hi

 

Italian?

 

if so search in Italian section so we can talk with less difficulty :)

 

do you mean Mac Pro 5.1?

 

I would try with MacPro SMbios if you can but I think you do not have any negative implication

 

you can also test if your system does all steps for frequency and related temperature

 

 

 

However I have a Nvidia card and I can encode in H265

 

I do not think also it is iMac Pro 1.1 related problem but if you solve in this way and you have proper stepping and temperature. it is good

 

 

 

https://postimg.cc/TKvZjr1K">LINK_TEXT>

Share this post


Link to post
Share on other sites

Hi people! :)

 

I would like to propose to you a different way to test our beloved Hackintosh system :) , I am referring in a special way to people who likes to overclock owned system in a not too much exaggerate and sophisticate way ;)

 

 

 

It is a "street way" to test using a different approach and thinking!

 

If you want use this simple steps.

 

Software needed:

 

 

 

1) an app to monitor your system frequency and temperature like Istat menu IPG (intel power gadgets)

 

I use IPG

 

https://software.intel.com/file/770353/download">https://software.intel.com/file/770353/download

 

 

 

2)

 

free software of color correction/special effects compositing like Blackmagic Design DaVinci Resolve 15

 

https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion">https://www.blackmagicdesign.com/suppor ... and-fusion">https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion

 

I use Studio version but also not Studio free version is ok for our task

 

This software will be installed with all default and basic parameters

 

 

 

3)

 

All high 4k and more resolution R3d video files you can download freely from link:

 

https://www.red.com/sample-r3d-files">https://www.red.com/sample-r3d-files

 

 

 

For point 2 you need to register before have the chance to download software we need (no confirm email is sent but you have to fill form with some datas)

 

 

 

So here we go!

 

 

 

After installing DaVinci Resolve free version you will have on Launchpad Resolve Icon like you can see in this screen shot:

 

 

 

https://postimg.cc/4ns7hg8T">LINK_TEXT>

 

 

 

launch DaVinci app and you will see this:

 

 

 

https://postimg.cc/142kj9bk">LINK_TEXT>

 

 

 

click on Untitled Project icon and you will enter on this great app used in many Hollywood Studios for spot or cinematographic task

 

 

 

https://postimg.cc/Rq2YpRNS">LINK_TEXT>

 

Previous picture is standard graphical interface for this app

 

Now right clic on media pool space like pictures here and select import media voice menu

 

 

 

https://postimg.cc/tn7N9LJ1">LINK_TEXT>

 

now choose previously downloaded high resolution R3d video files (more you download them more test will be longer

 

 

 

https://postimg.cc/yD5dG24Q">LINK_TEXT>

 

you will have in this way media pool populated by previously downloaded video files

 

 

 

https://postimg.cc/jWbVChzq">LINK_TEXT>

 

 

 

now open IPG (intel power gadgets or similar monitoring app)

 

 

 

https://postimg.cc/pynB1Mw7">LINK_TEXT>

 

 

 

Ok we are ready to start our "stressing" test

 

Please take a look to temperature and other parameters in particular way If you are using Sync all cores bios option or similar in your bios settings

 

 

 

Following steps will be use all cores of our CPU and in many situation also our GPU (AMD or Nvidia) so temperature will increase proportionally

 

ok

 

select with left click all video icons on media pool, right click and select "generate optimized media"

 

wait and listen your Cpu and GPU fans ;)

 

 

 

https://postimg.cc/R6qqb9qD">LINK_TEXT>

 

 

 

https://postimg.cc/dZy3wB2R">LINK_TEXT>

Share this post


Link to post
Share on other sites

Hi there,

 

 

 

I have a similar setup with Ga-X299-Designare EX and i9 7960X, 128GB Ram, SSD Samsung NVME.

 

 

 

The problem is that in Resolve, all the cores are not fully working : I mean when rendering the CPU is working at 35% max (I see that in iStat).

 

 

 

I'm with iMac Pro SMBIOS, latest High Sierra 10.13.6, and I've tried this setup with a 1080Ti or a Vega64 and there is no change : Core not fully working.

 

 

 

On the real iMac Pro, I tested my Resolve session and the cores go up to 90%... So I don't understand what the problem is.

 

 

 

I will try next week to restart from scracth with Mojave and the Vega64 card and I will come back to you.

Share this post


Link to post
Share on other sites
"gprime" post_id="20611" time="1544269902" user_id="934">

Hi there,

 

 

 

I have a similar setup with Ga-X299-Designare EX and i9 7960X, 128GB Ram, SSD Samsung NVME.

 

 

 

The problem is that in Resolve, all the cores are not fully working : I mean when rendering the CPU is working at 35% max (I see that in iStat).

 

 

 

I'm with iMac Pro SMBIOS, latest High Sierra 10.13.6, and I've tried this setup with a 1080Ti or a Vega64 and there is no change : Core not fully working.

 

 

 

On the real iMac Pro, I tested my Resolve session and the cores go up to 90%... So I don't understand what the problem is.

 

 

 

I will try next week to restart from scracth with Mojave and the Vega64 card and I will come back to you.

Hi @gprime[/mention] and welcome here

 

have you tried the method I suggest to test cpu and gfx (high media resolution and optimized output to see if in this case your cpu is used @100% as in my case?)

 

 

 

Ha scritto dopo 13 minuti 39 secondi:

 

You can also try different optimization in your bios cpu parameters about turbo section

 

 

 

Ha scritto dopo 8 minuti 11 secondi:

 

https://postimg.cc/XpXknPt0">LINK_TEXT>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.