Jump to content

Adobe Applications and AMD-OSX


Recommended Posts

I just reran the PugetBench again (release version of AE) and had a score of 1057. Running it again now to see if I get a similar score on a second run. Tomorrow I will try the Beta version of AE, without the Adobe patches/fixes, to see if it will complete or stall at the last 5% again.

  • Like 2
Link to post
Share on other sites
  • Supervisor
6 hours ago, Ploddles said:

I just reran the PugetBench again (release version of AE) and had a score of 1057. Running it again now to see if I get a similar score on a second run. Tomorrow I will try the Beta version of AE, without the Adobe patches/fixes, to see if it will complete or stall at the last 5% again.

Before patching it you can also try to move or delete two intel related plugin

mmx something and core somethingūüėā

later i will say better

  • Like 1
Link to post
Share on other sites
  • Supervisor
3 hours ago, Ploddles said:

New version of Photoshop has just been released, V22.0.

 

I'll download and try it, without the patches, later this evening when I get home. Hopefully the Intel specific stuff has been removed.

photoshop 2021 needs OSX greater than High Sierra

Thanks to @tomnicwe discovered that intel library are there......so I think same problem

 

302533230_ScreenShot2020-10-20at20_39_19.png.9764791f36f0f40e7d69f1f5a629aa43.png

  • Like 1
  • Sad 2
Link to post
Share on other sites

Boooooo, hissssssss Adobe.

 

Edit:-

 

Just tried it. It won't even load with the 'Adobe Crash Fix XLNC'.

 

Immediately crashes - loads of libtbbmalloc.dylib errors. Intel stuff but different dylib file than previous Photoshop version - libiomp5.dylib was the previous culprit.

 

 

Edited by Ploddles
  • Sad 2
Link to post
Share on other sites

Adobe suite completely broke?

 

22 hours ago, Ploddles said:

Boooooo, hissssssss Adobe.

 

Edit:-

 

Just tried it. It won't even load with the 'Adobe Crash Fix XLNC'.

 

Immediately crashes - loads of libtbbmalloc.dylib errors. Intel stuff but different dylib file than previous Photoshop version - libiomp5.dylib was the previous culprit.

 

 

 

Link to post
Share on other sites
2 hours ago, fabiosun said:

I have tested only photoshop for now..

 

Photoshop and Lightroom both crash out now. Strange that it is a different dylib file that is causing the crash.

 

I may try to install the old version of PS and copy the old version of the offending library file across to the new PS and see if that does anything for us. Just a PITA for Adobe to do this to us.

 

EDIT:-

Replaced the 2 offending dylib files. This time it gets a bit further, the splash screen loads, but it still crashes with a 'program error'.

Edited by Ploddles
Update
Link to post
Share on other sites
On 10/21/2020 at 7:22 PM, Ploddles said:

Photoshop and Lightroom both crash out now. Strange that it is a different dylib file that is causing the crash.

 

I may try to install the old version of PS and copy the old version of the offending library file across to the new PS and see if that does anything for us. Just a PITA for Adobe to do this to us.

 

EDIT:-

Replaced the 2 offending dylib files. This time it gets a bit further, the splash screen loads, but it still crashes with a 'program error'.

Edited Wednesday at 09:29 PM by Ploddles

I just renamed photoshop 2020 and installed the update (which is photoshop 2021), old still works if saved.

Link to post
Share on other sites
  • Supervisor

ei @DriftwoodI hope all is fine

 

I think @Ploddlesas me, is trying to have a working 2021 in our AMD

And if I have understood well he wanted to try to use old library (with new one fail PS 2021 for us) and see

but in my case no joy

to many dependences I see in those new library..and by the way..intel stuff is present the same in this 2021 "arm" release

  • Like 1
Link to post
Share on other sites

If you install both the 2020 and 2021 versions, the 2020 version may also stop working because of a shared version of Camera Raw - V13.0

 

To get over this you can download and install the old 12.4 version. Download Link.

Remember to disable auto updates or V13.0 will be installed again.

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

@fabiosun: Thanks for the Proxmox guide! ¬†Although¬†my bare metal hack (Gigabyte Designare 3070X) is running well with Big Sur (with just the sleep problem to content with), I can't run Photoshop or Davinci Resolve. ¬†Just download the Resolve 17 beta, it's still crashing at startupūü§®¬†¬†I've also tried all the patches from here (https://gist.github.com/naveenkrdy/26760ac5135deed6d0bb8902f6ceb6bd); these patches¬†help with starting Photoshop, but it¬†will crash if I do any editing!

Link to post
Share on other sites
  • Supervisor

@shutterbug168

Davinci 17.1B beta 3 works (not tested other versions (it should be first release with Arm M1 compatibility)

 

1703194786_ScreenShot2020-11-15at4_11_14PM.png.7d680afee2ad107f68f360683f719404.png

Above is photoshop version I use

If you patch correctly it works well

also Liquify and camera raw and all filters without problems 

Photoshop V22 for now has many problems

2006148011_ScreenShot2020-11-15at4_14_17PM.thumb.png.f9c7a4405fe6b7430d843bd4e3f86cd0.png

 

  • Like 1
Link to post
Share on other sites
1 hour ago, shutterbug168 said:

@fabiosun: Thanks for the Proxmox guide! ¬†Although¬†my bare metal hack (Gigabyte Designare 3070X) is running well with Big Sur (with just the sleep problem to content with), I can't run Photoshop or Davinci Resolve. ¬†Just download the Resolve 17 beta, it's still crashing at startupūü§®¬†¬†I've also tried all the patches from here (https://gist.github.com/naveenkrdy/26760ac5135deed6d0bb8902f6ceb6bd); these patches¬†help with starting Photoshop, but it¬†will crash if I do any editing!

 

There are a few different versions on there, the ones you want to use if you have Photoshop 2021 are :-

 

 

for file in MMXCore FastCore TextModel libiomp5.dylib libtbb.dylib libtbbmalloc.dylib; do
find /Applications/Adobe* -type f -name $file | while read -r FILE; do
sudo -v
echo "found $FILE"
[[ ! -f ${FILE}.back ]] && sudo cp -f $FILE ${FILE}.back || sudo cp -f ${FILE}.back $FILE
echo $FILE | grep libiomp5 >/dev/null
if [[ $? == 0 ]]; then
dir=$(dirname "$FILE")
[[ ! -f ${HOME}/libiomp5.dylib ]] && cd $HOME && curl -sO https://excellmedia.dl.sourceforge.net/project/badgui2/libs/mac64/libiomp5.dylib
echo -n "replacing " && sudo cp -vf ${HOME}/libiomp5.dylib $dir && echo
rm -f ${HOME}/libiomp5.dylib
continue
fi
echo $FILE | grep TextModel >/dev/null
[[ $? == 0 ]] && echo "emptying $FILE" && sudo echo -n >$FILE && continue
echo "patching $FILE \n"
sudo perl -i -pe 's|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg' $FILE
sudo perl -i -pe 's|\x90\x90\x90\x90\x56\xE8\x4A\x00|\x90\x90\x90\x90\x56\xE8\x1A\x00|sg' $FILE
done
done

AND THEN

[ ! -d $HOME/Library/LaunchAgents ] && mkdir $HOME/Library/LaunchAgents
AGENT=$HOME/Library/LaunchAgents/environment.plist
sysctl -n machdep.cpu.brand_string | grep FX >/dev/null 2>&1
x=$(echo $(($? != 0 ? 5 : 4)))
cat >$AGENT <<EOF

Label mkl-debug ProgramArguments sh -c launchctl setenv MKL_DEBUG_CPU_TYPE $x; RunAtLoad EOF launchctl load ${AGENT} >/dev/null 2>&1 launchctl start ${AGENT} >/dev/null 2>&1

After Camera Raw 12.4 installed, run:-

sudo perl -i -pe 's|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg' /Library/Application\ Support/Adobe/Plug-Ins/CC/File\ Formats/Camera\ Raw.plugin/Contents/Frameworks/libtbb.dylib

sudo perl -i -pe 's|\x90\x90\x90\x90\x56\xE8\x4A\x00|\x90\x90\x90\x90\x56\xE8\x1A\x00|sg' /Library/Application\ Support/Adobe/Plug-Ins/CC/File\ Formats/Camera\ Raw.plugin/Contents/Frameworks/libtbb.dylib

sudo perl -i -pe 's|\x90\x90\x90\x90\x56\xE8\x6A\x00|\x90\x90\x90\x90\x56\xE8\x3A\x00|sg' /Library/Application\ Support/Adobe/Plug-Ins/CC/File\ Formats/Camera\ Raw.plugin/Contents/Frameworks/libtbbmalloc.dylib

sudo perl -i -pe 's|\x90\x90\x90\x90\x56\xE8\x4A\x00|\x90\x90\x90\x90\x56\xE8\x1A\x00|sg' /Library/Application\ Support/Adobe/Plug-Ins/CC/File\ Formats/Camera\ Raw.plugin/Contents/Frameworks/libtbbmalloc.dylib

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.