Jump to content
You are a guest user Click to join the site
ziocharly

Aggiornamento a Catalina (10.15.7) sulla vecchia Asus X58

Recommended Posts

Saluti a tutti,

come da titolo, secondo Voi vale la pena provare, o meglio svecchiare l'hardware...

 

Sto usando ancora Clover V.5118 e funge tutto perfettamente, ma ho un nuovo SSD e mi piacerebbe provare.

 

 

Share this post


Link to post
Share on other sites

...questo silenzio mi sta convincendo a desistere... 😉

 

Qualcuno sa la versione di Clover idonea a Big sur

e magari qualche dritta su come settare i nuovi parametri....

Edited by ziocharly

Share this post


Link to post
Share on other sites

Ciao, l'ultima versione

ma non ti basta aggiornare clover e via, devi adattarlo, riconfigurarlo etc

ci sono topic guida che puoi seguire come molti altri di utenti che hanno fatto o stanno facendo proprio la stessa cosa

Share this post


Link to post
Share on other sites

penso che non dovresti avere molti problemi,

la tua x58 è Uefi?

Share this post


Link to post
Share on other sites

@Gengik, si questo lo so, chiedevo dove prendere spunto per un chipset così vecchio (Tylersburg).

Ho letto un pò per open core, ma mi é venuto mal di testa...


@carlo_67, no é ancora il vecchio bios legacy...

 

 

Share this post


Link to post
Share on other sites

Volevo aggiornare la situazione di avanzamento operazioni, dopo i consigli di Gengik ed i test effettuati,
magari potrà servire come approccio a chi si avvicina all'aggiornamento, da una versione funzionante di Catalina (10.15.7),
su hack vecchiotti :

 

> Ho clonato su un nuovo SSD il sistema funzionate con carbon copy e mi sono accertato che partisse regolarmente (giusto per aver un banco di test e non rischiare nulla)

> Ho aggiornato Clover, sino alla V.5122, nessun problema, ma alla V.5124 occorre mettere mano ai kext e ai quirks

> Quindi, rimosso tutti i kext in uso, piazzati gli indispensabili in 'other' (WEG, FakeSmc, Lilu) e i due per i controller HD e ethernet di Asus (Marvell e Yukon) 

> Aggiornato a Clover V.5126

> Inserito i quirks suggeriti da Baio77, in un post trovato in rete (non so se servono tutti)...

 

Ora il boot funziona regolarmente, ma con due grossi problemi :

> Dopo circa 30-40 sec. effettua da solo il reboot (dovrebbe essere la mancanza di nullcpupowermanagement.kext)

> Non vedo gli HD connessi al controller ICH10 della MB (già prima usavo una patch, che probabilmente con il nuovo Clover non funge +) 

 

Avete consigli, o provo ad aggiornare comunque a Big Sur ?

 

Share this post


Link to post
Share on other sites
6 minuti fa, ziocharly ha scritto:

Inserito i quirks suggeriti da xxxy

se vedi link in firma, Clover quirks, new e BLC, ci siamo attrezzati

 

6 minuti fa, ziocharly ha scritto:

Dopo circa 30-40 sec. effettua da solo il reboot (dovrebbe essere la mancanza di nullcpupowermanagement.kext)

devi abilitare il quirks dummypower

 

7 minuti fa, ziocharly ha scritto:

Non vedo gli HD connessi al controller ICH10 della MB (già prima usavo una patch, che probabilmente con il nuovo Clover non funge +) 

le patch funzionano ancora, solo che il percorso kext va inserito per intero, esempio pratico, quello per le icone arancioni, con vecchio clover

AppleAHCIPort

andava bene, con nuovo Clover come per OC deve essere cosi

com.apple.driver.AppleAHCIPort

Share this post


Link to post
Share on other sites

@iCanaro 

ho visto i link in firma, spettacolare, sto seguendo il tuo post,
mi mancava 'openruntime.efi' sottoClover/drivers/uefi, l'ho aggiunto.

 

Per gli HD ho corretto il percorso con 'com.apple.driver.AppleAHCIPort' e rivedo nuovamente i drive !

Grazie infinite per la dritta !!!

 

Per il boot improvviso dopo qualche minuto, sfortunatamente,

non é bastato il quirks 'dummypowermanagemen', lo fa ancora....

 

Direi che é meglio stabilizzare, prima di avventurarsi con l'aggiornamento a Big sur....

 

 

Edited by ziocharly
  • Like 1

Share this post


Link to post
Share on other sites
15 minuti fa, ziocharly ha scritto:

Per il boot improvviso dopo qualche minuto, sfortunatamente,

non é bastato il quirks 'dummypowermanagemen', lo fa ancora....

con il kext NullCpuPowerManagement che succede?

Share this post


Link to post
Share on other sites
9 minuti fa, ziocharly ha scritto:
1 minuto fa, iCanaro ha scritto:

con il kext NullCpuPowerManagement che succede?

 

 

non dovrebbe servire ne Null ne dummy con quella piattaforma

Share this post


Link to post
Share on other sites
Adesso, carlo_67 ha scritto:

non dovrebbe servire ne Null ne dummy con quella piattaforma

non ho idea, mai avuto X58, mi attengo a quanto diceva lui

 

6 ore fa, ziocharly ha scritto:

> Dopo circa 30-40 sec. effettua da solo il reboot (dovrebbe essere la mancanza di nullcpupowermanagement.kext)

 

Share this post


Link to post
Share on other sites

be io personalmente ho istallato una Sabertoot x58 con su una 780 

e ho una p5q e non li ho mai usati, non so che smbios sta usando ora Zio, 

ma un iMac 14,xx sarebbe consono e non andrei oltre, quindi Big nisba

 

Share this post


Link to post
Share on other sites

Intanto grazie per i commenti,

confermo che 'dummypowermanagement' sembra aver sanato, al primo tentativo distrattamente non ho salvato il config.plist...

 

Visto il sistema stabile e completamente funzionante, nuovamente con Catalina 10.15.7 e boot da Clover V.5126,

mi sono lanciato all'installazione di Big sur, che é arrivata fino alla fine chiedendomi il riavvio.

 

Ma poi subito un bel KO :

 

Big_crash.thumb.png.b19e56f7e1c6b98a6ebae3e1c09f39f8.png

 

Fortunatamente al boot Clover mi lascia partire ancora con Catalina funzionante...

Qualcuno ha idea di cosa gli manca ?! 

 

Allego la EFI in uso.

EFI.zip

Edited by ziocharly

Share this post


Link to post
Share on other sites
25 minuti fa, ziocharly ha scritto:

Qualcuno ha idea di cosa gli manca ?! 

visti i 31Mb della EFI, a me pare manchi niente 😂

 

togli aptio da BIOS

elimina cartelle driver64 e drivers64UEFI

sposta tutti i kexts da other a cartella macOS che usi, se catalina 10.15

crea cartella 11 e mettici LILU WEG VirtaulSMC

e riprova

Share this post


Link to post
Share on other sites

...e la EFI era giá ripulita dai temi...  😂

 

> Tolto aptioinputfix.efi e aptiomemoryfix.efi

> Tolto cartelle driver64 e driver64uefi

> Creata cartella 11, con solo lilu, weg, virtualsmc (tutti aggiornati)

 

...stesso blocco del capture allegato sopra,

sembra che non trovi qualcosa...

 

PS : Catalina parte sempre bene, anche dopo le correzioni.

Edited by ziocharly

Share this post


Link to post
Share on other sites

@iCanaro, grazie infinite per l'aiuto !

 

Sostituita integralmente la EFI, con la tua postata qui, sfortunatamente cambia l'output, ma sempre freeze :

 

Crash_2.thumb.png.d172992bc0819e585e3a469069e9f083.png

 

Al boot Clover propone 3 partizioni : BigSur, Catalina_data e Catalina, ma adesso non parto più con nessuna...

Con BS e Catalina_data ottengo il panic qui allegato,

con Catalina, va avanti sino a lasciare il verbose e al momento di avviare la grafica (GTX770) resta lo schermo nero...

 

Ho ripristinato la vecchia EFI, sul disco clone, dal disco originale NON cambiato.

 

Umhhh, da dove riparto....

 

 

 

Edited by ziocharly

Share this post


Link to post
Share on other sites

@iCanaro, mi é venuto un dubbio :

 

nella EFI che mi hai allegato NON c'era il folder APPLE,

io l'ho semplicemente sostituita alla mia, dovevo mica fare un merge ?!

 

Grazie per tutto il supporto e la pazienza !

 

Share this post


Link to post
Share on other sites
3 ore fa, ziocharly ha scritto:

nella EFI che mi hai allegato NON c'era il folder APPLE,

serve a niente, ma comunque basta copi la tua

 

4 ore fa, ziocharly ha scritto:

con Catalina, va avanti sino a lasciare il verbose e al momento di avviare la grafica (GTX770) resta lo schermo nero...

prova ad aggiungere boot-art

nv_disable=1

 

cmq davo per scontato che le prove le facessi con una pendrive, o perlomeno se hai messo mia EFI su disco, tieni la tua che ti avviava su pendrive

 

la cosa più rapida per test sarebbe usare BLC, vedi link in firma

poi in EFI lasci tua cartella CLOVER e la mia o altre la aggiungi chiamandola ad esempio CLOVERTEST

 

così facendo puoi immediatamente essere operativo senza sbattimenti di pendrive etc...

Share this post


Link to post
Share on other sites

Allora, 

 

Si, ho copiato il mio folder Apple, e il mio folder Themes che era vuoto nella EFI postata.

 

OK, provo ad aggiungere i due switch che mi hai suggerito.

 

No, sto facendo tutto dal disco clone, come dicevo, ho copiato con Carbon copy l'SSD funzionante

con Catalina (10.15.7) e Clover 5115, e da li ho aggiornato Clover alla V.5126, kext e quirks,

e poi lanciato l'aggiornamento a Big sur direttamente dallo store.

 

In effetti sto rinominando il folder Clover, se ho problemi torno indietro, come fatto ieri.

Non conosco BLC, proseguo i test questa sera, speriamo 😰

 

GRAZIE !

Edited by ziocharly

Share this post


Link to post
Share on other sites

ok per ‘nv_disable=1’, ma ‘boot-art’ non l’avevo mai sentito...

E’ corretto?

 

Catalina parte di nuovo, ma in bassa risoluzione... no nvidia...

 

Big sur stesso panic allegato ieri...

Edited by ziocharly

Share this post


Link to post
Share on other sites

Per test ho creato anche la chiave USB, con il media installer, configurata allo stesso modo dell' SSD,

ma perché il comportamento é diverso ?

 

Il boot in questo caso si ferma qui :

 

Crash.thumb.png.87e5e24aab0fdd27722f2cce7abe16c0.png

Edited by ziocharly

Share this post


Link to post
Share on other sites

devi modificare/lavorare sulla sezione quirks, lo puoi fare anche la volo da GUI Clover al boot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.