Jump to content

New Clover on AMD platform


Recommended Posts

  • Support Team

For those interested, currently the new Clover manages to start mojave, catalina and big sur beta 9 correctly

of course it is all "work in progress" and in my opinion the situation can only improve for the AMD user.
Having over OC also Clover on platforms like my X570, which until recently could not even start, is very positive.
Two boot loaders are better than one  
  😉

 

 

BS.png.68b7ad09182a3af2760173fa4b387db2.

 

Clover 5134 5124

config-BS.plist.zip config-moj_cata.plist.zip

config-CATA_MOJ_26.plist.zip config-CATA_BS_29.plist.zip config-CATA_BS_38.plist.zip

 

 

20-10-2020 -> CloverV2-5125-e80852a82 ->  https://www.macos86.it/files/file/89-clover-release-beta/

 

Clover_Patch_29-moj_cat_bs.plist.zipClover_Patch_38-moj_cat_bs.plist.zip

boot mojave, catalina big sur

 

Clover_Patch_35plus-moj_cat_bs.plist.zip

 

small evolution of the previous 3 plists

Clover_Patch_38-hs_moj_cat_bs.plist.zipClover_Patch_35plus-hs-moj_cat_bs.plist.zipClover_Patches_30-moj_cata_bs.plist.zip

 

correct config 35plus as there was a kext to patch aquantia, it did nothing but it was useless and superfluous

Clover_Patch_35+-hs-moj_cat_bs.plist.zip

 

:nov: 23-10-2020

Clover_17H_Patches38_MatchOS_Empty_X_All.plist.zip

 

This is the KernelToPatch that I have decided to adopt for the time being
is that of OC converted for Clover.
The MatchOS field where they were invoked 
10.13.x,10.14.x,10.15.x,11.x
were left empty
while I defined those where one or two macOS is invoked
Limit has been commented on and not converted to RangeFind

 

  • Like 2
  • Thanks 1
Link to post
Share on other sites
  • Support Team

I updated the initial post by adding 3 configs with 17h Patch kernel

To use with Clover 5125 or 5124 that you can download here

 

https://www.macos86.it/files/file/89-clover-release-beta/

 

before goodnight
KernelToPatch for the operation of AMD systems
I "enjoyed" working a bit using the existing patches and:

26-patch config that starts Catalina and Mojave
29-patch config that starts Catalina and BS
38-patch config that starts Catalina and BS

 

Link to post
Share on other sites
  • Support Team

added in initial post evolution of the config-BS created by @fabiosun
tested and working in mojave, catalina and big sur
the 35plus refers to that i added the new fix pat that increases the performance of the gpu but leaving the old present and disabled

 

if you want to try it @SavageAUS

Link to post
Share on other sites
  • Supervisor

if possible when we say..it works or it doesn't work a config.plist, we have also specify well with which clover commit exactly it is work or not

IE

I have posted a plist which generate some of the plist posted here and also on IM working with Big Sur

my plist does not work anymore in 5125 in my rig

in 5124 it is working the same

so I think we have to be more clear about config and commit used if possible

 

  • Like 1
Link to post
Share on other sites
  • Supervisor

With beta 10 and clover 5125 as op amd trx40 does not boot if matchos is present

deleting matchos tab allows system to boot

but, in this way other system, in my case high Sierra,does not boot anymore

  • Like 1
  • Sad 1
Link to post
Share on other sites
On 10/19/2020 at 12:08 AM, fabiosun said:

@jsl2020  if you want post here your working config with OpenCore and your actual clover EFI you want to try to boot 🙂

 

I need your help to check and fix my Clover's EFI settings which can not boot successfully to desktop yet after integrated with OC.

The working config.plist of Opencore is attached for your reference.

My hardware is Ryzen 1700X CPU with AMD RX-570 GPU.

config-OC.plist.zip EFI.zip

Edited by jsl2020
Link to post
Share on other sites
44 minutes ago, fabiosun said:

first try to delete matchOS data in your config..

Follow also indication @iCanarodid in OP because he has a similar CPU than your 🙂

Thanks for your advice.

However it still failed to boot to desktop after delete matchOS data.

It always hang after "previous shutdown cause: 5" appears.

Link to post
Share on other sites
  • Support Team

on the T-RyZo I could not update with Clover, the first phase went well; the last part of the installation if it goes, I couldn't find a way to get it going, I finished with OC 062 stable

then BS beta 10 starts well with Clover 5125, but not with all 5125.

Schermata 2020-10-21 alle 13.17.57.png

 

I currently use the Clover Patches 30 download in the opening post @jsl2020

Link to post
Share on other sites
12 hours ago, iCanaro said:

on the T-RyZo I could not update with Clover, the first phase went well; the last part of the installation if it goes, I couldn't find a way to get it going, I finished with OC 062 stable

then BS beta 10 starts well with Clover 5125, but not with all 5125.

Schermata 2020-10-21 alle 13.17.57.png

 

I currently use the Clover Patches 30 download in the opening post @jsl2020

Thanks for your prompt reply.

After applied with your 5125-e80852a82 version and Clover patches 30 it still hang at "previous shutdown cause: 5".

[Solved]

I need delete SMCHelper.efi and add several SSDT-*.aml to fit my hardware and Clover bootloader.

Edited by jsl2020
Link to post
Share on other sites
  • Support Team
1 ora fa, jsl2020 ha scritto:

After applied with your 5125-e80852a82 version and Clover patches 30 it still hang at "previous shutdown cause: 5".

evidently there are still several things to fix, on my X570 they work and I have no way to try for other CPUs and AMD platforms
sorry

Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.