Jump to content

[Discussion] - TRX40 Bare Metal - Vanilla Patches


Recommended Posts

https://github.com/Lucretia/hack-howto#no-access-to-iservices

 

I got my usb Ethernet adapter to work on all the iCloud services 🙂 . YEAHHHHHHHH. I follow the guide it was easy all I did was spoof my USB Ethernet adapter by adding the ssdt-rmne.aml to ACPI and NullEthernet to kext and I used Proper Three to commit and VOALA All Apple Services are  working on Ventura and Monterey 🙂

USB ETHERNET FIX .zip

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • Supervisor

@valmeidait is an easy solution here (if this one is the working one with monterey and Ventura)

You have to add kernel patches useful for BigSur because here they are missing!

config.plist.zip

here is the same your working config with all kernel patches added for your CPU

Link to post
Share on other sites
10 hours ago, fabiosun said:

@valmeidait is an easy solution here (if this one is the working one with monterey and Ventura)

You have to add kernel patches useful for BigSur because here they are missing!

config.plist.zip 7.36 kB · 3 downloads

here is the same your working config with all kernel patches added for your CPU

Works like a champ. Thanks I can boot to Windows 11 , Big Sur , Monterey, Ventura from Open core :-). Now if I can get my aquatia or wireless card to work that would be amazing . Baby steps 

  • +1 1
Link to post
Share on other sites
  • Supervisor

@Simras

 

read and ask in this thread

many Gigabyte trx40 users here and also a couple of users with a 3990x well configured

then, if you like create a your own thread and I and others could try to help you to have your system alive & kicking 🙂

 

  • +1 1
Link to post
Share on other sites
  • Supervisor

Beta 5 of Ventura is safe to install👍

image.png.a820361402f63fa2395fea0802f32844.png
 

without restrictevents kext some i have been shown in system information 

 

  • Thanks 1
Link to post
Share on other sites
  • Supervisor

unknown.png.b91b77ddb7340b5bd4ed079070c2cbcd.pngScreenshot_2022-08-08_at_9_43.39_PM.thumb.png.c62a4c95424184ad729f4855f2e1ca6c.png

 

Monterey and Ventura with same app and kexts

 

Last login: Mon Aug  8 21:45:05 on console
fabio@fabios-Mac-Pro ~ % kextstat | grep -v com.apple      
Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
   54    2 0                  0x2f000    0x2f000    as.vit9696.Lilu (1.6.2) 264B15BE-8923-3A33-A9F5-8F0FFBB80595 <9 7 6 3 2 1>
   55    0 0                  0x20000    0x20000    wtf.spinach.AMDRyzenCPUPowerManagement (0.7.1) 08416898-FC70-3057-9256-34AC0F79D0C0 <54 17 13 9 7 6 3 2 1>
   63    0 0                  0x1a000    0x1a000    as.vit9696.VirtualSMC (1.3.0) 40CF5E80-248F-35B7-833D-2DABF724B391 <54 16 9 7 6 3 1>
fabio@fabios-Mac-Pro ~ % 

Navi 2 is seen by HWMonitorSMC app with many of its features in Ventura 

In monterey no

 

App seems  not anymoreupdated and has some bug in Ventura 

It is interesting that using internal OSX IOKit for GPU, now with Ventura, many data are exposed!

 

  • Ok 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.