Jump to content
You are a guest user Click to join the site
dangia

Hack che freeza

Recommended Posts

Ragazzi qualcuno sa perchè ogni tanto mi succede che il pc si blocchi improvvisamente mentre non sto facendo nulla di particolarmente impegnativo?

Emette dei suoni per qualche secondo tipo corrente elettrica ed il cursore del mouse inizia a dare i numeri, poi si blocca completamente e mi tocca fare un reset manuale.

Ho Catalina con questa configurazione:

Asus TUF z370 Gaming Plus II

Intel i7 9700

Sapphire Radeon RX580

SSD Silicon Power NVMe 512GB

RAM 8X2 Crucial ballistix

Share this post


Link to post
Share on other sites

Per prima cosa, passa nel thread presentazioni... poi

 

opzione A:

Spoiler

SFERA_MAGA.jpg.103140dea3f2cbf580951c9e88c00adc.jpg

 

opzione B:

 

posta hack_info ed EFI (senza cartella Apple)

se non capisci di che parlo, prima di domandare clicca e leggi FAQ che ho in firma

 

L'alimentatore è una cosa seria, degna del resto dell'hardware elencato?

marca e modello esatto

 

  • +1 1

Share this post


Link to post
Share on other sites

Perdonami, sono nuovo del forum e di hackintosh, la EFI la allego volentieri ma non ha cartelle Apple, credo sia dovuto al fatto che è con OpenCore.

L'alimentatore è un Leadex III super flower 80 plus gold modulare da 650watt.

Al momento, in attesa della Fenvi T919 ho una chiavetta wifi Tp-Link

EFI.zip

Share this post


Link to post
Share on other sites

Salve a tutti, io e @A23SS4NDROabbiamo aiutato @dangia nell'acquisto dei pezzi compatibili con macOS, nonchè l'installazione di macOS. Dopo un'odissea dovuta all'SSD che dava problemi, siamo riusciti a portare la macchina ad uno stato decente. Tuttavia, ci sono alcuni problemi da risolvere:

- Audio basso dal jack 3.5mm (testeremo personalmente i layout-id)
- Freeze improvvisi del sistema

 

Per quanto riguarda la seconda problematica, nonostante l'accesso in lettura-scrittura all'MSR 0xE2 sia abilitato (CFG Lock disattivo), ogni tanto il sistema è soggetto a questi freeze. Avete qualche idea? 

Grazie mille

 

Share this post


Link to post
Share on other sites

qualcuno ha modificato ssdt x hack di gengik?

Share this post


Link to post
Share on other sites
Posted (edited)
12 minuti fa, iCanaro ha scritto:

qualcuno ha modificato ssdt x hack di gengik?

Sono state mappate le porte USB...altro non so.

io adesso ho questo però

Schermata 2020-05-26 alle 11.14.35.png

Edited by dangia

Share this post


Link to post
Share on other sites
38 minutes ago, iCanaro said:

qualcuno ha modificato ssdt x hack di gengik?

Si ho modificato il mio tempo fa, avevo sistemato alcune cose per me, e dal momento che ho anche la Z370 TUF Gaming II quando ci abbiamo lavorato avevo preso come base la mia configurazione funzionante uguale alla sua

 

Vi mostro un paragone delle correzioni che ho fatto per il mio

photo_2020-05-21_12-53-50.jpg.abffedaf4deed87e747ebb4343504896.jpg

 

ovviamente in fondo ci sta la parentesi finale per

 

If (_OSI("Darwin"))

{


}

 

Inoltre con l'arrivo di Catalina (Solo per la mia build, dal momento che nascondere EC0 non serve per la motherboard Z370 TUF Gaming) è stata anche implementata questa miglioria (da SSDT Kaby Coffelake PM) fatta da Gengik stesso in questo post, e poi ha mandato il nuovo SSDT con questa modifica (ripeto, questa modifica non è presente sull'SSDT in uso ora nella build di @dangia perché non necessaria, vedendo il suo DSDT)

 

photo_2020-05-21_12-53-51.jpg.28be1dd3b0caf34d3216837c87e4df6c.jpg

 

 

Fonti:

 

 

Anzi, personalmente ritengo che sarebbe carino integrare il riconoscimento dinamico di EC0 e PM in tutti i suoi ssdt se possibile 😃

 

 

Share this post


Link to post
Share on other sites
4 minuti fa, A23SS4NDRO ha scritto:

Anzi, personalmente ritengo che sarebbe carino integrare il riconoscimento dinamico di EC0 e PM in tutti i suoi ssdt se possibile 😃

 

C'è SSDT-Basic, usa quello.

Share this post


Link to post
Share on other sites
Just now, Gengik84 said:

C'è SSDT-Basic, usa quello.

Si certo, ma funziona già tutto ok sulla mia

 

Se volete la certezza controllate ioreg suo

Share this post


Link to post
Share on other sites
1 minuto fa, A23SS4NDRO ha scritto:

Si certo, ma funziona già tutto ok sulla mia

 

Se volete la certezza controllate ioreg suo

 

appena sfornato

iMac di Daniele.zip

Share this post


Link to post
Share on other sites
15 minuti fa, A23SS4NDRO ha scritto:

Si certo, ma funziona già tutto ok sulla mia

 

si ma non capisco la tua richiesta precedente visto che c'è già Basic

Share this post


Link to post
Share on other sites
10 minutes ago, Gengik84 said:

si ma non capisco la tua richiesta precedente visto che c'è già Basic

SSDT CoffeLake e tutti gli altri hanno molti altri device oltre a EC0 e PM, certo in effetti possono usarli entrambi in maniera separata...

Share this post


Link to post
Share on other sites
4 minuti fa, A23SS4NDRO ha scritto:

SSDT CoffeLake e tutti gli altri hanno molti altri device oltre a EC0 e PM, certo in effetti possono usarli entrambi in maniera separata...

Di cosa parli esattamente?

se usi basic non devi usare altro

Share this post


Link to post
Share on other sites
31 minutes ago, Gengik84 said:

Di cosa parli esattamente?

 

Per esempio solo guardando le external references ci sono alcuni device che mancano su SSDT-Basic

 

Per esempio tutti quelli che di norma sono gestiti da WeG, era carino averli su SSDT Coffelake, cosa che non è presente su SSDT Basic, mando uno screen (Unico è _PR_.PR00 che è presente sia su SSDT Basic che SSDT coffelake)

 

1763193906_Screenshotat2020-05-2613-09-43.png.870b41ec5f19907b32d81e7d1d4d245f.png

 

Questi device sono presenti solo su SSDT Coffelake, non su SSDT Basic...

Di qui dice


Name (SAT0._STA, Zero)  // _STA: Status
        Device (SATA)

Name (GFX0._STA, Zero)  // _STA: Status
        Device (IGPU)

Name (HECI._STA, Zero)  // _STA: Status
        Device (IMEI)
        Device (SBUS.BUS0)

 Method (_SB.PCI0.XHC._DSM, 4, NotSerialized)


 Scope (_SB.PCI0.PEG0)

    Device (GFX0)
    Device (HDAU)

 

Forse i device sopra elencati non servono, ma è carino averli su SSDT 

Share this post


Link to post
Share on other sites

Comunque al di là di questo, da ioreg è tutto apposto? 
Quali altre cose devono essere controllate per risolvere tali problemi di freeze?

Forse le kext installate su /L/E (dall'installer ufficiale della TP-Link) sono causa o fonte di questi problemi?

Share this post


Link to post
Share on other sites

Ale so i miei ssdt a memoria non c'è bisogno che tu mi metta le foto..😃

SSDT-Basic basta e avanza, non richiede nulla e nemmeno il rename per i dsm.

le cose che tu dici non mancano, ma non sono state messe di proposito e lasciate gestire ai kext acidanthera.

i vari ssdt come ho sempre io stesso detto hanno per esempio cose "cosmetiche"... completamente evitate su Basic.

Queste sono le motivazioni diciamo che permettono il funzionamento ovunque portando anche qualità.

 

3 minuti fa, A23SS4NDRO ha scritto:

Quali altre cose devono essere controllate per risolvere tali problemi di freeze?

Forse le kext installate su /L/E (dall'installer ufficiale della TP-Link) sono causa o fonte di questi problemi?

mi sembra strano siano i kext del wifi a dare dei freeze..tutto può essere ma mai visto un caso del genere.

Hai alcun log o report dopo tale problema?

i freeze possono anche essere grafici per esempio ma anche dovuti a configurazioni errate del bios, oppure anche problemi/incompatibilità hardware... esempio le ram

Share this post


Link to post
Share on other sites
1 minute ago, Gengik84 said:

Hai alcun log o report dopo tale problema?

 

@dangia dacci una descrizione più accurata di quando avvengono questi freeze, magari con qualche screenshot e in che circostanze riesci a ricreare il problema, hai provato con un solo banchetto RAM?

Share this post


Link to post
Share on other sites
5 minutes ago, Gengik84 said:

configurazioni errate del bios

 

@dangia per essere sicuri che tutte le impostazioni del bios sono corrette, inviaci cortesemente gli screenshot di tutte le sottosezioni

 

Ioreg com'è? tutto regolare?

Share this post


Link to post
Share on other sites

Posso ipotizzare: hai provato a togliere la chiavetta WiFi? Ultimamente mi è capitato di avere problemi su altre macchine, che si sono risolti nel momento in cui non andavo ad utilizzare la chiavetta USB WiFi.
Se ricordo bene hai la possibilità di collegarti tramite cavo LAN. Prova ad utilizzare solo il cavo LAN e vedi cosa cambia 🙂

  • +1 1

Share this post


Link to post
Share on other sites
9 minuti fa, A23SS4NDRO ha scritto:

Ioreg com'è? tutto regolare?

si è ok

quindi mi fa pensare o alla grafica o a qualcosa hardware/bios

riguardo al wifi come detto prima sono dubbioso ma in caso provate a rimuovere il kext da L/E, pannelo wifi etc.

 

Share this post


Link to post
Share on other sites
2 minutes ago, Gengik84 said:

si è ok

quindi mi fa pensare o alla grafica o a qualcosa hardware/bios

riguardo al wifi come detto prima sono dubbioso ma in caso provate a rimuovere il kext da L/E, pannelo wifi etc.

 

Sulla grafica sono dubbioso in quanto di fatto non è stata applicata alcuna patch per il framebuffer della iGPU, ne tantomeno per la dGPU giacchè è compatibile. Il BIOS è stato configurato a dovere ma per maggiore sicurezza andremo a controllare nuovamente le opzioni. 
Sono fermamente convinto che il problema sia la chiavetta USB WiFi

Share this post


Link to post
Share on other sites
1 minuto fa, dreamwhite ha scritto:

Sono fermamente convinto che il problema sia la chiavetta USB WiFi

possibile, di utenti ce ne sono molti ad aver installato e usato wifi con relativi driver tplink però nessuno ha avuto di queste problematiche

almeno per ora e su catalina

Share this post


Link to post
Share on other sites

Ok stasera vi mando le impostazioni BIOS, se mi dite quali sezioni volete ve le allego...

Ma la chiavetta wifi anche per quanto riguarda l'audio basso?

Share this post


Link to post
Share on other sites
1 ora fa, dangia ha scritto:

Ma la chiavetta wifi anche per quanto riguarda l'audio basso?

no no, per l'audio devi provare altri layout compatibili per il tuo codec

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.