Jump to content

Catalina su HP 840 G3 Elite Book


Recommended Posts

Salve a tutti,

sono nuovo di qui e dopo tanto tempo ho deciso di crearmi il mio primo hackintosh su notebook. Dopo tanti tentativi sono riuscito a inserire Catalina e in qualche modo anche a inserire driver video e audio. Gli unici problemi al momento che riscontro sono il touchpad (che va troppo veloce e non funzionano i tasti), la tastiera dove alcuni caratteri non riesco a riprodurli (tipo la chiocciola), il wifi (è una Intel AC8260, quindi dovrò provvedere quanto prima un wifi USB) e l'indicatore batteria che non riesco a visualizzarlo.

Avrei 2 quesiti:

1. Come posso risolvere i miei problemi rimanenti?

2. Su questo notebook ho 2 SSD separati, sul primo è installato Catalina, sul secondo avevo provato a inserire Windows, ma l'unico modo per farmi coesistere entrambi è avviare Clover dalla chiavetta usb, altrimenti avviava windows in automatico. Adesso ho eliminato windows, e finchè Catalina è da solo è ok, mi basta semplicemente sovrascrivere le cartelle di Clover dalla chiavetta alla cartella su SSD, ma nel momento in cui voglio inserire un secondo sistema operativo sull'altro SSD, Clover non viene nemmeno visto più. Ora sto provando Kubuntu come secondo sistema operativo ma credo che non risolverò nulla. Premesso che arrivato a questo punto, vorrei tentare un dual boot Catalina e Linux per avere un qualcosa di più versatile. Avete soluzioni anche su questo?

Se qualcuno riesce a darmi una mano ne sarei infinitamente grato.

 

Grazie

 

HP 840 G3 Elitebook

Intel i5 6300U 2.5Ghz Skylake

Intel UHD 520

Audio Conexant CX20724

RAM 12Gb DDR4 2133Mhz

SSD SanDisk 120GB + Western Digital 120GB

Link to post
Share on other sites
  • Administrators

Ciao il discorso di windows è risolvibilie, in caso ci sono le ottime guide di @netgear

per i tuoi problemi:

Estrai le acpi, per farlo premi F4 nella gui di clover e attendi 30 secondi, poi avvia normalmente.

comprimi e allega la cartella clover

Link to post
Share on other sites

Ecco qui il mio Clover...

Per il dual boot alla fine ho deciso che ritenterò con windows, ma prima andrò per gradi. 

E adesso si è presentato un altro problema: da quando ho inserito i programmi adobe, se spengo (quindi non riavvio) alla riaccensione mi va in kernel Panic e sono costretto a fare ripristino dalla chiavetta.

Cosa ho combinato?

 

Grazie

CLOVER.zip

Link to post
Share on other sites
  • Support Team
13 minuti fa, desmodromic ha scritto:

come faccio a darti il KP

fai foto e allegala come file zippato

 

ti sto controllando la EFI... 

Link to post
Share on other sites

Appena torno rimpiazzo e provo, grazie tante. 

Ah, domanda: nel momento in cui farò reinstallazione di windows sull'altro ssd, cosa devo fare per non intaccare nulla? Perché quando installo windows va ad intaccare comunque quella cartella e clover non funziona più andando poi a rimettere la cartella dopo e fare quel disastro che avevo già combinato. 

Link to post
Share on other sites

Sì, ma quando ripristinavo al Mac, si guastava windows. Faccio I comandi da dos per ripristinare efi di windows 10 e guasta Mac. A meno che non devo prendere la cartella efi di Microsoft dopo l'installazione e poi ripristinare la cartella efi di Mac mettendo insieme la cartella Microsoft, voi dite che funzionerà? 

Link to post
Share on other sites
  • Support Team

non stò capendo una mazza di che combini

45 minuti fa, desmodromic ha scritto:

e poi inserito il nuovo EFI, recupero il touch pad ma perdo in un colpo solo video, audio ed ethernet.

se intendi quella che ti ho passato, è minimale, serve per installare con il minimo dei kexts, si arriva al desktop in vesa

 

monta efi e apri gli occhiucci, dentro la cartella OFF ti ho lasciato i kext extra da testare uno alla volta per la tua LAN, sposti da OFF a other e riavvia

 

per la grafica, devi togliere il boot-arg 

-igfxvesa

per l'audio idem, sposti applealc da OFF a other ed inserisci nel config il layout del tuo codec... non sai quale è? no problem, esegui dump codec con F8 al boot e posta poi cartella misc

 

tutto quello che non capisci, hai risposta cliccando e leggendo FAQ che ho in firma

 

avere un'hack vuole dire costruire/affinare la build piano piano... non esiste EFI con dentro tutto e che va tutto al primo colpo... è come dire, voluto la bici!? ora pedala un po' 😉

Link to post
Share on other sites
  • Support Team

devi definire la grafica nel config

primo passo più semplice da provare

sezione graphics

flagga inject intel e definisci un ig-platform-id

nel tuo caso, skylake mobile, quindi

19160000

 

se non va, puoi provare

191b0000

poi eventualmente aggiungendo in devices --> fakeID GFX

19168086

Link to post
Share on other sites
  • Support Team
1 ora fa, desmodromic ha scritto:

Ho provato tutte le soluzioni, nulla... Non ne vuole sapere

passa il config con cui avvii

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.