Jump to content

Ubuntu danneggia EFI ad ogni avvio


Recommended Posts

Salve amici, nel mio Hackintosh ho due dischi

sul primo disco ho installato Catalina e utilizzo Clover come bootloader

sul secondo disco Ubuntu 18.04 ed utilizzo Grub come bootloader,

il problema è che ogni volta se li collego insieme grub mi danneggia clover non permettendomi più di avviare osx... la cosa strana è che grub è installato per fatti suoi nel disco perchè mi danneggia clover ?

come potrei risolvere il problema ? grazie mille e buona serata

 

PS: Quando ho scoperto questo forum completamente italiano è stata una gioia e spero di poter contribuire anche io ad aiutare gli utenti quando sarà mia competenza

Link to post
Share on other sites
  • iCanaro changed the title to Ubuntu danneggia EFI ad ogni avvio
  • Support Team

Ma esattamente che danneggia, ti sparisce l'entries di Clover dal BIOS o cosa???

Non uso ubuntu ma linux Mageia e di queste problematiche mai avute, forse ti può aiutare @fabiosun che di recente ha combattuto con ubuntu.

 

PS: ti ho modificato io il titolo, scrivere tutto maiuscolo, sul web, è equivalente ad entrare in un posto urlando, nella vita reale.

  • +1 1
Link to post
Share on other sites
  • Supervisor

Ubuntu da me scriveva sempre su una EFI presente su altro disco...

prova a verificare anche te..

Ma detto questo o acceso o spento mi partiva sempre regolarmente tutto

avevo solo nella EFI di OSX una cartella ubuntu con i suoi files di boot

 

  • +1 1
Link to post
Share on other sites

Ragazzi grazie per le risposte tempestive ! In pratica dal momento in cui avvio ubuntu ed è collegato anche il disco di OSX , il disco con a bordo OS X non mi comparirà più fra gli avviabili nel bios come se fosse un disco senza bootloader. Però la partizione efi rimane lì , è il bios a non riconoscerla più finché non formatto il disco è reinstallo tutto 😅

Link to post
Share on other sites
1 ora fa, fabiosun ha scritto:

Ubuntu da me scriveva sempre su una EFI presente su altro disco...

prova a verificare anche te..

Ma detto questo o acceso o spento mi partiva sempre regolarmente tutto

avevo solo nella EFI di OSX una cartella ubuntu con i suoi files di boot

 

Confermo, quando installai ubuntu la prima volta senza scollegare il disco con Osx, ubuntu andò a sovrascrivere i file di clover con i suoi file, poi ho reinstallato osx, e reinstallato Ubuntu facendo attenzione a dove andasse a mettere il bootloader,

quindi opra mi ritrovo con grub sul suo ssd, ed osx sul suo ssd con clover però appena avvio il disco con Ubuntu quello con osx non sarà più riconosciuto dal UEFI BIOS

Link to post
Share on other sites

Avrai un problema di sola Entries, ma essere c'è tutto, non credo che nulla sia cancellato, fai una pulizia da Shell:

 

bcfg boot rm 00

 

Ripetuto più volte e verifica che vede da BIOS, oppure disabilita il disco di Linux e fai pulizia e verifica...

 

Quando installi Ubuntu lui ti fa vedere dove mette il Grub, nella prima EFI, se non ti va bene lo cambi.

Link to post
Share on other sites
1 minuto fa, netgear ha scritto:

Avrai un problema di sola Entries, ma essere c'è tutto, non credo che nulla sia cancellato, fai una pulizia da Shell:

 

bcfg boot rm 00

 

Ripetuto più volte e verifica che vede da BIOS, oppure disabilita il disco di Linux e fai pulizia e verifica...

 

Quando installi Ubuntu lui ti fa vedere dove mette il Grub, nella prima EFI, se non ti va bene lo cambi.

dopo che avvio ubuntu anche scollegandolo il disco con osx non me lo trova più anche se i file almeno a vista rimangono inalterati

Link to post
Share on other sites
4 minuti fa, netgear ha scritto:

Anomalo, ripulisci le Entries come sopra e vedi se lo rivede, dopo aver scollegato Linux...

il problema è che non mi farà proprio arrivare alla schermata di clover per eseguire la pulizia delle entries, si comporta esattamente come se clover non ci fosse 

Link to post
Share on other sites

Il BOOT da Clover lo si può eseguire a prescindere, se non vuoi usare Grub invece puoi cancellare o svuotare la EFI di Ubuntu, ma anche lasciarla e avviare in EFISTUB come da guida postata poco sopra.

  • Thanks 1
Link to post
Share on other sites
1 ora fa, netgear ha scritto:

Il BOOT da Clover lo si può eseguire a prescindere, se non vuoi usare Grub invece puoi cancellare o svuotare la EFI di Ubuntu, ma anche lasciarla e avviare in EFISTUB come da guida postata poco sopra.

Proverò a seguire la guida sopra grazie 💪🏻

Link to post
Share on other sites
3 ore fa, netgear ha scritto:

Fermo restando che tutto deve funzionare anche in modalità "ordinaria"...

ciao netgear, cosa intendi per ordinario  ? giusto per chiarirmi le idee,

poi volevo chiederti un altra cosa.. ma una volta eliminate le entries si ricreeranno da sole ? 

grazie 🙂

Link to post
Share on other sites

ragazzi, comunque siete dei grandissimi no dei grandi ! il problema erano le Entries, in pratica appena ti metti a giocare con l'ordine di boot nel UEFI BIOS si corrompono le entries ma una volta ricreate funziona tutto a dovere ! Ubuntu direttamente da Clover senza aver fatto alcuna modifica ! grazie ancora 

 

PS: Dovrei installare anche windows, mi consigliate di scollegare il disco di osx prima di procedere con l'installazione ? lo chiedo perchè è un m2 quindi mi devo mettere a smontare il pc per disconnetterlo 🤣

Link to post
Share on other sites

SI appunto non avevi nulla che non andava, uno degli svataggi di alcuni Bios e Nvme e che nn puoi disabilitare il Disco, installa alle brutte sposti il Boot, oppure fai un preboot in VM, ma questa è un altra storia.

 

Puoi anche fare un Immagine della EFI di OS X, cancellarla, installare WIndows e rimetterla, in ogni caso nn è mai un problema...

Il problema delle Entries si presenta cmq sono installado OS X, in tutti gli altri casi tutto rimane al suo posto, da quando ripristino Immagini dalla VM senza installare Fisicamente non ho più dovuto cancellare una sola Entries, cmq sempre cancellare, sempre...

  • Thanks 1
Link to post
Share on other sites
  • 11 months later...
Il 30/3/2020 at 16:38, netgear ha scritto:

SI appunto non avevi nulla che non andava, uno degli svataggi di alcuni Bios e Nvme e che nn puoi disabilitare il Disco, installa alle brutte sposti il Boot, oppure fai un preboot in VM, ma questa è un altra storia.

 

Puoi anche fare un Immagine della EFI di OS X, cancellarla, installare WIndows e rimetterla, in ogni caso nn è mai un problema...

Il problema delle Entries si presenta cmq sono installado OS X, in tutti gli altri casi tutto rimane al suo posto, da quando ripristino Immagini dalla VM senza installare Fisicamente non ho più dovuto cancellare una sola Entries, cmq sempre cancellare, sempre...

Ciao, ti volevo chiedere una gentilezza.. potresti spiegarmi come convertire una macchina virtuale da vmware a disco fisico ( per evitare l'nstallazione fisica).

grazie mille 

Link to post
Share on other sites

Puoi usare questa soluzione l'esempio e per MAC ma non cambia nulla.

Installazione in VM

Immagine R-Drive

Ripristino R-Drive

Per creare un Immagine senza la VM di Windows si può montare il Disco VM Linux con OFSMount.

-

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.