Jump to content

Guida installazione - Mac OS X 10.13.6 High Sierra su Acer 5750g


Recommended Posts

aggiornamento e progresso, al DSDT_TEST allegato da @Gengik84 sono riuscito ad applicare le patch, batteria, brightness fix. non so perché ma con l'ultima versione di MaciASL non riuscivo a patchare e compilare il DSDT, ne ho ripreso una vecchia versione, compilando in iasl 4 e adesso tutto ok.

ora provo con l'audio, nel vecchio DSDT avevo iniettato il layout id 3 e nei kext in EFI messo AppleALC e LILU e andava tutto bene, non so perché ma se in Clover inserivo il layout 3 non funzionava, con la patch al DSDT invece si. adesso provo e vi aggiorno.

Link to post
Share on other sites

tutto ok e funzionante grazie mille sempre e ancora per gli insegnamenti @Gengik84

 

aggiornamento e progresso, al DSDT_TEST allegato da @Gengik84 sono riuscito ad applicare le patch, batteria, brightness fix, fix HPET, layout id 3 (audio), non so perché ma con l'ultima versione di MaciASL non riuscivo a patchare e compilare il DSDT, ne ho ripreso una vecchia versione, compilando in iasl 4 e adesso tutto ok.

tutte le patch applicate compresa quella di Gengik per spegnere la DGPU;

 

per scrupolo, prova e studio, ho ripreso il DSDT pulito da Origin, ho messo tutte le patch sopraelencate tranne quella di Gengik per spegnere la DGPU, ma in compenso ho inserito il SSDT_Disable sempre di Gengik e funziona tutto uguale.

 

tutto perfetto e ripeto GRAZIE SEMPRE MILLE, e non tanto per il laptop performante, ma per il modo in cui di DEDICHI A SPIEGARE LE COSE E AD INSEGNARLE 😊

  • Like 1
Link to post
Share on other sites
  • 6 months later...
Il 27/3/2020 at 10:00, eza ha scritto:

partiamo con il preparare la USB con la nostra installazione di HIGH SIERRA, seguendo questa guida di Gengik

Hai mantenuto il BIOS stock che è solo legacy o hai installato la versione modificata con il supporto UEFI?

Link to post
Share on other sites

Ho provato a seguire la guida (con BIOS modificato e UEFI attivato) dato che si tratta del mio modello nonostante io abbia la versione con Intel i5 2410M e grafica Nvidia Geforce 520M, solo che non riesco ad arrivare all'installazione. Ho provato anche con modifiche varie alle quirks che ho pescato tra forum, Reddit e gruppi Facebook, ho tentato sia una configurazione manuale della partizione EFI sia prendendo direttamente quella della guida, e ho anche riprovato un paio di volte a reinizializzare l'USB utilizzando anche versioni diverse di Clover, ma il risultato è sempre lo stesso, ovvero un bel kernel panic. Dopo essersi fermato qualche istante su EndRandomSeed seguito da una serie di + (che però mi sembra di notare anche all'avvio della macchina virtuale che ho usato per le configurazioni) l'avvio sembra riprendere, tuttavia si ferma con il seguente messaggio:

panic (cpu 0 caller 0x[numero esadecimale]): "Unable to find driver for this platform :\"MacBookPro8,1\".\n"0/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4570.71.2/lokit/Kernel/IOPlatformExpert.cpp:1783

Anche modificando i valori del SMBIOS il risultato non è cambiato. Ci può essere una soluzione o faccio meglio a lanciare il portatile dalla finestra?

Link to post
Share on other sites
  • 1 year later...

Ciao a tutti,

io ho lo stesso ACER 5750G, che sto usando ora per scrivere questo post, con stesso processore, etc.. e ho installato Mojave (10.14.6).

Per fare ciò è necessario "aggiungere" i kext della Intel HD3000 eseguendo l'utility "Fix Graphics HD 3000 Mojave-10.14". Per l'audio ho da sempre usato "VoodooHDA 2.9.2 Clover-V15" mentre per la porta USB 3 ho usato " USB 3.0 NEC ".

La NVIDIA l'ho disabilitata da BIOS.

i kext che stanno in EFI di clover sono:

- ACPIBatteryManager.kext

- FakePCIID_BCM57XX_as_BCM57765.kext

- FakePCIID.kext

- FakeSMC.kext

- mXHCD.kext

- ProBookAtheros.kext

- VoodooHDA.kext

- VoodooPS2Controller.kext

 

Pure io ho avuto problemi a ricompilare ACPI e ho risolto facendo delle correzioni "a orecchio". Evidentemente è codice che non viene utilizzato o mi è andata a culo.

 

Funziona tutto. Ma dato che sono pignolo, vorrei provare ad usare il file ACPI che mi sembra tu hai modificato in maniera "più scientifica". Mi puoi postare l'ultima versione?

 

Grazie!

image.png.0555fc06e24f1039084f49b3ee6726df.png

Link to post
Share on other sites
  • 2 months later...

ciao, sto provando ad installare Catalina sul 5750g ma sono proprio a digiuno...sto leggendo le varie guide ma ancora sono in alto mare...qualcuno che c'è riuscito può darmi una mano?...grazie

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.