Jump to content
You are a guest user Click to join the site
DS-1

Catalina su i7 2600k

Recommended Posts

Posted (edited)

Ciao ragazzi!

Sul sistema su cui ho attualmente High Sierra (i7 2600k, mb AsRock Z77 Pro3, 8gb RAM DDR3, GT 710 GK208) vorrei provare ad installare Catalina.

Il primo problema deriva dal fatto che, su questo sistema, non riesco a scaricare Catalina, evidentemente perchè l'SMBIOS è di un iMac late 2011. 

 

Vorrei dunque avere qualche dritta su come poter procedere.

 

Posto qui uno screenshot della mia configurazione di base e la mia EFI.

 

Grazie a tutti in anticipo per la risposta.

 

CLOVER.zip

Schermata 2020-03-26 alle 18.35.15.png

Edited by DS-1

Share this post


Link to post
Share on other sites

ti ho aggiornato la firma

 

devi cambiare SMBIOS, usa iMac13,2

 

perderai AGPM e con catalina non ti aspettare chissà che migliorie... high sierra ti conviene tenerlo sempre li

  • Like 1

Share this post


Link to post
Share on other sites

Pensi che io possa farlo senza apportare danni al boot in questione?

 

Share this post


Link to post
Share on other sites

tieni i kext separati quelli di 10.13 da quelli di 10.15, questo per dire, di non ficcare tutto in other

 

devi aggiornare clover, tutti i driver .efi che usi e kext alle più recenti release

 

e installa catalina in altra partizione... io ho sia mojave che catalina sulla mia Z68, e caty non è che sia il massimo, in particolare al boot

Share this post


Link to post
Share on other sites
2 minutes ago, iCanaro said:

tieni i kext separati quelli di 10.13 da quelli di 10.15, questo per dire, di non ficcare tutto in other

 

devi aggiornare clover, tutti i driver .efi che usi e kext alle più recenti release

 

e installa catalina in altra partizione... io sia mojave che catalina sulla mia Z68, e caty non è che sia il massimo, in particolare al boot

 

Per ora procederei così, correggimi se sbaglio:

 

- Metto la EFI su USB e booto da lì, con l'SMBIOS 13,2

 

- Se va tutto bene, scarico Catalina e poi procedo con gli aggiornamenti che mi hai consigliato

 

- Infine metto dentro un hdd vuoto e provo ad installare Catalina, usando la nuova EFI, contenente kext ed efi aggiornati

Share this post


Link to post
Share on other sites

tutto bene... catalina poi lo puoi installare da high sierra indirizzandolo appunto nel disco vuoto

 

non ti scordare il driver apfs che ora non usi, altrimenti non vedrai poi la partizione di catalina

  • +1 1

Share this post


Link to post
Share on other sites

Ok, sto preparando il tutto, ma mi sorge un dubbio, visto che ogni volta mi dimentico come si faccia: per l'audio (ALC892), bisogna lanciare qualche script dopo aver installato il tutto?

Share this post


Link to post
Share on other sites

no no... lo script ormai è deprecato... era il metodo di Toleda

oggi basta AppleALC.kext

Share this post


Link to post
Share on other sites

ma per favore.. AppleALC + 

Realtek ALC892 layout 1, 2, 3, 4, 5, 7, 12, 15, 16, 17, 18, 28, 31, 90, 92, 97, 99

 

uno di questi layout nel config devices audio inject

 

 

  • +1 1

Share this post


Link to post
Share on other sites

Giusto. Me lo scordo sempre.

Dunque posso usare il config.plist che ho postato all'inizio, solo con l'SMBIOS del 13,2?

Share this post


Link to post
Share on other sites
Posted (edited)

Ok, installazione portata a termine. Usando la EFI opportunamente backuppata da High Sierra ed avendola aggiornata con tutti i nuovi efi e kext, sembra funzionare tutto al primo colpo.

 

Ora ho installato Clover su hdd e vorrei copiare la EFI da cui ho bootato via USB sul disco fisso, ma ho letto che Catalina ha il file system in read only, non sapevo di questa novità, visto che è la prima volta che lo installo come hackintosh.

Edited by DS-1

Share this post


Link to post
Share on other sites

La partizione efi è a se, non c'entra con quel discorso

che poi se sei in uefi ti basta copiare semplicemente la efi della usb sul disco

  • Like 1

Share this post


Link to post
Share on other sites
Just now, Gengik84 said:

La partizione efi è a se, non c'entra con quel discorso

che poi se sei in uefi ti basta copiare semplicemente la efi della usb sul disco

 

Sì, sono in UEFI, ma non mi faceva copiare nulla nella root del disco Mac prima di aver lanciato questi:

 

sudo mount -uw /
sudo killAll Finder

 

Share this post


Link to post
Share on other sites

Problema relativo... per manutenzione kext & repair di gengik che trovi in download, ONYX fa sempre il suo dovere; poi se non vuoi stare sempre a scrivere comandi a terminale, io uso questa app

 

Share this post


Link to post
Share on other sites
Adesso, DS-1 ha scritto:

Sì, sono in UEFI, ma non mi faceva copiare nulla nella root del disco Mac prima di aver lanciato questi:

perchè nella root?

 

meglio senza dubbio su partizione EFI

Share this post


Link to post
Share on other sites
Just now, Gengik84 said:

perchè nella root?

 

meglio senza dubbio su partizione EFI

 

Per usare Clover in UEFI su partizione EFI devo semplicemente copiare il contenuto della usb nella partizione EFI dell'hdd e rimuovere la cartella EFI presente nella root dell'hdd?

Share this post


Link to post
Share on other sites

esatto

poi avendo una asrock di vecchia serie devi impostare il boot sul bios manualmente perchè altrimenti non avvia diretto.

puoi usare la shell oppure app

  • +1 1

Share this post


Link to post
Share on other sites
15 minutes ago, Gengik84 said:

esatto

poi avendo una asrock di vecchia serie devi impostare il boot sul bios manualmente perchè altrimenti non avvia diretto.

puoi usare la shell oppure app

 

Tempo fa ricordo che usai le Clover option per printare le entries. Ora però noto che questa opzione non funziona più, o meglio: nel bios AsRock mi trovo le nuove entries, ma poi nel pratico non boota e rientra nel bios.

Share this post


Link to post
Share on other sites

c'è la mia guida per efi shell oppure anche app citate e spiegate più volte da @iCanaro

  • +1 1

Share this post


Link to post
Share on other sites
22 minutes ago, Gengik84 said:

c'è la mia guida per efi shell oppure anche app citate e spiegate più volte da @iCanaro

 

Ricordo sia l'app citata da @iCanaro che la guida sulla efi shell tua, @Gengik84.

 

Per praticità ho usato la guida efi shell, dopo aver spostato la cartella EFI nella partizione EFI dell'hdd e dopo aver cancellato la cartella EFI dalla root dell'hdd.

 

Per ora è tutto ok. Ora cerco di recuperare il config.plist originale, che includeva boot entries personalizzate per il triple boot. Faccio questa prova e vi aggiorno.

  • +1 1

Share this post


Link to post
Share on other sites
1 ora fa, DS-1 ha scritto:

 

Tempo fa ricordo che usai le Clover option per printare le entries. Ora però noto che questa opzione non funziona più, o meglio: nel bios AsRock mi trovo le nuove entries, ma poi nel pratico non boota e rientra nel bios.

 

sarà pieno di entries fantasma... o usi la SHELL o BOOTICE da LivePE strelec o da windows
https://www.macos86.it/topic/1562-opencore-clover-boot-custom-entries/

ecco una idea di come procedere.. ocio, maneggiare con attenzione

  • +1 1

Share this post


Link to post
Share on other sites
Posted (edited)
18 minutes ago, iCanaro said:

 

sarà pieno di entries fantasma... o usi la SHELL o BOOTICE da LivePE strelec o da windows
https://www.macos86.it/topic/1562-opencore-clover-boot-custom-entries/

ecco una idea di come procedere.. ocio, maneggiare con attenzione

 

Era proprio questa la guida a cui facevo riferimento.

Per ora ho fatto tutto da shell. Poi dopo, quando avrò messo Catalina sull'hdd principale (non quello per le prove) e avrò sistemato il triple boot, pulirò le entries fantasma, che in effetti sono almeno 3-4.

Edited by DS-1

Share this post


Link to post
Share on other sites

Ho installato Catalina sull'hdd principale ed ora sto cominciando a configurare il triple boot. 

 

Come posso cancellare dal bios le entries fantasma, usando shell di Clover? So che da BOOTICE potrei fare prima, ma per ora non posso bootare in Win e quindi preferirei agire da shell.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.