Jump to content
You are a guest user Click to join the site
max70

amd Richiesta di aiuto [AMD 3700 X570 1050Ti]

Recommended Posts

Ecco, questa è la Efi del disco Mac che però si blocca subito appena cerco di far partire high Sierra che era arrivato alla fine dell'installazione e doveva fare il primo riavvio.

EFI.rar

Share this post


Link to post
Share on other sites
Posted (edited)

Allora, nuovo aggiornamento. Dopo un sacco di tentativi sono riuscito a fare una chiavetta usb funzionante e sono riuscito ad installare High Sierra. Ora sono dentro al sistema operativo e sto cercando di sistemare un pò di cose. Intanto Internet funzione, e siamo a buon punto. Per la scheda video sto scaricando i Web Driver e poi dovrebbe sistemarsi. Siccome l'unico modo per le mie scarse capacità per far partire il tutto era prendere il file OC.zip 053 dal post Ryzentosh di iCanaro lo ho messo nella EFI del disco Mac e ora mi parte senza l'ausilio della chiavetta. Ovviamente un sacco di roba è sbagliata per il mio hardware e spero di riuscire a far qualcosa, comunque la cosa che a me basterebbe sarebbe far andare la Magic Keyboard Apple Usb, che ora non vede e al limite l'audio. Vi prego, datemi qualche dritta. Grazie mille

Ah dimenticavo, per far partire il disco Mac nel bios ho disattivato il CSM, ma in questo modo non mi vede più l'HD con su Windows 10 e nemmeno premendo F8 al boot lo riesco ad avviare, mentre se abilito il CSM vede Windows ma il disco Mac da subito un errore al boot di OC

Edited by max70

Share this post


Link to post
Share on other sites

l'audio devi inserire il layout per il tuo codec ma prima controlla che il path sia corretto in DevicesProperties/Add

Questo puoi controllarlo usando SystemSearch che è un app che trovi in download

devi cercare HDEF

Share this post


Link to post
Share on other sites

Per l'audio avevo già fatto una cosa del genere sulla vecchia installazione e iCanaro mi aveva preparato il config con inserita la voce, ma cambiando tutti i 3 valori possibili non si sentiva niente lo stesso

Share this post


Link to post
Share on other sites

E ti pareva che avevo fortuna!!!!! Mi ha aggiornato High Sierra a un aggiornamento 2020-002 portandolo alla build 17G12034 e i Web Driver non sono ancora usciti.....vabbè pazienza, per ora va anche così. Il mio dubbio è il fatto di aver usato la cartella EFI del post Ryzentosh dove contiene tutti i Kext e Driver che sicuramente non corrispondono alla mia macchina. Per fare una pulizia e mettere i necessari come posso muovermi? Grazie

Share this post


Link to post
Share on other sites

 

per i webdriver nvidia ho risolto con il test nvram e lo script di Gengik menzionato qui:

 e poi mettendo i driver del primo post

  • Like 1

Share this post


Link to post
Share on other sites

Anche l'audio adesso funziona, manca il far andare la tastiera originale Apple, che ora anche inserita nella stessa porta dove viene vista la tastiera usb generica che ho recuperato, non va. E poi capire come far apparire nel Boot di OC il disco Windows e togliere l'avvio automatico dalla partizione EFI. Grazie mille

Share this post


Link to post
Share on other sites

Citanto l'acqua Lete......... c'è nessuno???????😥😥

Share this post


Link to post
Share on other sites

ch ti vada una tastiera classica diciamo e non quella apple è strano

la porta usb è la medesima... quindi non è che è difettosa la tastiera?

 

Windows avvialo col boot manager del bios (F8)

Share this post


Link to post
Share on other sites
9 ore fa, max70 ha scritto:

E poi capire come far apparire nel Boot di OC il disco Windows e togliere l'avvio automatico dalla partizione EFI. Grazie mille

per far apparire windows al boot, occorre impostare scan  a valore 0

al boot ti sposti con le frecce su quello che vuoi avviare come predefinito, e pigi CTRL+invio

Share this post


Link to post
Share on other sites

Grazie per la risposta. Ma la tastiera in Windows va benissimo, e andava anche con la vecchia installazione di Sierra. Ho provato tutte le Usb e non va proprio solo quella. Per l'avvio di Windows invece non c'è modo di farlo apparire nel menù di boot di OC?

Share this post


Link to post
Share on other sites

passa tuo config 1 moment pliz

3. HideSelf

  • Tipo: plist boolean

  • Failsafe: false

  • Descrizione: nasconde la propria voce di avvio dal selettore di avvio. Questo potrebbe potenzialmente nascondere altre voci, ad esempio, quando un altro sistema operativo UEFI è installato sullo stesso volume e viene utilizzato l’avvio del driver.

  • 7. ShowPicker

    • Tipo: plist boolean Failsafe: false

    • Descrizione: mostra un semplice selettore di avvio per consentire la selezione della voce di avvio

metti yes

Share this post


Link to post
Share on other sites

7. ScanPolicy

  • Tipo: plist integer, 32 bit

  • Failsafe: 0xF0103

  • Descrizione: definire i criteri di rilevamento del sistema operativo. Questo valore consente di impedire la scansione (e l’avvio) da una fonte non attendibile basata su una maschera di bit (somma) di flag selezionati. Poiché non è possibile rilevare in modo affidabile ogni file system o tipo di dispositivo, questa funzione non può essere completamente utilizzata in ambienti aperti e devono essere applicate le misure aggiuntive.

Driver di terze parti possono introdurre ulteriori misure di sicurezza (e prestazioni) seguendo la politica di scansione fornita. Il criterio di scansione è esposto nella variabile del criterio di scansione di 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102 GUID solo per i servizi di avvio UEFI.

  • • 0x00000001 (bit 0) — OC_SCAN_FILE_SYSTEM_LOCK, limita la scansione solo ai file system noti definiti come parte di questo criterio. I driver del file system potrebbero non essere a conoscenza di questo criterio e, per evitare il montaggio di file system indesiderati, è meglio non caricare il driver. Questo bit non influisce sul montaggio di dmg, che può avere qualsiasi file system. I file system noti hanno il prefisso OC_SCAN_ALLOW_FS_.

  • • 0x00000002 (bit 1) — OC_SCAN_DEVICE_LOCK, limita la scansione solo ai tipi di dispositivi noti definiti come parte di questo criterio. Questo non è sempre possibile rilevare il tunneling del protocollo, quindi tieni presente che su alcuni sistemi 31 potrebbe essere possibile ad es. Gli HDD USB devono essere riconosciuti come SATA. Casi come questo devono essere segnalati.

Share this post


Link to post
Share on other sites

scusa ma @max70 che release di OC stai usando?

Share this post


Link to post
Share on other sites
Posted (edited)

Qulla del tuo post su Ryzentosh, mi pare la 0.5.3.

Infatti poi avrei anche chiesto come aggiornarlo in sicurezza

Edited by max70

Share this post


Link to post
Share on other sites

ah ecco.. mi sembrava un po vecchiotto.. e a occhio pare sia settato perché tu possa vedere windows tra le scelte di avvio, da me vedeva entrambi i bootloader dei 2 windows

 

potevi prendere 056, ma comunque, fatta salva questa EFI di OC, backup su pendrive, perché non aggiorni alla 056 il config??? 

 

capisco che è una palla tremenda, ma vi sono un sacco di novità dalla 053 alla 056

 

prendi tuo config, sample del 056 uno di fianco all'altro e con plist editor aggiorni il tuo sulla base del sample

Share this post


Link to post
Share on other sites

Proverò, ma sicuramento so già che combinerò quache guaio. Intanto ho provato a fare la cosa che dicevi al boot, ma muovento le frecce cursore mi sparisce l'asterisco vicino alla partizione EFI e poi non succede niente per selezionare le altre voci. Tornando alla cosa di aggiornare alla 056, nella EFI che prendo nuova non ci va trasferito niente dalla vecchia? Per sample intendi il file config.plist della EFI della cartella OC della 056? Ti chiedo perchè non son tanto pratico delle terminologie..... E in pratica confronto il nuovo col vecchio e metto quello che ho nel vecchio nel nuovo?

Share this post


Link to post
Share on other sites

Hai 2 strade, scarichi OC 056 stable da acidanthera, aggiorni i vari driver .efi e come spiegato su, adegui tuo config sulla base del sample, aggiungendo/rimuovendo/spostando quello che serve

 

Oppure prendi mio OC 056 ma però devi poi adattare per i kext che usi tu, percorso pci audio etc... insomma, non si scappa dal fatto che si deve controllare config e verificare un po' tutto...

 

poi scusa, ma che paura hai? ora avvii con OC053, bene la versione 056 la prepari e testi su una pendrive e sino a che non l'hai sistemata a modo, non metti su EFI disco

Share this post


Link to post
Share on other sites

Eh la fai facile tu.....che ci sei dentro da parecchio.....😂. Io adesso ho proprio la tua OC 053 a cui non ho toccato nulla e funziona abbastanza, non basterebbe prendere ora la OC 056 e fare lo stesso apportanto solo le 2 modifiche che ho fatto al config.plist per l'audio, e il SMBIOS?

Share this post


Link to post
Share on other sites

col cavolo che la faccio facile, mi viene il mal di testa ad ogni nuova release, poi figurati se va tutto al primo colpo.. per questo ti dico di aggiornare, mese dopo mese OC si evolve parecchio

 

SMBIOS va sempre bene quello che usi ora, presumo iMacPro1,1

 

se prendi mio 056 devi solo abilitare i kext che usi tu, SSDT che hai ora in uso, devi fare uguale a come sei ora impostato

poi tutto il resto va bene direi

Share this post


Link to post
Share on other sites
Posted (edited)

Ok proverò, anzi no come direbbe Yoda FARO' o NON FARO'......Ora come SMBIOS ho messo iMac 14,1 con quello che c'era si piantava all'avvio. Per abilitare i Kext di preciso cosa intendi? E come OC del tuo post è meglio OC056 NDK o OC056 ?

Edited by max70

Share this post


Link to post
Share on other sites

ah OK se hai iMac14,1 continua ad usarlo

 

scusa ma se prendi una EFI che sia di clover o di OC di altro hack, la devi poi sistemare per il tuo hardware

Share this post


Link to post
Share on other sites

Si certo, ma essendo proprio alle prime armi io dalla tua non ho toccato nulla tranne quelle 3 cosette nel config.plist e va, non benissimo, ma va

Share this post


Link to post
Share on other sites

come ti ho detto, mettiti all'opera con la mia 056 e la testi su una pendrive, sbagliando si impara

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.