Jump to content
You are a guest user Click to join the site
jhoadmac

Hackintosh Acer Nitro 5 [i7-8750H UHD630]

Recommended Posts

allega ioreg per vedere se è tutto ok

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Ecco a te @Gengik84. Grazie sempre per il supporto. Ps ho appena notato che inserendo le cuffie ascolto un fruscio e non vengono rilevate

Ioreg_report.zip

Edited by jhoadmac
Problema rilevato

Share this post


Link to post
Share on other sites

Prova a cambiare layout audio.

  • +1 1

Share this post


Link to post
Share on other sites

Ragazzi da qualche giorno sto usando il sistema sul nuovo ssd con OpenCore, che preferisco a Clover per snellezza e stabilità. Ho un problema tuttavia: il laptop non va mai in standby. Anche non usandolo, lo schermo diventa nero, senza screensaver, pur essendo lo stesso abilitato, ma le ventole non si fermano mai del tutto, anzi sospetto che si fermino e riattacchino in quanto una volta che mi ricollego, ci sono una sfilza di messaggi riguardo alla necessità di estrarre l'hard disk esterno (dove memorizzo le copie dei file su cui lavoro) prima di spegnerlo o staccarlo, cosa da me mai effettuata. Quindi ho dedotto che il sistema è come se non andasse del tutto in standby mentre non lo uso. Vi ringrazio del supporto che mi date e per il tempo che vorrete spendere per me. Grazie mille a tutti!

Share this post


Link to post
Share on other sites

Salve ragazzi scusate il fastidio, ma avrei un piacere da chiedere a @Gengik84 o @iCanaro, insomma voi che mi avete assiduamente seguito nella realizzazione dell'hack. Ieri ho aggiornato il bios, ho estratto le tabelle acpi con acpidump.efi in OpenCore. Potreste controllare cortesemente se ci sono errori? Ho estratto le tabelle seguendo sempre la guida di Gengik84 per OpenCore. Vi ringrazio per il tempo che vorrete dedicarmi. Buona giornata a tutti

origin.zip

Share this post


Link to post
Share on other sites

se hai aggiornato il bios è da rifare il dsdt

poi te lo rifaccio

  • Like 1

Share this post


Link to post
Share on other sites

Ecco @Gengik84, va bene? Grazie sempre della disponibilità. Vorrei essere più capace per poter aiutare anche io la community. Scusate se non sono in grado e grazie sempre a tutti.

Ioreg_report.zip

Share this post


Link to post
Share on other sites

si va bene

riguardo a aiutare uno può farlo come crede e via via facendo può anche imparare cose nuove

  • Like 1

Share this post


Link to post
Share on other sites
4 minuti fa, jhoadmac ha scritto:

Vorrei essere più capace per poter aiutare anche io la community

beh di solito si parte dalle cose semplici

molti non sanno come aggiungere un boot-arg, estrarre le ACPI, settare il config per poter attivare ssdt-basic/hack, capire quale chip audio si ha e consigliare i layout da provare...

etc...

quindi, se uno vuole basta poco 😉 

 

5 minuti fa, Gengik84 ha scritto:

e via via facendo può anche imparare cose nuove

👍

  • Like 1

Share this post


Link to post
Share on other sites

Va bene ragazzi, grazie mille anche per il sostegno morale.

Share this post


Link to post
Share on other sites

Ragazzi scusatemi per tutto il fastidio che sto procurando, ma avrei un paio di curiosità chiedere. Innanzitutto ho compreso a cosa servono le sezioni Add e Block di OC, ma non ho capito come operare. Mi spiego: in Add va inserito ciò che è necessario per avviare il sistema, in Block invece ciò che invece non deve essere avviato, ma con quale criterio aggiungo o blocco qualche cosa? Per configurare il primo boot, ho usato propetree e non capisco con che criterio abbia aggiunto delle voci nella sezione Block della NVRAM, che mi paiono contraddittorie con quelle presenti in Add.

Altra curiosità: la sezione Device l'ho popolata di Add in base al mio vecchio config di Clover, se volessi comprendere maggiormente le diverse aggiunte che ho fatto, come posso operare?
Vi ringrazio per il tempo che spendete per noi. Vi pongo tali domande essenzialmente sì per migliorare il mio hack, ma in modo da avere più chiara la situazione e poter dare consigli giusti alla community magari. Grazie mille ancora per la disponibilità. Vi auguro buona giornata.

Share this post


Link to post
Share on other sites

non hai da bloccare nulla nel tuo caso, su Add metti il solo DSDT

  • Like 1

Share this post


Link to post
Share on other sites

Okay all'interno della sezione ACPI ho solo aggiunto il DSDT e nella sezione Block ho due stringhe ma disabilitate già. All'interno di NVRAM ho lasciato solo la sezione Add cancellando le stringhe presenti in Block. Grazie @Gengik84

Share this post


Link to post
Share on other sites

ok poi magari fai ioreg per controllare se tutto è ok

  • +1 1

Share this post


Link to post
Share on other sites

Ecco il report @Gengik84. Scusandomi sempre per il disturbo, come controllo il report di ioreg? Vi ringrazio per la disponibilità ed il tempo che spendete per me.

Ioreg_report.zip

Share this post


Link to post
Share on other sites

Ioreg va bene

Spiegare il tutto è direi impossibile e non si avrebbe mai fine, stessa cosa per un discorso acpi che un semplice manuale porta ben oltre 1000 pagine.

tutto questo poi va comunque portato in hack, conoscenza dei kext di sistema, veri mac etc...

Comunque per esempio riguardo a vedere il pm se è configurato, in generale basta un semplice comando sul terminale

kextstat | grep -i X86

Qualora tu non avessi alcun risultato significherebbe che non è configurato a modo

  • +1 1

Share this post


Link to post
Share on other sites

Grazie mille come sempre @Gengik84. Digitando il comando da te indicato, mi esce "grep: X86: No such file or directory" per cui deduco che probabilmente non sia configurato a dovere. Avrei un'altra domanda da porti: quando è necessario aggiungere al DSDT gli SSDT? Grazie mille per il tempo che mi potrai dedicare.

Share this post


Link to post
Share on other sites

ho dimenticato una lettera...pardon..

ho edita il post precedente 🙂

 

Share this post


Link to post
Share on other sites
Posted (edited)

Non che dubitassi, ma per mia natura devo sperimentare, hai perfettamente ragione @Gengik84. Ti allego il testo in spoiler: 

Spoiler

122    1 0xffffff7f82f1c000 0x19000    0x19000    com.apple.driver.X86PlatformPlugin (1.0.0) D2F3502B-0794-38BD-A592-5EDC3C4639D4 <121 27 15 12 8 7 6 5 3 1>
  165    1 0xffffff7f82f35000 0x9000     0x9000     com.apple.driver.X86PlatformShim (1.0.0) 8AF7E94C-12F9-38A2-B896-4E415C68BC54 <122 121 15 8 5 3>


Ciò detto ragazzi stavo cercando di definire al meglio la sezione dei Device di OC e grazie anche ai consigli di @iCanaro, sono giunto a definire la situazione che vi allego in foto nella sezione resoconto, PCI.  
Mi sorgono delle domande:

1) Per alcune periferiche mi riporta dei driver assenti, cosa posso fare, ammesso che possa fare qualcosa?

Grazie sempre per il tempo che vorrete dedicarmi.
 

P.S mi ero reso conto di non aver dichiarato una periferica, ora l'ho fatto e l'ha riconosciute tutte, con l'unico problema dei driver. Grazie mille sempre

Schermata 2020-05-21 alle 13.44.27.png

Schermata 2020-05-21 alle 13.44.40.png

Schermata 2020-05-21 alle 13.44.55.png

Edited by jhoadmac
Piccolo fix

Share this post


Link to post
Share on other sites

PCI è solo ed esclusivamente estetica, questo non è ne sintomo di un hack configurato bene e nemmeno sintomo di maggiore stabilità/qualità  🙂

i mac veri hanno PCI vuota nel 99% dei casi

Share this post


Link to post
Share on other sites

Va bene @Gengik84. Grazie ancora. Non so se possa fare ancora altro per la mia configurazione. In tal caso sarò lieto di ascoltarvi. Grazie ancora di cuore a tutti

Share this post


Link to post
Share on other sites

puoi diciamo divertirti con PCI, ti ho solo dato informazioni anche perchè oggi purtroppo ci si basa troppo spesso con questo discorso che è solo estetico collegandolo a "qualità hack" ma di fatto non è così

 

  • Like 1
  • +1 1

Share this post


Link to post
Share on other sites

Ragazzi buongiorno. Penso di aver compreso un poco più le cose. Allora il mitico @Gengik84 ha implementato i diversi SSDT necessari al boot, come quello relativo alle usb, al plugin type e via discorrendo, all'interno del mio DSDT ecco perché non ho bisogno di patch. Siccome ho preso a cuore la cosa mi sono documentato, anche se non basterebbe una vita come afferma il boss e penso di aver compreso come funziona il DSDT. Infatti ho provato a dichiarare la periferica audio non da OC, bensì tramite DSDT. Quindi cancellando il Device da OC, l'ho dichiarato tramite DSDT e l'audio funziona. Spero di migliorare quanto più possibile e aiutare la community. È una modifica piccola, ma per me ingegnere appassionato di questi temi, vale tanto. Spero di migliorare sempre più. Grazie, grazie mille a tutti!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.