Jump to content

Guida Gigabyte Aorus PRO Z390 + i5 9600k + RX580 / Vega / RDNA con EFI, PROFILI e Sblocco CFG/MSR per NVRAM - MacOS Monterey compliant.


Recommended Posts

Buongiorno a tutti, posto qui le mie riflessioni e la mia mini-guida all’installazione di Catalina/BigSur (procedura compatibile anche con Monterey ma non supportata in quanto BETA) su scheda madre Z390 Gigabyte Aorus Pro

(guida compatibile anche con Aorus PRO WIFI , previa disabilitazione wifi non compatibile con OSX in quanto chipset intel)

 

Cominciamo….

In questa guida, sono stati utilizzati i seguenti componenti e soprattutto nessuno è stato maltrattato! :

 

Mainboard: Gigabyte Aorus Pro rev1,0 chipset z390 bios f12l

CPU: Intel i5 9600k

RAM: Ballistix Sport LT (4x16gb)

Video: AMD Sapphire RX580 Nitro+

CPU Cooler: iTek Liqui v2 240 (modificato)

NVMe: CRUCIAL P5 500gb

Case: Deepcool Matrex 70

WiFi/BT: Abwb 802.11AC BT4.0 chipset BCM943602CS pci-e 

Vari SSD e HDD che però a noi non interessano...

 

Spoiler

1076648827_aoruspro.thumb.jpg.13f24e573f20dc75d6ea97a36c2f9602.jpg

bt.thumb.jpg.393bdf1c38f41fad3e47cef5e98a0cfe.jpg

i5.thumb.jpg.4741de01c15e391781adfe7b0a08ec8a.jpg

itek.thumb.jpg.a6fb73648affaa39eb5e7cc300636f66.jpg

crucial-p5-500-gb-m2-3d-nand-nvme-pcie-m2-ssd-2.thumb.jpg.c86866fb832908da0fc863a88c0f73f9.jpg

386726818_ram4x16.thumb.jpg.806e241c83f834546c4be4d9a5cfa939.jpg

RX580.jpg.231d3244297bad29d6d4f40ac62b322a.jpg

matrexx.thumb.jpg.16fd9fd2bdd17b9a31f5341ba4515f54.jpg

 

 

 

COSA FUNZIONA:

  • Porta Ethernet
  • Audio
  • WiFi (con il modulo utilizzato in questa guida OOB installato nella PCI-E più in basso)
  • SSD Trim
  • USB 3.0 , USB 2.0 e USB-C  (USB-C interna DISABILITATA con mappatura)
  • AirDrop (con il modulo utilizzato in questa guida OOB installato nella PCI-E più in basso)
  • iCloud
  • Accelerazione Hardware h264/HEVC  
  • iMessages
  • Facetime
  • Sleep e Wake
  • Sleep e Spegnimento tramite pulsante Power
  • Handoff
  • Continuity
  • Netflix 1080p/4k Safari
  • NVRAM
  • AppleTV 1080p/4k

 

 

COSA NON FUNZIONA:

  • Sidecar
  • Null’altro (ditemi voi in caso!)

 

 

OCCORRENTE:

  • Chiavetta USB installazione Big Sur / Monterey (BETA) con EFI ottimizzata (in allegato)
  • Una Aorus PRO Z390 con bios f12l
  • Una RX580/590
  • Un monitor xD
  • Un mouse e una tastiera LoL

 

 

Prepariamo la chiavetta di installazione:

Per fare questo, o emulate osx su macchina virtuale da Windows o usate un vero Mac/Hack. 

In questo Forum , è presente la guida alla creazione Vanilla (no Vanilla Ice, gli anni 80 son finiti ahimè)… seguite quella!

…..Dopo questa bruttissima battuta, alla fine della creazione della vostra chiavetta di installazione, dovrete copiare la cartella EFI allegata alla guida. Non preoccupatevi, la cartella che scaricherete, non è nient’altro che una EFI di OpenCore 0.7.1 opportunamente modificata per la nostra scheda madre e per la nostra RX580, completa di SSDT  e di mappatura USB effettuata come riportato in foto allegata... 

 

 

IMPOSTAZIONI BIOS:

(impostazioni basate su versione f12k o successive – meglio aggiornare a f12l - bios f12l allegato al fondo della discussione)

Per prima cosa, una volta assemblato il tutto, facciamo partire la macchina.

Entriamo nel BIOS (con il tasto CANC)

Carichiamo le impostazioni di default, riavviamo e rientriamo nuovamente nel BIOS

A questo punto, andiamo a cliccare su “Advanced Mode” per attivare l’interfaccia completa.

Inseriamo le seguenti impostazioni, lasciando TUTTO il resto di default:

 

    • Boot -> Boot -> CFG Lock -> Disabled
    • Boot -> Windows 8/10 Features -> Windows 8/10  (Attenzione, questo deve essere su Other SOLO se usate sistemi Linux con bootloader grub proprietario. Se usate OpenCore, DEVE essere Windows 8/10)
    • Boot -> CSM Support -> Disabled
    • Tweaker -> Extreme Memory Profile (X.M.P.) -> Profile1
    • Tweaker -> System Memory Multiplier -> DDR4-2666 (solo se avete memorie con profilo superiore ai 2666 ...poi vi spiego****)
    • Tweaker -> Advanced CPU Settings -> VT-d -> Disabled
    • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
    • Settings -> IO Ports -> USB Configuration -> XHCI Hand-off -> Enabled
    • Settings -> IO Ports -> USB Configuration -> USB Mass Storage Driver Support -> Enabled
    • Settings -> IO Ports -> USB Configuration -> Port 60/64 Emulation -> Disabled
    • Settings -> IO Ports -> Initial Display Output -> PCIe 1 Slot
    • Settings -> IO Ports -> Internal Graphics -> Disabled
    • Settings -> IO Ports -> Aperture Size -> 256MB
    • Settings -> IO Ports -> Above 4G Decoding -> Enabled
    • Settings -> Miscellaneous -> Intel Platform Trust Tecnology (PTT) -> Enabled
    • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
    • Settings -> Miscellaneous -> Trusted Computing -> tutto Disabled
    • Settings -> Platform Power -> Platform Power Management -> Enabled
    • Settings -> Platform Power -> PEG ASPM -> Enabled
    • Settings -> Platform Power -> PCH ASPM -> Disabled ***
    • Settings -> Platform Power -> DMI ASPM -> Disabled ***
    • Settings -> Platform Power -> ErP -> Enabled
    • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
    • Save & Exit  Save & Exit Setup 

 

Avendo io il bios settato in lingua inglese, ho riportato tutti i menu scritti in inglese! Ma comunque vi posto le foto per far rendere l’idea di cosa impostare!

 

Spoiler

210703144937.thumb.jpg.2ed319c8dfd305225122101f5b5fb7c7.jpg

210703145002.thumb.jpg.88d9b9f8e3b801a4710796e8c3499c4f.jpg

210703145032.thumb.jpg.96ad71c52d5fd96009092a9386910eda.jpg

 

210703145118.thumb.jpg.3536946b210da0039bc67df644c8696d.jpg

210703145053.thumb.jpg.dc3b9e94cfff19ca31df8182af837aba.jpg

210703145142.thumb.jpg.2dc90b5b3b3a082ee3ccd658f8f803b4.jpg

210703145312.thumb.jpg.ad07592c281b8dfd29dd21ee8a101b3e.jpg

 

 

Non resta che partire con l’installazione di OSX vera e propria!

Avviate l’installazione normalmente seguendo i canonici passi.

 

L’unico accorgimento è, una volta installato il tutto, utilizzare il vostro editor plist preferito , (possibilmente NON textedit) e modificare i dati "sensibili" (seriale , mlb , smuuid , mac address**).

 

Lasciate iMacPRO1,1 che è il più "consono" (nel nostro caso) per i processori CoffeeLake e la nostra scheda madre.

 

 

**Nella sezione “PlatfotmInfo -> Generic” "ROM" , dovrete inserire il MAC Address della vostra scheda di rete con l’esclusione dei “ : “ esempio, Mac address: D0:81:7A:CE:13:B0, diventerà  D0817ACE13B0 . Questa precauzione, farà funzionare senza problemi, dopo aver configurato un account apple, iMessage e FaceTime!

 

Nella EFI presente a fine pagina, potrete trovare il tema Aorus impostato di default per quanto riguarda la GUI di OpenCore.

 

 

A questo punto, BUON HACK CON AORUS PRO Z390! 😄 

 

PS Aggiornate tranquillamente alle nuove versioni di MacOS previo aggiornamento di OpenCore e Kext in caso (questa EFI è testata fino alla versione di MacOS Monterey Beta 2 21A5268h)…

Saluti!

 

 

 

 

 

 

 

 

 

 

 

 

iMac19,1

 

 

Deprecated EFI

Spoiler

EFI SABATO 10 APRILE 2021 OpenCore 0.6.8:

 

 

 

EFI 2.zip

 

Profilo BIOS:

BigSur19.1.zip

 

 

 

 

Attivazione FrameBuffer SMBIOS iMac19,1 per utilizzo UHD630 come singola scheda video:

 

LA EFI iMac19,1 E' PER UNA CONFIGURAZIONE UHD630 IN MODALITA' HEADLESS + SCHEDA VIDEO PCI-E (RXxxx VEGAxx).

 

PER UTILIZZARE LA EFI IMAC19,1 CON LA SOLA UHD, E' NECESSARIO MODIFICARE IL PLATFORM-ID NELLA SEZIONE

 

DeviceProperties / Add / PciRoot(0x0)/Pci(0x2,0x0) / AAPL,ig-platform-id

 

e passare da 0300913E a 07009B3E oppure 00009B3E 

 

Per usare la iGPU, generalmente, occorrono due patch al framebuffer (se non avete la possibilità di modificare i valori vram e max memory nel bios - quindi per questa scheda madre, ne occorre solo una)

 

framebuffer-patch-enable Data 01000000

 

da aggiungere sotto alla riga AAPL,ig-platform-id

 

Questa patch, abilita il framework di Whatevergreen e abilita la gestione corretta delle porte etc.

 

Nel bios, invece, va impostata la ram per la iGPU a 64mb

 

 

Profili iMac19,1 colorati:

 

 Aggiungo, per chi volesse, i profili bios adatti all'avvio e all'installazione di BigSur con impostazione iMac19,1 (quella più vicina alla scheda madre in oggetto), con attiva la iGPU per funzioni Headless (quicksynch)

Attenzione: i profili presenti qui di seguito, sono adatti anche per l'utilizzo SENZA scheda video dedicata. Per far ciò, sarà sufficiente modificare la sezione dedicata del file config.plist senza dover modificare anche il bios.

 

Profilo BigSur iMac19,1 con illuminazione GIALLA

 

BigSur19.1.yel.zip

 

 

Profilo BigSur iMac19,1 con illuminazione VIOLA

 

BigSur19.1.pur.zip

 

 

Profilo BigSur iMac19,1 con illuminazione ROSSA

 

BigSur19.1.red.zip

 

 

Profilo BigSur iMac19,1 con illuminazione AZZURRO CIELO

 

BigSur19.1.sky.zip

 

 

Profilo BigSur iMac19,1 con illuminazione ARANCIONE

 

BigSur19.1.ora.zip

 

 

Profilo BigSur iMac19,1 con illuminazione BLU

 

BigSur19.1.blu.zip

 

 

Profilo BigSur iMac19,1 con illuminazione BIANCA

 

BigSur19.1.whi.zip

 

 

🙂 scegliete il colore che più vi piace!

Attenzione, i presenti profili, sono per il bios versione f12l .

 

 

 

 

 

 

 

 

 ATTENZIONE

 

Per poter vedere gli aggiornamenti, da BigSur in avanti,  il SIP va tenuto abilitato. Nella EFI qui presente, è ABILITATO DI DEFAULT.

 

 

 

EFI iMacPro1,1 OPENCORE 0.7.23

 

ATTENZIONE:

 

 

La efi seguente, contiene la mappatura USB tramite KEXT e non più tramite patch ACPI

Questa efi, va utilizzata ESCLUSIVAMENTE con SMBIOS iMacPro1,1

Le porte sono attivate come segue:

 

 

AorusZ390Port.png.227503cb405ad08ef4638c287e9ca7f5.thumb.jpg.6c014563cad9e0f3100e27754d746691.jpg

 

PORTE A FUNZIONE SINGOLA:

 

HS11   HUB* INTERNO PER SCHEDA BLUETOOTH CONFIGURATO COME USB 2.0 (QUESTA PORTA CONTROLLA ANCHE LE USB2.0 FRONTALI)    ""CODICE PORTA 255""

HS13   HUB* POSTERIORE 4 PORTE USB 2.0    ""CODICE PORTA 0""

SS09   USB 3.0 FRONTALE    ""CODICE PORTA 3""

 

PORTE A FUNZIONE DOPPIA USB2.0 USB3.0:

 

HS07/SS07   USB 2.0 / USB 3.0    ""CODICE PORTA 0 / 3""

HS08/SS08   USB 2.0 / USB 3.0    ""CODICE PORTA 0 / 3""

 

PORTE A FUNZIONE DOPPIA USB3.0 USB3.1:

 

SS03   USB 3.0  USB 3.1    ""CODICE PORTA 3""

SS05   USB 3.0  USB 3.1    ""CODICE PORTA 3""

 

PORTE A FUNZIONE TRIPLA:

 

HS06/SS06   USB TYPE-C 2.0  /  USB TYPE-C 3.0  /  USB TYPE-C 3.1  CON AUTO SWITCH   ""CODICE PORTA 10""

 

 

 

* ESSENDO UN HUB , VIENE CONTAT0 INDIPENDENTEMENTE DAL NUMERO DI CONNESSIONI PRESENTI, COME UNA PORTA SINGOLA PER IL LIMITE DI 15

 

TUTTE LE PORTE FUNZIONANO AL MASSIMO DELLE LORO POSSIBILITA'.

Spoiler

-----Per modificare le porte USB attive, è necessario modificare il file info.plist contenuto all'interno del kext AorusPRO-USB.kext-----

(per fare ciò, potete utilizzare la guida dortania ufficiale all'indirizzo web https://dortania.github.io/OpenCore-Post-Install/usb/ )

PER SEMPLIFICARE, RIPORTO QUI COSA DOVETE FARE:

 

Le parti da modificare sono nella chiave "IOKitPersonalities -> IOProviderMergeProperties" e in nessun'altra parte (mi raccomando)

 

port-count -> l'indirizzo numerico della porta SS (usb3) più "alta" che avete (es. SS02 SS18 HS02 HS16 , in questo caso la porta "più alta" è SS18 ; es.2 SS02 SS04 SS19 HS01 HS02 HS21 , in questo caso è SS19)

questo "numero" è facile da trovare... si può risalire tramite ioregistryexplorer (avviando con TUTTE le porte abilitate tramite apposito kext e apposito quirks) oppure, nel nostro caso, è più semplice... si parte da 01000000 per la HS01 fino a 

0D000000 per la HS13 e 11000000 per la SS01 fino a 1A000000 per la SS10 (allora, da 1 a 9 si usano i numeri...dalla porta 10 in poi, le lettere es. HS09 09000000 HS10 0A000000)

 

ports -> qui va inserito l'id della porta... in base a quelle già presenti, è facile aggiungerne o toglierne...i numeri porta (id) si trovano come specificato sopra.

 

A questo punto, salvate e riavviate. 

 

1021096465_AorusZ370ProMainboardcopy.png.829d3646ffaf314ac98b9af695cbf382.png.79dc20bd18994832744941d75f898f7a.pngAorusZ390Port.png.227503cb405ad08ef4638c287e9ca7f5.thumb.png.188fde692a13b6c0c42614834b38a63a.png

 

 

 

elenco data port:

 

HS01 01000000

HS02 02000000

HS03 03000000

HS04 04000000

HS05 05000000

HS06 06000000

HS07 07000000

HS08 08000000

HS09 09000000

HS10 0A000000

HS11 0B000000

HS12 0C000000 <- ASSOLUTAMENTE DA NON TOGLIERE NELLA MAPPATURA

HS13 0D000000

 

SS01 11000000

SS02 12000000

SS03 13000000

SS04 14000000

SS05 15000000

SS06 16000000

SS07 17000000

SS08 18000000

SS09 19000000

SS10 1A000000

 

ricordo che la porta USB-C posteriore va settata, se volete utilizzarla come 2.0 :8 invece se volete usarla come USB2.0/3.0: 10

l'hub interno del bluetooth (ovvero l'hs 11) va settato 255

le usb 2.0 vanno settate 0

le usb 3.x vanno settate 3

 

 

660018315_Schermata2021-08-05alle08_52_01.png.656395539c25d9facf79791b5a1b2dd3.png

 

 

 

 

Bios Update f12l:

 

Z390AOPR.12l.zip

 

 

Profilo BIOS da caricare con impostazioni di default per Hackintosh (necessita bios versione f12l):

(da scompattare e caricare nel bios nella sezione "boot" "load profile")

 

Hackintosh.zip

 

 

EFI OpenCore 0.7.3 ESCLUSIVAMENTE PER iMacPro1,1 (per altri smbios, modificare modello in platforminfo/generic) con mappatura usb tramite KEXT:  

ATTENZIONE: Nel pacchetto ci sono 2 EFI

una con Whitelist MMIO (da provare e sperimentare)

e una senza Whitelist MMIO (con semplicemente il quirk attivato e quindi funzionante)

 

(link esterno per il download per problemi di dimensione)

 

EFI

 

 

 

 

EFI OpenCore 0.7.1 iMacPro1,1 per GPU RDNA/RDNA2 con mappatura usb tramite ACPI (credits @rainbowflare)

 

EFI.zip

 

 

 

PROFILI f12l CON IMPOSTAZIONI HACKINTOSH COLORATI:

Arancione - Azzurro/Smeraldo - Bianco - Blu Scuro - Giallo - Rosa Shocking - Rosso - Verde

 

Profili Aorus PRO colorati.zip

 

 

 

 

 

 

*** ringrazio @katsuja per aver trovato queste impostazioni che velocizzano gli nvme!

**** questa accortezza, evita il fastidioso problema delle usb disconnesse dopo il wake e fa in modo che il sistema si risvegli dopo solo un clic del mouse e non dopo due.

 

 

 

 

 

Edited by SemanticA
Aggiornamento BIS OpenCore0.7.3
  • Like 7
  • Thanks 4
  • whahahah 1
  • +1 1
Link to post
Share on other sites

Aggiungo in allegato anche una configurazione con RX580 ma con OpenCore... 

E' una prova visto che non ci ho capito molto di OC...(cioè ho capito cos'è e come funziona etc... ma non troppo su come conifgurarlo...c'ho messo anni per clover...datemi almeno fino al 2024 per OC)

Editate il file config.plist presente nella cartella EFI\OC e nella sezione PlatformInfo\Generic , sostituite i valori, dove è chiaramente specificato, con i relativi presi da Clover.

Attenzione, utilizzate solo xCode oppure PlistEdit Pro. NON usate altri programmi per editare il config...

Con questa EFI, il pc/hack parte egregiamente e tutto funziona...ma è da "affinare"...

EFI riservata a possessori di RX580 con bios f12d, CFG sbloccata e iGPU ATTIVATA.

Le mie conoscenze finiscono qui con OC...quindi, funziona, ma non sono in grado di affinare di più! Siate buoni e clementi! 😄 (magari se qualche anima pia ha voglia di dargli un occhiata)

 

Se a qualcuno eventualmente può servire, posso postare anche la config del bios da caricare dopo aver sbloccato la CFG...ma già vi do le efi...voi sbattetevi un po cacchio! ahahaahha

🙂

Un Saluto

 

 

Edited by SemanticA
  • Like 1
  • +1 1
Link to post
Share on other sites

Quasi tutti dicevano la stessa cosa al tempo di Chameleon 😄, resistere e persistere, anche io sono vicino all'abbandono di Clover, magari uso solo la GUI per Windows e Linux, ma il tempo alla fine determinerà le cose...

Link to post
Share on other sites
4 minuti fa, A23SS4NDRO ha scritto:

Bella guida... Tra i driver che metti nella EFI hai provato ad avviare e testare il sistema senza Fsinject, datahubdxe, partitiondxe e VirtualSMC.efi (ora deprecato?) 

Facci sapere, e grazie ancora per la guida 🙂

 

Grazie... no non ho ancora provato sinceramente...ora sto profilando il monitor...appena ha finito provo xD

 

VirtualSMC deprecato?! e da quando?! xD è uscita ieri la versione 1.1.1 ...magari su OC...ma su clover?!me! 😛

Link to post
Share on other sites
2 minutes ago, SemanticA said:

VirtualSMC deprecato

È deprecato il driver .efi perché è stato implementato in OC con il quirk AppleSMCIO, infatti nella release di VirtualSMC 1.1.1 non trovi quel driver efi

Poi mi pare che si usasse solo per FileVault, ma potrei sbagliare

Edited by A23SS4NDRO
Link to post
Share on other sites

Allego le due efi clover aggiornate a oggi, snellite e testate... i seriali inseriti, sono messi a ***zo... possono andar bene come no... ricordatevi di cambiarli in base alle vostre esigenze!...

Entrambi gli smbios sono impostati su 19,1 poichè più idoneo...ma si possono cambiare in 1,1 eventualmente.

Grazie a @A23SS4NDRO che mi ha fatto notare l'inutilità di alcuni driver e a @Gengik84 al quale ho ciulato il ssdt 😛  🙂  e a @fabiosun che ha visto la "A" 😄 

 

...opencore lo lascio a voi esperti...io non ho voglia di creare un dsdt...o forse non ne sono pienamente capace...come già detto nella guida...datemi qualche annetto per imparare 😄 

 

 

 

Edited by SemanticA
  • Like 2
Link to post
Share on other sites
  • Administrators
2 minuti fa, SemanticA ha scritto:

@Gengik84 al quale ho ciulato il ssdt 😛  🙂

 è un piacere veramente.. ci mancherebbe 😉

 

in generale è veramente bello che spesso fai per aiutare... e poi dopo un po'..anche parecchio... c'è qualche simpaticone che nel vero senso della parola "ciula" il lavoro senza manco un credits.. o  anche peggio qualcun'altro ancora che  da credits proprio al "ciullone"...

eg: usb map... etc...

Ma del resto... "the same story..."... e in alcuni, altri casi è proprio vero il detto "siamo proprio italiani"... :default_hysterical:

Scusa il piccolo OT 🙂

 

  • Haha 1
Link to post
Share on other sites

Aggiornamento: Nuova EFI per RX580 (e comunque tutte le ellesmere polaris) con l'abilitazione dei DRM su Safari. (Ora si può vedere Netflix in FHD con polaris)

Grazie a @iCanaro che mi ha quotato nel suo post e mi ha avvisato della nuova uscita della nuova beta di WEG. 

 

Saluti 🙂 

 

Spoiler

 

  • +1 1
Link to post
Share on other sites

Ciao @SemanticA

segnalo che la stringa per il CFG lock è la stessa sulla Gigabyte z390m gaming in mio possesso

2124918556_Schermata2020-02-10alle22_44_21.thumb.png.9ff58cd32fa9ce4e2ee2f7528388c0a8.png

 

Solo appunto: una volta sbloccato il CFG tramite il metodo descritto, eseguendo il reset del bios tale stringa ritorna al valore di default 0x1...perlomeno nel mio caso.

Tra l'altro questa cosa è specificata pure nella wiki di opencore....sicuro che nel tuo caso resti a 0x00 ?

  • +1 1
Link to post
Share on other sites

Seguendo alla lettera tutta la procedura descritta, resta 0x0 ...può ritornare a 0x1 solo caricando i valori di default e/o aggiornando a altra versione di bios e/o se Windows ci pasticcia dentro e/o si cambia da clover a oc per poi ritornare a clover continuando a resettare la nvram. Se si effettua la procedura e si mantiene lo stesso bootloader (anche aggiornandolo), la cfg resta sbloccata a 0x0 . dopo il reset bios/nvram effettuato con la rimozione della batteria, la mb riporta la cfg a 0x1 ma caricando la configurazione salvata prima di togliere la pila, viene ripristinato lo sblocco. Per questo che ho specificato tutti i passaggi che vanno obbligatoriamente eseguiti! ...e si , Assolutamente resta 0x0 . E , attualmente, lo è su entrambi i miei bios. 

Link to post
Share on other sites

Ps , se fosse tornata a 0x1  , con igpu attiva in bios, non partirebbe l’hack ...segnale di divieto immediato...poiché non riuscirebbe a controllare il collocamento della memoria...a meno di non usare accrocchi vari tipo i free2000 ...e ti garantisco che a ogni riavvio, era un gioiello! 😊

Link to post
Share on other sites

Aggiungo:

Ogni qualvolta che per un motivo o per l'altro, lo sblocco "salta" (vedi anche casualmente con aggiornamenti Windows e/o caricamento per sbaglio dei valori di default/reset bios), per ripristinare lo SBLOCCO della CFG, bisogna fare così (DUE PASSAGGI):

 

  • resettare il bios procedendo con la rimozione della corrente dall'alimentatore e rimuovendo la batteria tampone

(NON basta cortocircuitare i pin per il reset del bios poichè quella procedura NON cancella la parte di NVRAM lasciata indietro dal bios stesso)

 

  • entrare nel bios e caricare la config precedentemente salvata durante il primo sblocco illustrato nella guida

(pertanto, consiglio di mantenere il file della configurazione salvato sulla chiavetta)

 

SE SI AGGIORNA IL BIOS:

saranno persi tutti i dati di esso e la CFG ritornerà allo stato 0x1 (bloccata)

Bisognerà ripetere i passaggi dall'inizio (non basterà togliere la batteria e caricare la config inquanto non verrà riconosciuta poichè creata con una versione diversa di BIOS)

 

Comunque sia, io, sconsiglio l'aggiornamento del bios se la situazione con quello attuale è stabile e non da problemi.

 

Edited by SemanticA
Link to post
Share on other sites
Il 11/2/2020 at 07:28, SemanticA ha scritto:

Ps , se fosse tornata a 0x1  , con igpu attiva in bios, non partirebbe l’hack ...segnale di divieto immediato...poiché non riuscirebbe a controllare il collocamento della memoria...a meno di non usare accrocchi vari tipo i free2000 ...e ti garantisco che a ogni riavvio, era un gioiello! 😊

 Ora mi hai fatto sorgere un dubbio....ho testato parecchie volte l'avvio solo tramite igpu visto che avevo deciso restituire la rx580.

Fallimento totale su tutta la linea, non ci sono riuscito. Ho dovuto attendere la vega 56 per poter riaccedere all'hack

 

Non dirmi che era il CFG lock il problema 😅

L'ho sbloccato da poco per poter lavorare con opencore

 

 

 

Edited by Seridan80
Link to post
Share on other sites
Il 11/2/2020 at 07:22, SemanticA ha scritto:

Seguendo alla lettera tutta la procedura descritta, resta 0x0 ...può ritornare a 0x1 solo caricando i valori di default e/o aggiornando a altra versione di bios e/o se Windows ci pasticcia dentro e/o si cambia da clover a oc per poi ritornare a clover continuando a resettare la nvram. Se si effettua la procedura e si mantiene lo stesso bootloader (anche aggiornandolo), la cfg resta sbloccata a 0x0 . dopo il reset bios/nvram effettuato con la rimozione della batteria, la mb riporta la cfg a 0x1 ma caricando la configurazione salvata prima di togliere la pila, viene ripristinato lo sblocco. Per questo che ho specificato tutti i passaggi che vanno obbligatoriamente eseguiti! ...e si , Assolutamente resta 0x0 . E , attualmente, lo è su entrambi i miei bios. 

 

Scusami ma la configurazione che salvi prima di togliere la pila non la effettui prima di procedere allo sblocco del CFG? Quindi salvi il CFG a 0x1

Link to post
Share on other sites
  • SemanticA changed the title to Guida Gigabyte Aorus PRO Z390 + i5 9600k + RX580 / Vega / RDNA con EFI, PROFILI e Sblocco CFG/MSR per NVRAM - MacOS Monterey compliant.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.