Jump to content
You are a guest user Click to join the site
khris801822

Ottimizzazione Catalina su Asus Rog Maximus X Hero

Recommended Posts

Ciao ragazzi sabato libero perciò dedicato al montaggio del nuovo hack in firma ... Spostati i dischi con gli os già installati e impostato il Bios come ho letto sulla guida di @iCanaro  su configurazioni di riferimento ...

Ho quindi  soltanto cambiato il config sulla efi  con le impostazioni adatte a questa scheda e cpu almeno per il primo avvio e con estrema facilità sono già su Catalina e a prima vista funziona più che bene ... Ovviamente ho preparato tutto sulla base delle conoscenze acquisite creando il vecchio hack perciò , essendo quest ultimo molto datato , potrei aver omesso o messo sul config qualcosa di errato/obsoleto su queste schede nuove...  per questo chiedo gentilmente una mano d aiuto per cercare di ottimizzare al meglio ... Per il momento quindi

 

Installato e avviato os Catalina 10.15.2 con le guide di @Gengik84

Avvio per il momento con solo il config e kext su cartella clover senza nessun dsdt e ssdt 

Impostazioni bios come da istruzioni per asus nel post di @iCanaro ; ho solo settato le ram a 3200 mhz in quanto in auto le impostava a 2133 mhz 

 

L' audio è funzionante , scheda video riconosciuta nativamente ... devo testare lo stop e se il monitor va in stop ecc ... 

Per ora prima di frugare e sporcare il sistema inutilmente attendo i vostri consigli per ottimizzare e vi allego la cartella di clover e ioreg 

Grazie mille per ora

CLOVER.zip iMac di kris.zip

Share this post


Link to post
Share on other sites

Ciao segui la mia guida ssdt per hack, successivamente quella per mappatura

almeno ripulirai anche un po' il config

😄

 

  • Thanks 1

Share this post


Link to post
Share on other sites

lieto che sei riuscito ad installare.. copia EFI USB su EFI disco e tieniti la USB per avvii di emergenza... 

 

vi è da lavorare sul config... faccio prima a modificarlo, lo testi e poi lo confronti con il tuo

hai iniettato la grafica per HD630 

ma stando alla tua CPU

https://ark.intel.com/content/www/it/it/ark/products/134896/intel-core-i5-9600k-processor-9m-cache-up-to-4-60-ghz.html

tu hai UHD630

devi inserire port limit patch per catalina

https://www.macos86.it/topic/890-raccolta-lista-usb-xhci-patch-port-limit/

poi ssdt per hack

config-1.plist.zip

  • Thanks 1

Share this post


Link to post
Share on other sites
23 minutes ago, Gengik84 said:

Ciao segui la mia guida ssdt per hack, successivamente quella per mappatura

almeno ripulirai anche un po' il config

😄

 

 

 

18 minutes ago, iCanaro said:

lieto che sei riuscito ad installare.. copia EFI USB su EFI disco e tieniti la USB per avvii di emergenza... 

 

vi è da lavorare sul config... faccio prima a modificarlo, lo testi e poi lo confronti con il tuo

hai iniettato la grafica per HD630 

ma stando alla tua CPU

https://ark.intel.com/content/www/it/it/ark/products/134896/intel-core-i5-9600k-processor-9m-cache-up-to-4-60-ghz.html

tu hai UHD630

devi inserire port limit patch per catalina

https://www.macos86.it/topic/890-raccolta-lista-usb-xhci-patch-port-limit/

poi ssdt per hack

config-1.plist.zip 2.65 kB · 0 downloads

grazie ragazzi  Ora procedo a lavorarci sopra e corrego ciò che mi avete detto ... appena ho fatto vi faccio sapere 

Share this post


Link to post
Share on other sites

Ho letto le guide e un pò di commenti per chiarirmi le idee ... Vado per gradi perchè rispetto all' altro hack è tutto un altro mondo ...

@iCanaro ho preso il config che mi hai modificato e inserito il port limit .... riavviato e rifatto ioreg ... 

 

allego nuovo config e ioreg 

 

ora il prossimo passo è inserire ssdt giusto ?  e poi per ultimo la mappatura porte è corretto @Gengik84 ? 

 

 

config2.plist.zip iMac di kris.zip

Edited by khris801822

Share this post


Link to post
Share on other sites

si pensa prima a ssdt per hack

quando hai fatto allega ioreg che lo controlliamo, se fosse poi ok allora passerai alla mappatura

Share this post


Link to post
Share on other sites
Just now, Gengik84 said:

si pensa prima a ssdt per hack

quando hai fatto allega ioreg che lo controlliamo, se fosse poi ok allora passerai alla mappatura

ok perfetto allora procedo 

  • +1 1

Share this post


Link to post
Share on other sites

yhea! ssdt x hack caricato... come si lavora bene sulla Z370

 

@khris801822 ora mappatura USB

 

 ioreg per mappatura e ACPI

  • Thanks 1

Share this post


Link to post
Share on other sites

@khris801822

Poi quando hai finito di faccio un ottimizzazione su ssdt per hack, mirata per il tuo caso

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
33 minutes ago, iCanaro said:

yhea! ssdt x hack caricato... come si lavora bene sulla Z370

 

@khris801822 ora mappatura USB

 

 ioreg per mappatura e ACPI

Hai proprio ragione questa scheda è veramente ottima non mi aspettavo questo balzo nettissimo in avanti rispetto all' altra

 

27 minutes ago, Gengik84 said:

@khris801822

Poi quando hai finito di faccio un ottimizzazione su ssdt per hack, mirata per il tuo caso

 

ok grazie ora procedo alla mappatura poi posto il risultato ... speriamo bene 

  • +1 1

Share this post


Link to post
Share on other sites

a mè pare OK

 

ssdt a cui si riferisce gengik, è un ssdt x hack personalizzato per le tue acpi e non generico... 😉 

  • Like 1

Share this post


Link to post
Share on other sites
16 minutes ago, iCanaro said:

a mè pare OK

 

ssdt a cui si riferisce gengik, è un ssdt x hack personalizzato per le tue acpi e non generico... 😉 

ok perfetto allora attendo poi l' ssdt per terminare ...  mi veniva poi la domanda , mi darebbe dei vantaggi attivare anche la video  intel integrata oltre alla gtx 660 ? 

 

Ho notato non funziona lo stop ma credo tra le patch della guida ssdt di aver visto anche quella ( poi non uso mai lo stop )  e sono già soddisfattissimo del risultato raggiunto in poco tempo poi pian piano lo testerò per bene ... Per il momento mille grazie 

Share this post


Link to post
Share on other sites

beh fatta salva la configurazione attuale, nessuno ti vieta di sperimentare

 

puoi attivara da BIOS assegnargli DVMT64Mb

flaggare inject intel nel config ed inserire un ig-platform-id senza connettori tipo 0x3E980003

 

e vedere con videoproc prima e dopo il giochino cosa cambia

1361906373_Schermata2020-01-11alle20_15_29.thumb.png.72b851bbca0be4e8ba5b468ee4d05cc5.png

  • Like 1

Share this post


Link to post
Share on other sites

La integrata la puoi utilizzare per Quick Sync in primis, quindi tutte accelerazioni per encodifica che puoi sperimentare da un applicativo che su chiama "Videoproc". Inoltre la GTX660 è nativa e ha zero problemi, ma se sei con integrata OFF potresti avere noie per quanto riguarda anteprima/Quicklook o playback di contenuti quali Netflix eccetera, cosa che risolveresti con molta facilità configurando opportunamente la tua UHD630 con patch framebuffer. Per maggiori info controlla magari il manuale di Whatevergreen

  • Like 1

Share this post


Link to post
Share on other sites

ma non ingenerare confusione e prevedere problematiche che potrebbe nemmeno avere...

non occorre fasciarsi la testa prima di rompersela e poi le cose cambiano velocemente, se si vede il changelog dell'ultimo WEG beta

https://www.macos86.it/files/file/21-whatevergreen/

mai avuti simili problematiche nella Z370 in cui tengo la iGPU disabilitata con iMacPro1,1 e nemmeno nel ryzentosh dove per ovvi motivi non è presente una integrata intel

 

se avrà problemi si affronteranno di volta in volta.

 

PS: poi come farà mai il vero iMacPro1,1 con con gli xeon senza iGPU ad avere il quicksynch.. un bel mistero eh?!

  • Like 1

Share this post


Link to post
Share on other sites

Buongiorno a tutti eccomi di nuovo... ieri quando ho staccato ho notato che il pc non si spegne ma si riavvia ... ora tento di risolvere questo problema poi magari tenterò di far funzionare anche la integrata ...  io come smbios sto utilizzando imac 19,1 è corretto ?

 

Per lo shutdown ora mi rivedo la guida per ssdt hack 

Share this post


Link to post
Share on other sites

il smbios va bene, hai per caso dispositivi usb collegati?

Share this post


Link to post
Share on other sites

metti il flag in ACPI Halt Enabler salva riavvia e poi prova a spegnere... se ancora si riavvia aggiungi il flag a Fix Shutdown

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, Gengik84 said:

il smbios va bene, hai per caso dispositivi usb collegati?

si in effetti ho un hub collegato oltre a tastiera e mouse 

 

4 minutes ago, iCanaro said:

metti il flag in ACPI Halt Enabler salva riavvia e poi prova a spegnere... se ancora si riavvia aggiungi il flag a Fix Shutdown

ora provo anche questo e vi faccio sapere 

 

 

@Gengik84 volevo chiederti già ieri , io ho messo il ssdt coffie lake + pm ; è corretto o andava meglio  il ssdt coffie lake  ? 

Share this post


Link to post
Share on other sites

Va benissimo anche quello, non usi il pm sul config

stessa soluzione di fatto alla fine 🙂

 

  • Like 1

Share this post


Link to post
Share on other sites

Allora rieccomi ... rimosso il dispositivo usb ma non si spegne; spuntato halt enabler niente ancora, spuntato anche fix shutdown e ora si spegne 

 

ho dato uno sguardo al dsdt e compare un errore e molti warning , c'è una patch su maciasl per correggerlo ? 

 

allego ultimo ioreg e clover ditemi se è tutto ok perchè il verbose passa talmente veloce che non capisco se ci sono errori o meno

Share this post


Link to post
Share on other sites

non toccare il DSDT, non ti serve

Share this post


Link to post
Share on other sites
10 minuti fa, khris801822 ha scritto:

Allora rieccomi ... rimosso il dispositivo usb ma non si spegne; spuntato halt enabler niente ancora, spuntato anche fix shutdown e ora si spegne 

 

ho dato uno sguardo al dsdt e compare un errore e molti warning , c'è una patch su maciasl per correggerlo ? 

 

allego ultimo ioreg e clover ditemi se è tutto ok perchè il verbose passa talmente veloce che non capisco se ci sono errori o meno

 

non toccare lavori di gengik pliZ 😉

 

avvia clover configurator --> BootLog --> generate log 

così te lo guardi per bene

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.