Jump to content
You are a guest user Click to join the site
Sign in to follow this  
Gengik84

[Guida]Asrock Z270 Extreme HD630 AMD Rx 480

Recommended Posts

z270-e10.jpg"><a href=https://i11.servimg.com/u/f11/19/64/14/46/z270-e10.jpg' alt='z270-e10.jpg'>

 

 

 

Materiale occorrente:

 

Versione OSx ufficiale: High Sierra e per Sierra non antecedente a 10.12.6

 

 

 

Kext Ethernet: IntelMausiEthernet

 

Kext usb: UsbInjectAlll

 

Kext audio: AppleALC

 

Kext per scheda video:WhateverGreen

 

Ovviamente Fakesmc.kext (versione 6.26 o successivi) *nota: nel pacchetto allegato in guida è già l'ultima versione disponibile

 

Lilu.kext (versione 1.1.6 o successivi)

 

IntelGraphicsFixUP (per grafica integrata)

 

 

 

 

 

Impostazioni Bios oltre alle solite:

 

Grafica primaria : scheda video

 

CSM disable

 

 

 

Impostazioni Bios oltre alle solite in caso di utilizzo di grafica integrata:

 

Grafica primaria: integrata

 

Dvmt impostata a 128 mb

 

 

 

Iniziamo a preparare la usb come da mia guida seguendo la parte per installazione di Clover in UEFI

 

Ulteriori impostazioni per il config.plist:

 

Sezione ACPI/DSDT-Patches:

[code]Change HDAS to HDEF
Change HECI to IMEI
Change GFX0 to IGPU

[/code]

Selezionate Generate C & P states

 

 

 

Sezione Devices

 

USB:lasciate selezionati tutti gli inject

 

 

 

Audio: 1 o 7 o 11

 

 

 

FakeID: in caso di uso di grafica integrata

 

IntelGfx= 0x59128086

 

Sezione Graphics (per integrata)

 

selezioniamo inject intel

 

ig-platform-id inseriamo: 0x59120000

 

Sezione SMbios

 

Impostate iMac 18.3 avendo l'accortezza di usare un seriale non riconosciuto.

 

 

 

Salvate le modifiche al config.plist.

 

 

 

Riavviate, premete F11 e selezionate il boot da usb

 

 

 

Se è tutto è andato come dovrebbe dovreste una volta installato aver già configurato scheda ethernet, video, e power management

 

 

 

Avvio da HD/SSD: Basta copiare la EFI della usb nella EFI del disco

 

scherm22.png"><a href=https://i11.servimg.com/u/f11/19/64/14/46/scherm22.png' alt='scherm22.png'>

 

scherm28.png"><a href=https://i11.servimg.com/u/f11/19/64/14/46/scherm28.png' alt='scherm28.png'>

 

 

 

Intel power gadget:

 

scherm18.png"><a href=https://i11.servimg.com/u/f11/19/64/14/46/scherm18.png' alt='scherm18.png'>

 

scherm21.png"><a href=https://i11.servimg.com/u/f11/19/64/14/46/scherm21.png' alt='scherm21.png'>

 

scherm21.png"><a href=https://i11.servimg.com/u/f11/19/64/14/46/scherm21.png' alt='scherm21.png'>

 

 

 

Ethernet:

 

scherm27.png"><a href=https://i11.servimg.com/u/f11/19/64/14/46/scherm27.png' alt='scherm27.png'>

 

 

 

Audio:

 

scherm25.png"><a href=https://i11.servimg.com/u/f11/19/64/14/46/scherm25.png' alt='scherm25.png'>

 

 

 

Ottimizzazione Dsdt e un po' di estetica:

 

scherm51.png"><a href=https://i62.servimg.com/u/f62/19/64/14/46/scherm51.png' alt='scherm51.png'>

 

Nota: Non è basilare !!! si ha un ottimo hack non usandolo...e gestendo tutto dal config..

 

 

 

SSDT: ho creato un ssdt con script di @Piker impostando manualmente perché ancora non supporta pienamente alcune cose.

 

Non ho notato la minima differenza rispetto a far gestire il PM a clover... quindi andate tranquilli !!

 

 

 

Personalmente non uso ne patch per port limit ne usbinjectall, questo perché ho mappato e disattivato le porte usb non usate tramite le acpi originali della scheda madre

 

https://www.macos86.it/viewtopic.php?f=45&t=5">[Guida] Mappatura porte usb

 

Un ottimo hardware e un ottimo Hack....

Share this post


Link to post
Share on other sites

Come faccio a trovare i valori da inserire su find & replace per queste voci?

 

Change HDAS to HDEF

 

Change HECI to IMEI

 

Change GFX0 to IGPU

Share this post


Link to post
Share on other sites

1° hack in firma, utilizzo la scheda grafica integrata e si manifestano alcuni freeze di diversi secondi durante l'utilizzo normale del pc.

 

 

 

Altro problema...clover all'avvio non mostra la partizione windows installata su ssd nvme.

 

Windows è stato installato prima e non so se possa c'entrare con questo problema.

 

Allego la EFI

EFI.zip

Share this post


Link to post
Share on other sites

prova impostando iMac 18.1. come smbios..ovviamente in caso aggiorna anche i kext

 

per windows segui la guida di @netgear[/mention]

Share this post


Link to post
Share on other sites

Ho inserito la cartella EFI nel post sopra per vedere se ci sono errori da correggere.

 

I kext li ho scaricati ieri e credo siano tutte le ultime versioni

Share this post


Link to post
Share on other sites

ok però aggiungi il flag su inject intel.. e prova mettendo iMac 18.1

 

sul bios dvmt nel caso prova a 128

Share this post


Link to post
Share on other sites

Nel caso ancora non sia ancora perfetto, prova ad aggiungere SHIKI, tentar non nuoce

Share this post


Link to post
Share on other sites

dvmd già impostato su 128.

 

Ho cambiato simbiosi in 18.1 anche se il 18.2 è proprio lo stesso processore del mio.

 

Adesso vediamo se la situazione migliora :D

Share this post


Link to post
Share on other sites

Sembra che con il SMBIOS 18.1 i freeze siano spariti, vedremo durante un utilizzo più prolungato.

 

 

 

Adesso vorrei risolvere il problema del wake from sleep. Il monitor resta spento e se lo accendo manualmente il pc si riavvia.

 

Allego hack info, ioreg, foto dcpi manager, cartella EFI ed infine un file di errore generato da un arresto anomalo causato dopo aver provato a risvegliare il sistema dopo lo sleep

Foto dcpi.zip

HackInfo_Report.zip

iMac di FT.zip

errore riavvio 2.zip

EFI.zip

Share this post


Link to post
Share on other sites

Scaricati dalla sezione download Fix_Hibernate, lancialo e vedi se le cose migliorano.

Share this post


Link to post
Share on other sites

Niente da fare, non funziona neanche cosi.

 

Prima di questa nuova installazione funzionava senza problemi quindi non so quale sia il problema. Ho provato anche con il config vecchio ma non funziona lo stesso.

 

 

 

Ha scritto dopo 1 ora 18 minuti 6 secondi:

 

Mi servirebbe una mano per eliminare gli errori del DSDT.

 

Sto utilizzando MACIasl e DSDT.dsl mi da il seguente errore: Name already exist in scope (BNUM) e non so come eliminarlo.

Share this post


Link to post
Share on other sites

Cancella l'intera riga e salva il DSDT , importante correggere errori , warnings sono influenti .....

 

NON credo con questa configurazione ti serva un DSDT , Clover può gestire benissimo tutto ...

Share this post


Link to post
Share on other sites

Dovresti settare darkwake, per le asrock spesso consigliano di mettere 8

 

 

 

Ha scritto dopo 5 minuti 48 secondi:

 

Poi volendo potresti aggiungere alcuni fix in acpi che male non fanno sicuramente:

 

fix darwin, fix regions, delete unused, fix tmr

 

 

 

Ha scritto dopo 11 minuti 30 secondi:

 

di IntelMausiEthernet.kext Mieze ha rilasciato la 2.4.0 finale, invece di quella di RM che stai usando ora

 

SHIKI siamo alla 2.2.6, stai usando la 2.1.1

Share this post


Link to post
Share on other sites
"Baio77" post_id="4829" time="1524862274" user_id="55">

Cancella l'intera riga e salva il DSDT , importante correggere errori , warnings sono influenti .....

 

NON credo con questa configurazione ti serva un DSDT , Clover può gestire benissimo tutto ...

Quindi lascio le cose come stanno senza correggere gli errori? L unico errore riscontrato è quello riguardante la scritta BNUM! Son presenti pochissimi warning e alcuni non presentano nemmeno warning.

 

Provo ad aggiornare i kekt, lilu e shiki li ho presi dalla vecchia cartella perché prima non avevo problemi, gli altri son tutti aggiornati.

Share this post


Link to post
Share on other sites
"memphis84" post_id="4836" time="1524871328" user_id="93">

Quindi lascio le cose come stanno senza correggere gli errori? L unico errore riscontrato è quello riguardante la scritta BNUM! Son presenti pochissimi warning e alcuni non presentano nemmeno warning.

 

Provo ad aggiornare i kekt, lilu e shiki li ho presi dalla vecchia cartella perché prima non avevo problemi, gli altri son tutti aggiornati.

Se il "BOSS" ha fatto la guida cosi , io la seguirei in tutto e x tutto ,NON credo possano esserci migliori configurazioni di questa , se poi hai problemi di sicuro puoi provare altre strade .....

 

X il DSDT , estratto ti aiuterebbe a capire i rename dovresti usare in Clover , ma in questo caso ha già fatto tutto Gengik ... ...

 

Buona giornata a tutti

Share this post


Link to post
Share on other sites

@memphis84[/mention] il problema è la grafica integrata.. che è problematica per lo sleep

Share this post


Link to post
Share on other sites

@Gengik84[/mention] prima di questa nuova Installazione funzionava senza problemi. Avevo problemi di freeze e crash di applicazioni ma il wake from sleep non mi aveva mai dato problemi.

 

Adesso non ho più problemi di freeze da quando mi hai fatto cambiare smbios in 18.1, per ïl crash delle app nn saprei visto che prima d installare qualcosa volevo avere un hack completamente funzionante

Share this post


Link to post
Share on other sites

Posso farti il dsdt ma non credo che si risolva nulla perchè il log del crash riporta il problema riguardo alla grafica

Share this post


Link to post
Share on other sites

Non saprei cosa pensare. Prima il wake from sleep funzionava egregiamente! Più avanti magari monterò una scheda grafica dedicata.

 

Tutto il resto sembra funzionare, hai dato uno sguardo ai Files che ho postato sopra per capire se c'è qualcos'altro da fare?

 

Ultima cosa, i kext è sempre bene tenerli costantemente aggiornati?

Share this post


Link to post
Share on other sites

Apri il terminale e prova con questo comando:

 

 

 

sudo pmset -a autopoweroff 0

Share this post


Link to post
Share on other sites
"memphis84" post_id="4903" time="1525115210" user_id="93">

Non saprei cosa pensare. Prima il wake from sleep funzionava egregiamente! Più avanti magari monterò una scheda grafica dedicata.

 

Tutto il resto sembra funzionare, hai dato uno sguardo ai Files che ho postato sopra per capire se c'è qualcos'altro da fare?

 

Ultima cosa, i kext è sempre bene tenerli costantemente aggiornati?

 

Ci sono stati molti cambiamenti nei kext riguardo alla grafica su 10.13.4 soprattutto per l'integrata

 

i kext, sopratutto Lilu e relativi plugins.. è buona regola tenerli aggiornati

 

 

 

Ha scritto dopo 1 minuto 38 secondi:

 

Nel caso puoi provare i vari darkwake sul config, provando in primis 0 8 oppure 10

Share this post


Link to post
Share on other sites

Ho reinstallato high Sierra da 0 utilizzando la stessa cartella EFI che utilizzavo in precedenza. Ho aggiornato i kext alle ultime versioni però adesso non mi viene riconosciuta la risoluzione del monitor (si ferma a 1900x1080 mentre ho un monitor 2k) e durante l'avvio, dopo metà caricamento della mela, il monitor non riceve più il segnale e devo spegnerlo a riaccenderlo per poter visualizzare il desktop.

 

Any help?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.