Jump to content
Sign in to follow this  
ninoger

[RISOLTO] Desktop GA-EP45-UD3LR: no shutdown e no sleep

Recommended Posts

Ciao a tutti,

 

torno a parlare di questo mio hack (Desktop 3 in firma) dopo averne discusso su Insanelymac qualche tempo fa.

 

La macchina va abbastanza bene ma come da titolo non fa lo shutdown, o meglio, lo fa 2-3 volte su 10 e poi non si riprende dallo sleep. In pratica resta con lo schermo nero e devo spegnere brutalmente. Se va in stop per breve tempo si riprende senza problemi.

 

Allego quanto richiesto. Grazie a tutti per l'aiuto che vorrete darmi anche qui.

iMac P45 CLOVER.zip

iMac P45 HackInfo_Report.zip

iMac P45 IOreg.zip

iMac P45 Screenshot.zip

Share this post


Link to post
Share on other sites

Ciao, da quello che stai dicendo sembra un problema legato alla scheda video

 

Quando rimane lo schermo nero, hai provato a staccare e ricollegare il cavo?

Share this post


Link to post
Share on other sites

si ma senza successo, anzi qualche volta mi sembra di ricordare che il "trucco" ha funzionato. Un po' come per lo shutdown, che funziona un paio di volte su 10. Alcune volte sono certo di ricordare che lo sleep ha funzionato. Adesso l'ho acceso e aspetto.

 

A mio avviso c'è da sistemare qualcosa, ma non so cosa.

 

Grazie.

Share this post


Link to post
Share on other sites

Potrebbe essere un problema dell'edid del monitor

 

vedo che stai usando nvidiagraphicsfixup, sicuro che ti serva? provato senza?

 

se proprio ti serve prova nel caso ad aggiornare tale kext, adesso c'è la versione 1.2.3

Share this post


Link to post
Share on other sites

l'ho iniziato a usare perchè a suo tempo avevo problemi di glitch al boot, che sono scomparsi dopo aver iniziato a usarlo. Ma non so se c'entra del tutto. E' già all'ultima versione mi pare. Se fallisce lo sleep ancora provo a toglierlo.

Share this post


Link to post
Share on other sites

ah scusa, pensavo di averla cambiata prima di raccogliere i dati da postare. Comunque ho scoperto il problema dello sleep da poco, mentre il problema dello shutdown c'è da sempre

Share this post


Link to post
Share on other sites

Per lo shutdown poi provare il relativo fix sul config, ma spesso su mobo datate non funziona

 

Nel caso allega il dsdt pulito

 

Per farlo premi F4 nella gui di clover,attendi 30 secondi e poi avvia

 

Comprimi e posta la cartella origin

Share this post


Link to post
Share on other sites

non so qual'è il fix. In origin dovrebbero esserci già i dati, se non ho cappellato anche li

Share this post


Link to post
Share on other sites

sul config, sezione acpi --> FixShutdown

 

 

 

si origin è ok...sorry non avavo guardato

Share this post


Link to post
Share on other sites

adesso sono passati circa 20 minuti e si è ripreso dallo sleep, stavolta. Ora aspetto ancora mezz'ora e vediamo che succede

Share this post


Link to post
Share on other sites

si è avviato regolarmente ma non funzionano tastiera e mouse. E' un kit wireless della HP.

Share this post


Link to post
Share on other sites

in pratica non funzionano le porte usb 2.0 della mb perchè se metto la pennetta in quelle 3.0 della scheda aggiuntiva funziona

Share this post


Link to post
Share on other sites

adesso le usb mi sembrano tutte ok ma non funziona più l'audio. Si è spento due volte consecutive, successo raramente finora.

 

Gengik, scusa, ma lo stesso risultato si può ottenere senza file dsdt?

Share this post


Link to post
Share on other sites

si spegne, sembra, ogni volta! Adesso l'audio è ok, ma ho notato che dopo lo sleep perde le porte usb 3.0 anche se il resto si riprende. Al successivo riavvio sembra tutto ok. E' stato un problema casuale o c'è dell'altro da sistemare?

 

 

 

Ribadisco la domanda da neofita: si può fare tutto questo senza dsdt.aml? Perchè difficilmente imparerò mai a maneggiarlo.

 

Grazie

Share this post


Link to post
Share on other sites

In questo caso no perché come ti avevo detto prima le patch di clover non riescono a correggere il problema nel modo corretto

Share this post


Link to post
Share on other sites

ah ok, ho capito. Questo vale per le mb datate come questa, giusto?

 

 

 

Ora sto aspettando ancora un po' per vedere se si riprende dopo lo sleep e cosa si riprende e cosa no.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.