Jump to content
You are a guest user Click to join the site
Sign in to follow this  
Gengik84

Ethernet e servizi Apple

Recommended Posts

Per poter accedere ai servizi Apple…tra cui App Store ecc..

 

La ethernet deve essere sempre configurata anche se poi non la utilizziamo.

 

Deve essere vista su en0 e Built-in

 

Cosa vuol dire questo?

 

 

Possiamo controllarlo andando nelle Info/ Reseoconto di sistema/ Schede Ethernet

 

Schermata 2019-10-29 alle 11.56.46.png

 

[immagine tiny]

 

Oppure usando Dpci Manager controllando nella parte “Status”

 

Schermata 2019-10-29 alle 11.58.00.png

 

 

Nel caso che non fosse in en0, questo potrebbe essere dovuto al fatto, per esempio, di aver configurato prima il wifi della ethernet…

 

Il problema è facilmente risolvibile…

 

Apriamo il terminale e digitiamo i seguenti comandi:

 

cd /Library/Preferences/SystemConfiguration

sudo rm -rf NetworkInterfaces.plist

sudo rm -rf preferences.plist

 

Successivamente riavviamo… torniamo a controllare e potremo constatare il buon esito dell’operazione…

Edited by iCanaro
Aggiornamenti

Share this post


Link to post
Share on other sites

Hack 1 in firma, con DCPI manager:

 

 

 

High Sierra en0 - qui siamo OK

 

 

 

Sierra en0 - anche qui OK

 

 

 

El Capitan en1 - en0 non occupato

 

 

 

Premesso che non è indispensabile, puro esercizio :) che è possibile fare per cambiargli locazione sul elcap?

Share this post


Link to post
Share on other sites
"iCanaro" post_id="436" time="1519427171" user_id="57">

Hack 1 in firma, con DCPI manager:

 

 

 

High Sierra en0 - qui siamo OK

 

 

 

Sierra en0 - anche qui OK

 

 

 

El Capitan en1 - en0 non occupato

 

 

 

Premesso che non è indispensabile, puro esercizio :) che è possibile fare per cambiargli locazione sul elcap?

 

Hai provato con quelle righe di comando di cui sopra?

 

 

 

cd /Library/Preferences/SystemConfiguration

 

sudo rm -rf NetworkInterfaces.plist

 

sudo rm -rf preferences.plist

Share this post


Link to post
Share on other sites

Di primo acchito non ho provato, in quanto mi era parso di capirenell'esempio esposto, che con DPCImanager era en0 e poteva essere un errore nella configurazione; premesso ciò ero mezzo dell'idea di provare comunque, poi tu ci metti il carico, mo' avvio il portatile e vado :D

Share this post


Link to post
Share on other sites

Allora... resoconto dell'operazione:

 

 

 

avviato terminale copia/incolla i comandi, riavvio

 

ora la scheda è en0 però non si collega, pallino rosso in network.

 

disabilita/abilita servizio, imposta manualmente indirizzi IP dns etc, niente, riavvio, niente.

 

rimozione ethernet in network, riavvio, aggiungo ethernet, applico e emoticon_41 adesso parte

 

 

 

ora el capitan, sierra, high sierra hanno tutti la scheda di rete en0 emoticon_closed emoticon_41

Share this post


Link to post
Share on other sites

Quindi va bene..

 

Comunque poi "per la cronaca" usando i kext di @Mietze la rete al 99% dei casi viene automaticamente iniettata "built-in"

 

Ha fatto veramente un gran lavoro in tutti i suoi kext

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.