Jump to content

[BETA] Clover Bootloader


Recommended Posts

Dove vedi pci8086xxxxxx , Ioreg mostra cosi , xche dovrei assegnarli un la giusta periferica, inteso come quando inserisco IMEI o MCHC in DSDT o in Clover..........

Link to post
Share on other sites
  • Support Team

Risposta di slice ai problemi audio https://www.insanelymac.com/forum/topic/284656-clover-general-discussion/?page=693&tab=comments#comment-2614883">https://www.insanelymac.com/forum/topic ... nt-2614883">https://www.insanelymac.com/forum/topic/284656-clover-general-discussion/?page=693&tab=comments#comment-2614883

 

--------------------------------------

 

 

 

Yes, file Settings.c lines 5048 and 5051 should be added

 

 

 

gSettings.HDAInjection = TRUE;

 

Previously this was by default, but since 4497 I don't want any default injection because Properties will be full enough

 

 

 

-------------------------------------

 

tradotto viene fuori:

 

Sì, è necessario aggiungere il file Settings.c, le linee 5048 e 5051

 

 

 

gSettings.HDAInjection = TRUE;

 

 

 

Precedentemente questo era di default, ma dal 4497 ​​non voglio alcuna iniezione predefinita perché le Proprietà saranno abbastanza complete.

 

------------------------------------

 

 

 

e quindi???? non comprendo, la soluzione poi quale sarebbe... ti attacchi al tram :D usi i voodoo?? sarà iniettato da un nuovo AppleALC?

 

 

 

@Gengik84[/mention] non è che hai anche un bel SSDT per iniettare il layout-ID dell'hack 3? emoticon_blabla

Link to post
Share on other sites
  • Support Team

Forse trovata soluzione, nella pausa testo la cosa:

 

 

 

@arsradu FixHDA nelle correzioni DSDT ... è ciò che fa funzionare la mia build Skylake. Sono abbastanza sicuro che non è abilitato sul mio build Haswell.

 

 

 

Quindi, suggerirei a chiunque con questo problema di abilitare semplicemente FixHDA nelle correzioni DSDT e ... dovrebbe essere così. Tutto il resto rimane lo stesso.

Link to post
Share on other sites
  • Administrators

Non è necessario su haswell.. Ha già il device

 

Nei successivi basta il rename hdas to hdef

 

Ma il discorso layout è a se

Link to post
Share on other sites
  • Support Team

Se mi posso permettere di dare un consiglio ai ragazzi che seguono il forum... NON aggiornate all'ultimo clover, seppur ufficiale, rimanete con la versione 4458 ed in particolare se siete in legacy.

 

Poi sono sicuro che piano piano si sistema tutto, ma ad oggi vedo più svantaggi che vantaggi ad aggiornare ;) poi se uno gli piace smanettare e passarsi la serata, questo è un'altro discorso _whaa

 

 

 

Ha scritto dopo 1 ora 10 minuti 36 secondi:

 

Hack 3 in firma:

 

clover beta 4499 non mi sia avvia più emoticon_uff

 

clover finale 4497 con FixHDA l'audio scompare comunque e processi lenti arrabbiati10

 

quindi resto in attesa di novità dai developers :ugeek:

Link to post
Share on other sites
  • Support Team
"Gengik84" post_id="6165" time="1527247596" user_id="2">

@iCanaro

 

Sai a cosa serve FixHDA?

Sono andato sul wiki a rinfrescarmi la memoria e in effetti...

 

 

 

FixHDA

 

Renames AZAL to HDEF or HDAU. Adds the HMDI device if absent. Else AppleHDA will not work. Adds the properties "layout-id", "MaximumBootBeepVolume" and "PinConfigurations".

 

 

 

Ha scritto dopo 1 ora 36 minuti 45 secondi:

"Gengik84" post_id="6159" time="1527239687" user_id="2">

Non è necessario su haswell.. Ha già il device

 

Nei successivi basta il rename hdas to hdef

 

Ma il discorso layout è a se

 

Il fatto è che con questo hack (il 3 in firma) sinora con tutti i clover dal 4497 compreso in poi l'audio scompare, ma se fosse solo l'audio, i processi rimangono appesi; ad esempio avvio opera e se guardo con il monitor lo da bloccato per liberarsi dopo 30/30 secondi. Se clicchi sull'audio per vedere se le periferiche sono state caricate, idem... ect... poi non son stato lì a verificare altre cose, appena sbloccati i processi, ripristino EFI e riavvio, poi tutto a posto.

 

HDAS to HDEF quello è impostato in tutti gli hack, il layoud-id pure dove uso AppleALC

 

Sul forum internazionale diversi lamentano problemi e alcuni non mi sembrano dei pivelli come me emoticon_linguaccia

Link to post
Share on other sites
  • Administrators

Boh forse mi spiego male...

 

hai avuto un problema di layout, giusto?

 

poi sei scappato dicendo "qualcuno consiglia FixHDA"... correggimi se sbaglio..

 

Quindi in questo caso ho solo detto che non ha senso aggiungere o consigliare FixHDA.. perché i problemi di cui parlavamo non sono inerenti al problema che avevi...e inerenti allo scopo di quel fix...

Link to post
Share on other sites
  • Support Team

@Gengik84[/mention] non eravamo stati spiegati bene :D tutto chiaro ora emoticon_41

 

 

 

@netgear[/mention] eh lo so' che non sto usando proprio quelli che dovrebbero essere i migliori SMBIOS, ma per ora non mi hanno dato problemi, per cui per ora mi tengo questi. Ma cambiarli mi ci vuole un'attimo, visto che non uso nessun servizio apple :)

Link to post
Share on other sites

Io x NON saper leggere e scrivere ho seguito le dritte di Gengik e con la spunta aggiunta in FixHDA al riavvio l'audio torna a funzionare ...... (NON ne avevo dubbi) =) ..... GRANDEEEEE

Link to post
Share on other sites
  • Support Team

@Baio77[/mention] Lo strano mondo dell'hack :D tu hai risolto con FixHDA, se leggi sopra un mio post vedi che fa quel fix, preso dal wiki di clover:

 

FixHDA

 

Renames AZAL to HDEF or HDAU. Adds the HMDI device if absent. Else AppleHDA will not work. Adds the properties "layout-id", "MaximumBootBeepVolume" and "PinConfigurations".

 

 

 

A te ha risolto a me non ha fatto un tubo come ad altri se vedi i link che ho messo su insanely.

 

 

 

Ora, come si dice, ho lavori in corso, ho messo nell'hack 3 un SSDT-HDEF.aml disabilitato HDAS to HDEF e tolto il layout-ID ho riavviato e l'audio funziona ancora emoticon_applausi ora non mi resta che provare qualche clover tranne il 4499 che mi blocca il sistema al boot sulla en0

Link to post
Share on other sites
  • Administrators

sulla ethernet?

 

ci sono un sacco di bug, problemi acpi e conflitti a go go...

 

della lan non mi è capitato

 

riesci a fare un piccolo video del verbose fino a quando si blocca?

 

Thx

Link to post
Share on other sites

Dico forse va , xche in DSDT ho B0D3 rinominato con Clover in HDAU , quindi la butto là , ci sta quella Fix lavora meglio su questo tipo di configurazione o struttura di DSDT......

 

Sono solo ipotesi , dovrò fare alcune prove x vedere in DSDT cosa varia quella Fix , adesso vedo tramite F5 alla Gui ...

Link to post
Share on other sites
  • Administrators

Altra cosa @iCanaro[/mention]

 

tuo hack 3...Z97 --> Haswell non ha hdas ma è sempre presente il corretto device, quindi il rename Hdas to Hdef non serve.. diciamo che questo è per hardware skylake e successivi... (escluso X299 che non ha hdas) :)

 

 

 

Ha scritto dopo 2 minuti 32 secondi:

 

@Baio77[/mention] quel fix fa quello riportato da iCanaro ma non inietta nessun layout.. quindi nel caso uno ne abbia bisogno sarà FixHDA+layout-id

 

Riguardo ai problemi citati da ieri, almeno per iCanaro e altri il bug è la NON iniezione della layout da parte di clover

Link to post
Share on other sites
  • Support Team

@Gengik84[/mention] io avevo fatto la battuta tempo fa... basta compaia l'ectoplasma di gengik con la spada laser e qualsiasi hack si mette in riga di corsa :D fatta la premessa, non sono riuscito a riprodurre il blocco emoticon_uff installato il 4499 che mi inchiodava il sistema oggi nella pausa, e ho fatto 2 riavvi per vedere che non fosse casuale il blocco; quindi installo, riavvio, vai di filmato per gengik.... e il bastardo parte emoticon-occhi_61 mmm stai a vedere che è perché ho lasciato quell'SSDT che mi fa andare l'audio... rimuovo l'SSDT, tolgo il flag da HDAS to HDEF, immetto il layout-ID e riavvio.. vai di filmino... e il bastardo anche stavolta parte emoticon_varie1 non so' che fare per bloccarlo... se gli dico che sei andato in ferie di che ci crede??!| :D

 

 

 

Battute a parte, se ti interessano i blocchi, d'ora innanzi tutte le volte che mi capitano, gli faccio il filmino o almeno una foto OK emoticon_41

 

 

 

PS: ora ho il 4499 sull'hack 3 con SSDT e audio perfettamente funzionante e il sistema va bene... faccio qualche benchmark

 

Se interessa metto link in chiaro o PM al repo cinese dove ho trovato questo e altra roba, fatemi sapere

 

Link to post
Share on other sites

Ho verificato e in effetti ho visto dove e come interviene e detto fra noi , ben venga testare BETA , con 1 pizzico di sbattimento aiuta a comprendere sempre di più in questo mondo , di sicuro aiuta ....

 

Questa puo essere una carta da giocare in futuro

Link to post
Share on other sites
  • Support Team

Clover beta 4500

 

 

 

enable HDA injection if codecID set as string - slice2009 emoticon-personaggi_89

 

 

 

Ha scritto dopo 1 ora 22 minuti 12 secondi:

 

allora... installato clover 4500 nell'hack 2 e 3, tolti SSDT, immesso i layout-id e nel 2 HDAS to HDEF, poi @gengik prima mi ha fatto scoprire che nell'hack 3 quel rename non serve na cippa :) quindi non messo, riavvio e... tutto OK emoticon_applausi quasi quasi mi attento a installarlo anche nell'hack 1 che è in legacy

Link to post
Share on other sites

Sembra periodo di evoluzione , nell'ultimo mese parecchi cambiamenti , le potenzialità di questo bootloader fanno paura ....

 

Saperle tutte sarebbe bellissimo ....

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.