Jump to content

Suono Avvio Hack (carillon) CHIME


Recommended Posts

Come anticipato sull'altro thread¬†ho provato ma sto riscontrando qualche difficolta (come mio solitoūüėÖ)

non riesco ad aprire il men√Ļ options con O non si apre nemmeno se ci pigio sopra con enter e non emette nessun suono con F7

ho verificato su clover il driver AudioDXE.efi

e sul tema che ho installato e presente l'audio...entrambi presenti!

ad ogni modo ho estratto con F8 il dump del codec che allego... non so se può servire!

Thanksss

Dump Codec.zip

Link to post
Share on other sites

Ciao ragazzi io ho capito come creare gli audio personalizzati; devono essere wav stereo 8000hz a 16bit, non ho capito se c'√® una lunghezza massima di secondi ma mi sono tenuto a 2 secondi, un audio pi√Ļ lungo mi sembra¬†inutile.

Link to post
Share on other sites
  • 7 months later...

Buonasera, sono riuscito con OpenCore a far sentire il suono d'avvio del mio hackintosh. L'unica cosa che non riesco a risolvere è,  che prima della Gui si presenta questa scritta molto fastidiosa. Qualcuno può aiutarmi a capire. Grazie

 

ocs: Failed to calculate size of true field conteining <empty> as type integer, content <PlayChime>

Link to post
Share on other sites

@foskvs ho eseguito i tuoi consigli, sul config.plist in UEFI/Audio Properties  ho lasciato string, provando lasciando il campo vuoto sia mettendo YES sia true. All'avvio di OpenCore non appare nessuna dicitura, ma il suono non funziona. Ti ringrazio di cuore come sempre. Ciao

Link to post
Share on other sites
  • Support Team

Oltre che per Clover, nel post iniziale aggiunte spiegazioni su come ottenere il suono di avvio tramite OC

NB: abilitazione audio genera un leggero ritardo di 1, 2 secondi al caricamento GUI

  • Like 1
Link to post
Share on other sites

Hi

Buona la soluzione di iCanaro

Però si ha il suono d'avvio dopo il login funzionante

io lo facevo all'apertura della gui come quando si avvia un vero mac

ma dopo una nuova installazione di BS pur settando l'audio nella Gui/Option/Startup sound output

testando con F7 e sentirlo,non me lo salvava piu.

Si resettava all'audio nvidia

Ho risolto al primo colpo installando CloverApp da qui:https://www.insanelymac.com/forum/topic/341047-cloverapp-testing/

mi chiedo come mai su mojave e catalina mi funziona,forse ho sbagliato versione di Clover Configurator

 

Link to post
Share on other sites
  • Support Team
1 ora fa, m3skall ha scritto:

io lo facevo all'apertura della gui come quando si avvia un vero mac

 

Ti stai riferendo a Clover giusto; è il suo comportamento predefinito, solo che le impostazioni sono salvate in NVRAM, quindi se si resetta o non ti lavora bene, non si avrà il suono. Inoltre quando abilitato il suono, il file audio deve essere presente nel tema in uso.

  • +1 1
Link to post
Share on other sites
On 3/5/2018 at 11:23 PM, iCanaro said:

✅ metodo per avere il suono all'avvio della GUI di Clover

 

Prima in maniera non tanto documentata, solo chi seguiva lo sviluppo di Clover aveva capito la cosa, ora un po' pi√Ļ chiara, ma era ed √® possibile ottenere un suono personalizzato all'avvio della GUI di Clover.

 

Per ottenere questo occorre che sia presente in drivers --> BIOS e drivers --> UEFI il driver AudioDXE.efi, tramite il quale è possibile avere il suono e come altra funzione, pigiando F8 si ottiene anche il dump del codec che si ha a bordo dell'hack. Il risultato dell'operazione sarà poi prelevabile nella cartella Clover --> misc

 

Altro prerequisito è che sia presente un suono compatibile nella cartella del tema in uso

 

Infine occorre settare correttamente dalla GUI di clover l'uscita audio su cui avere il suono

 

con tasto F1 si apre l'help per tutte le funzioni di Clover

screenshot2.jpg

 

Pigiare il tasto O Options e selezionare Startup Sound Oputput

screenshot3.jpg

 

con le frecce spostarsi sull'uscita e con F7 testare se è quella corretta, sarà OK se sentite un suono

screenshot4.jpg

 

Occorre ricordarsi che il valori saranno memorizzati nella NVRAM, quindi ogni qualvolta sarà resettata, vi sarà da eseguire nuovamente le operazioni sopra descritte

 

Suoni che è possibile usare in download

 

Driver: AudioDxe.efi.zip

 

Ora molti temi hanno già il loro suono incluso, occorrerà solo attivarlo

 

OLD:

 

Nel vecchio forum c'è la guida per abilitare il suono di avvio dei veri mac anche sull'hack

http://www.macos86.com/t44-guida-abilitare-chime-sound-all-avvio-dell-hackintosh?highlight=suono+avvio [NON funzionante]

 

Guida Pablonardo

  Reveal hidden contents

ecco un metodo abbastanza semplice per abilitare il classico suono di boot dei Mac originali anche sui nostri hackintosh

l'unico file che ci servirà sarà chime sound (in allegato a fine guida)


Procediamo

Dopo aver scaricato il file lo copiamo nella cartella musica e con il tasto secondario creiamo una copia alias.

Apriamo automator e clicchiamo su nuovo documento e selezioniamo "applicazione"

All'interno di automator nella sezione "azioni" andiamo su utility e selezioniamo "esegui script Shell"

Nella finestra di shell digitaiamo Afplay e il percorso dell'alias precedentemente creato. esempio:

Afplay /Users/pablo/Music/Chime.wav

Chime.wav.zip

Infine andiamo su "salva" in alto nella status bar, nome file: "startup" e selezioniamo la cartella musica come destinazione.

In preferenze di sistema -->utenti e gruppi -->elementi di login clicchiamo sul tasto "+" scegliendo dalla cartella musica il file startup creato con Automator.

 

Per chi ha i voodoo funziona molto bene questo carillon alternative di CHRIS1111

https://github.com/chris1111/Carillon-AppleALC-Version

 

Nel mio hack 1 in firma mi fa il suono prima del caricamento dell'ultima mela ūüėĄ con El Cap, Sierra, HS

PS: per i pi√Ļ pigri con AppleHDA √® disponibile l'installer qui: https://github.com/nicoSWD/carillon/releases/tag/1.0b

 

 

 

sound-1.wav.zip 70.89 kB · 44 downloads sound-2.wav.zip 181.05 kB · 21 downloads sound-3.wav.zip 120.95 kB · 20 downloads sound-4.wav.zip 173.99 kB · 19 downloads

Mac Chime.aiff.zip 65.01 kB · 21 downloads

 

 

✅ OpenCore

OC_Play_Chime.thumb.png.bef1504fa1990f4ae029453340a5632d.png

 

Per ottenere il suono all'avvio di OpenCore occorre configurare il plist:

 

UEFI --> Drivers --> AudioDxe.efi (il driver deve essere presente in EFI/OC/Drivers)

UEFI --> Audio --> AudioDevice --> percorso PCI di HDEF

UEFI --> Audio --> AudioDevice --> AudioSupport --> Yes

UEFI --> Audio --> AudioDevice --> PlayChime --> Auto

UEFI --> Audio --> AudioDevice --> VolumeAmplifier --> (impostare un numero che corrisponda al volume di gradimento)

UEFI --> Audio --> AudioDevice --> ConnectDrivers --> Yes

EFI/OC/Resources/Audio --> OCEFIAudio_VoiceOver_Boot.wav  OCEFIAudio_VoiceOver_Boot.wav.zip 312.99 kB · 1 download

 

VoiceOver_boot.png.eb3ad86ef9e53e3e22e068f1342d32d8.png

posso farlo io sul mio optiplex @iCanaro con clover? ho provato ma non mi fa scegliere opzioni da f1 allora l ho fatto dal menu principale di clover ma all avvio non si sente nulla vorrei mettere il sound 1 wav che hai postato 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.