Jump to content

OpenCore aka OC.. Nuovo BootLoader !!!


Recommended Posts

18 minuti fa, fabiosun ha scritto:

con delle prove incrociate ho scoperto che uno dei miei SSDT era il responsabile di un errore ACPI se partivo con windows dal mio boot menu di openCore

Dì la verità: hai pagato una birra a qualcuno?   🤣

Link to post
Share on other sites
  • Supervisor

no no dimenticate che sono amico del capo! 🙂 🙂

ma questo lo avevo fatto da me con un tool on line 

 

 

 

  • whahahah 2
Link to post
Share on other sites
Posted (edited)
13 minuti fa, fabiosun ha scritto:

la cosa bella e' che non mi serve nemmeno in realtà...

 

ni...ti serve invece 😛 

 

Edited by Lorys89
Link to post
Share on other sites

Ho aggiornato a 082 ma ho bisogno di un consiglio: 

731228538_Schermata2022-07-05alle14_56_28.thumb.png.9edbf53a0be330be2dfbdf3566f1934a.png

 

Come mi consigliate di settarlo . None o Auto?

Edit: dopo reset nvram riparte win11 diretto senza OC però appena entrato nel bios ho trovato le preferenze in realtà invariate: così anche per voi?

Link to post
Share on other sites
21 ore fa, Extreme™ ha scritto:

No non le mantiene. Ma almeno per ora escludi del tutto la possibilità di avviare Windows con OC: non è consigliato. 
A proposito di id Apple: nel pannello preferenze quando selezioni iCloud  vedi Ventura e Monterey associati nel tuo account? Se si, è tutto apposto. 

Ciao @Extreme™  intendevi dire questo:

870741603_Schermata2022-07-05alle15_11_31.png.a163ec0c965447b4c2026f3854d1add5.png

Qesta slide è da Monterey, dove compare un secondo iMacPro non associato che dovrebbe essere ventura. 

Link to post
Share on other sites
  • Supervisor
17 minutes ago, Ramirez71 said:

Edit: dopo reset nvram riparte win11 diretto senza OC però appena entrato nel bios ho trovato le preferenze in realtà invariate: così anche per voi?

no, non avevi detto che non ti accadeva con OC082?

 

comunque bisogna fare attenzione anche alla versione dei kext usati

molto movimento, non consiglio di attivare i kext DEV su OCAT ma utilizzare i propri sicuri

OCAT prende da Dortania gli ultimi commi..e non sono stabili per tutti

 

Link to post
Share on other sites
4 minuti fa, fabiosun ha scritto:

no, non avevi detto che non ti accadeva con OC082?

Avevo detto che non modifica le impostazioni di boot contenute nel bios ma difatto riavvia win11 diretto, se c'è stata una incomprensione è in parte una mia colpa dal momento che tutte le volte che resetto la nvram entro subito nel bios senza farlo boottare: oggi ho provato a lasciarlo libero per vedere cosa succedeva.

 

Quindi ricapitolo:

081 resetta anche quello che è impostato nel bios in termini di boot preference,

082 non resetta le boot preference nel bios ma dopo reset comunque parte il disco win. 

9 minuti fa, fabiosun ha scritto:

OCAT prende da Dortania gli ultimi commi..e non sono stabili per tutti

Oggi però ho usato i kext relise non dev.   Kexts.zip 

Non li ho aggiornati a manina però.

 

Fabio che mi consigli? Apro un topic a parte per vedere se ci sono delle cavolate mostruose nella hack ? A me non sembrava necessario ma a questo punto inizio a vacillare. 

 

@Extreme™ questo è quello che esce da ventura:

 

1689054371_Screenshot2022-07-05alle15_21_03.png.808aec671823806882ee4e66dca8b06f.png

 

 

come puoi vedere il primo mac in alto corrisponde al disco ventura, quello scollegato dall' ID a Monterey. In pratica ogni volta che avvio Ventura Mi chiede le credenziali ID collegando il disco aperto e scollegando Monterey, viceversa appena rientro in Monterey: se ne collego uno l'altro viene sconnesso. Se è un problema di impostazioni ID sono off topic e me ne scuso ma non saprei dove mettere le mani

Link to post
Share on other sites
  • Supervisor
6 minutes ago, Ramirez71 said:

Fabio che mi consigli? Apro un topic a parte per vedere se ci sono delle cavolate mostruose nella hack ? A me non sembrava necessario ma a questo punto inizio a vacillare. 

si se hai già un tuo thread con questa Build posta li

magari chi ne sa di piu' ti puo' aiutare

 

e' strano quello che ti accade

a me pulendo la Nvram non accade questo...mi accadeva che mi cambiava l'ordine dei dischi ma non con le ultime versioni di Opencore, e solo quando facevo probabilmente dei mischioni di boot con Clover (untested)

 

Link to post
Share on other sites

Grazie, lo posto sul topic GIGIOHACK vediamo se qualche "anima pia" si accolla un caso umano... Altrimenti pazienza, la cosa importante è, come dico sempre,  che al di la della piccola scocciatura, non sia segno di problemi più profondi. 

Link to post
Share on other sites
  • Supervisor

image.thumb.png.16449ab0f9c9984d6df86b302ed508f2.png

 

sono partito da OpenCore...

ma secondo me fare dei passaggi tra i due bootloader incasina qualche variabile di NVRAM

 

Link to post
Share on other sites
  • 3 weeks later...
  • Support Team

Per chi non si ricorda  🙃  come ha impostato il valore CSR ( SIP ) con l ultimo commit  https://dortania.github.io/builds/?product=OpenCorePkg&viewall=true&version=0.8.3&sha=83123452fe6bb254ad40ff7a55e142213f1ea4c0

 

e' possibile visualizzarlo al boot ( Aggiungere  "  --show-csr  "  in Arguments )

 

874767556_Screenshot2022-07-28alle12_59_

 

 

Occio cambia la struttura del plist nella sezione drivers 

1046094126_Screenshot2022-07-28alle12_56

 

Da Enabled ( YES / NO ) a Load ( Enabled / Disabled )

  • Like 1
Link to post
Share on other sites

Occhio all'ultimo commit 083: mi ha fatto innervosire abbastanza perché pensando al solito aggiornamento all'acqua di rose non mi sono letto prima il changelog.  Cercavo di correggere gli errori di OC Validate nella sezione Uefi>>Driver ma ovviamente non riuscivo. Perché bisogna aprire il nuovo config.plist dell'ultimo commit prendere la sezione Uefi>>Driver e sostituirla completamente nel vostro config.plist in uso. Infine personalizzarla in base ai drivers che caricate, come sempre.

 

Infine, nella sezione NVRAM  hanno tolto LegacyEnable: quindi cancellatelo nel vostro config.plist

Edited by Extreme™
Link to post
Share on other sites
  • Administrators

Release v0.8.3

  • Added ext4 file system driver
  • Added support for macOS 13 DP3 Kernel Collection
  • Added --force-device option to AudioDxe, allowing UEFI audio on HDA contollers which misreport themselves as non-HDA audio devices
  • Provided optional unsafe fast file logging (suitable only for firmware with a fully compliant FAT32 driver)
  • Fixed incorrect OSBundleLibraries_x86_64 handling during cacheless injection
  • Changed RsaTool not to link against system ssl on macOS
  • Fixed crash during cacheless injection when kext blocking is enabled
  • Removed default codec connection delay from AudioDxe
  • Added optional --codec-setup-delay argument to AudioDxe
  • Changed units of Audio -> SetupDelay from microseconds to milliseconds (divide previous value by 1000 if using this setting)
  • Fixed incorrect FAT binary slice being selected under macOS 10.4.11 when performing a cacheless boot
  • Fixed rare assertion caused by label animation initialisation in OpenCanopy
  • Added --show-csr option for Toggle SIP boot menu entry
  • Added macOS 10.4 and 10.5 support to AllowRelocationBlock Booter quirk
  • Added CPU cache info injection for macOS 10.4 to ProvideCurrentCpuInfo quirk
  • Added emulated NVRAM driver for use separately from OpenDuet
  • Added support for NVRAM reset and set default boot entry when using emulated NVRAM
  • Upgraded emulated NVRAM logout script to allow unsupervised installation of recent macOS OTA updates
  • Added Driver -> LoadEarly for drivers which need to be loaded before NVRAM init
  • Like 5
Link to post
Share on other sites

Ho provato ad aggiornare il mio hack n 3) in firma con OCAT da Oc 0,81 a Oc 0,83, ma NON ci sono riuscito… hack in blocco… allego schermata 😩😩😞😞

Help 

IMG_2298.jpg

Link to post
Share on other sites
  • Supervisor
6 minutes ago, scipione said:

Ho provato ad aggiornare il mio hack n 3) in firma con OCAT da Oc 0,81 a Oc 0,83, ma NON ci sono riuscito… hack in blocco… allego schermata 😩😩😞😞

Help 

IMG_2298.jpg

hai aggiornata anche i kext?

vedo le righette porpora che non si vedevano da anni

 

Link to post
Share on other sites
10 minuti fa, fabiosun ha scritto:

hai aggiornata anche i kext?

vedo le righette porpora che non si vedevano da anni

 

Si aggionato tutto, kext, drivers e salvato il config senza errori… ma al riavvio mi fa sta schermata e non si avvia…. 
mo vedo se riesco s far partire il disco di emergenza usb dove ho una copia del sistema operativo… se si avvia da li, copio la efi e la posto… 😩😩 

  • Cross Finger 1
Link to post
Share on other sites
Il 28/7/2022 at 13:33, antuneddu ha scritto:

 

 

 

Occio cambia la struttura del plist nella sezione drivers 

1046094126_Screenshot2022-07-28alle12_56

 

Da Enabled ( YES / NO ) a Load ( Enabled / Disabled )

 

 

Io ho aggiornato da OCAT direttamente alla 0.8.4 pare che funzioni tutto bene e OCValidate non da nessun errore , ma questo cambiamento che dici a me non lo rileva.

 

 

Schermata 2022-08-02 alle 11.58.28.png

 

 

 

Schermata 2022-08-02 alle 11.59.35.png

Link to post
Share on other sites
  • Support Team

Era un commit precedente ... nel frattempo hanno ricambiato 😆 

 

Se fai caso alla mia immaggine sopra invece di ENABLED c e' LOAD 

 

Invece ora hanno rimesso ENABLED come prima e hanno creato una voce a parte per LOADearly  

 

  • +1 1
Link to post
Share on other sites

Ecco la EFi 083 aggiornata con OCAT e che non mi avvia il sistema.... ho tolto la cartella Resources per renderla più leggera e poterla postare.... 

Potete dargli una occhiata e dirmi se riscontrate qualche anomalia ?.... 

Apparentemente sembra tutto ok.... ho pure guardato la struttura DRIVERS e sembra esattamente come l'immagine postata sopra... non capisco cosa è che non funziona.... sigh

Efi 0,83 NON funzionante.zip

Link to post
Share on other sites

Adesso non sono a casa altrimenti avrei guardato la tua EFI. 
Comunque quando - raramente in realtà- mi capita di aggiornare OC con salti di versione abbastanza evidenti  come nel tuo caso preferisco sempre affidarmi alla manina piuttosto che a OCAT. 
OCAT è un ottimo tool ed io stesso ne faccio uso quotidiano ma il metodo “a mano” resta secondo me quello più affidabile. 

  • Like 1
  • Ok 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.