Jump to content
You are a guest user Click to join the site

A23SS4NDRO

Contributor
  • Content Count

    422
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by A23SS4NDRO

  1. Perfetto, allora facciamo una modifica per volta e vediamo dove si intoppa, grazie mille! Vi aggiorniamo
  2. Perfetto, quest'ultima gli funziona. Ha schermo nero dopo la verbose, servirà agdgpmod=pikera o agdgpmod=vit9696 per la RX5700XT della sapphire che sta usando? Sbaglio @zLeo99?
  3. Se l'ioreg ti risponde allo stesso modo, prendi l'ultimo ssdt che ho fatto per questa build, in cui ho definito grazie a Gengik le porte Si chiama SSDT-4-xh_rvp08_new.aml ed è zippato
  4. Ok perfetto allora inizio con zero patch ACPI. Le kext metto quelle di un mese fa o vanno bene quelle compilate all'ultimo commit? Per i Driver invece (applesupportpkg e opencore.efi) Appena ho conferma di tutto rifaccio la EFI nuova e la mando qui
  5. Penso che gli serva nascondere solo questo Device dal DSDT, almeno questo consiglia SSDT Time DefinitionBlock ("", "SSDT", 2, "APPLE ", "SsdtEC", 0x00001000) { External (_SB_.PCI0.SBRG, DeviceObj) Scope (\_SB.PCI0.SBRG) { Device (EC) { Name (_HID, "ACID0001") // _HID: Hardware ID Method (_STA, 0, NotSerialized) // _STA: Status { If (_OSI ("Darwin")) { Return (0x0F) } Else { Return (Zero) } } } } }
  6. Unica opzione RTC che ha è Power On by RTC che è su Disabled
  7. Ora ripartiamo da zero allora, siccome non schioda. Kext minimali, magari il config.plist lo posso riutilizzare, quello con DummyPowerManagement off e tra le kext NullCPU, e gli SSDT che metto (SSDT EC serve necessariamente in linea teorica per catalina) controllo
  8. Con Lilu sistemato in cima: lilu.mp4 Con RTCMemoryFixup nel config e nella cartella: EFI_TUF_V7.zip rtcmem.mp4
  9. Faccio due avvii indipendenti, prima solo sistemando Lilu, non mi è ancora chiara la svista di aver messo SMCSuperIO in cima, poi provo con RTCMemoryFixup Ok dopo aver testato procedo
  10. Ecco video di avvio della USB e del disco, stessi errori video2.mp4 Avvio da USB (installer) video3.mp4 Ripartiamo da zero con un nuovo topic aggiornando il BIOS della TUF X570 (resettando di conseguenza il CMOS)?
  11. Abbiamo provato ad avviare la USB che non ha toccato, con cui d'altronde aveva installato con successo con la EFI allegata sopra (EFI_Originaria_asus_X470) ma ha lo stesso errore. Non riesco neanche io a crederci comunque, serve individuare che cosa abbia potuto stravolgere F4 F8 e F11 dalla USB di clover
  12. Questa è la EFI con cui ha avviato per la prima volta su Asus X470 EFI_Originaria_asus_X470.zip In questo video mostrava i problemi che aveva con la tastiera, che dopo pochi minuti non gli andava piu, sebbene avesse disattivato ogni forma di stadby, power nap, sistemato a dovere con pmset da terminale, eccetera video1.mp4
  13. Provo ad avviare l'installer della USB con cui ha installato. Nel frattempo allego screenshot e cartella EFI originaria, ottimizzata in versioni successive appena prima di combinare quella roba con F4 F8 ed F11 dalla USB di clover, mannaggia a me, non l'avessi mai detto
  14. La EFI l'ho ricompilata da capo ieri all'ultima versione di OC, mettendo Bootx64.efi nuovo, OpenCore.efi nuovo, il config.plist sistemato, Kext ribuildate da zero e l'errore è lo stesso Se volete ho anche delle foto della build quando era partita, vi posso passare qui anche la EFI con cui ero partito. Si dopo l'aggiornamento avviene in automatico. Ho anche cambiato la motherboard e l'errore non schioda Sarà forse il disco che si è corrotto? non so
  15. Secondo me non mi è ancora ben chiaro quale sia l'origine del problema RTC che persite
  16. I test avvenuti prima della EFI che ho postato precedentemente che si chiama Asus_TUF avevano stessa mobo stessa versione del bios (resettato prima la NVRAM, non cambiava nulla, poi abbiamo aggiornato il bios, rimesse le impostazioni non è cambiato nulla) stessa efi anche come versione opencore stessa versione di catalina prima andava e ora no, esattamente Tutto ciò è avvenuto solo perché volevo estrarre le ACPI con una USB temporanea usando F4 da clover e un dump audio usando F8, poi ho pulito la NVRAM con F11 ed ecco che la motherboard ha cominciato a fare i capricci Entrambe le motherboard poi, perché abbiamo fatto anche una sostitizione e sistemazione della EFI con quelle postate in alto Abbiamo provato un reset nvram con il tool CleanNvram.efi da OpenCorePkg, ecco la verbose dopo aver spento il PC e avviato
  17. Si esattamente, da gli stessi errori della precedente. E ancora non capisco da dove provengano.
  18. Si viene caricato correttamente come è visibile dall'inizio della verbose Ecco cosa ho provato, quindi si ho provato a riflashare il bios sulla motherboard precedente, e anche a cambiare tutta la motherboard intera
  19. Ok, ho apportato le modifiche che mi hai detto: EFI_Asus_TUF_V3.zip Ho aggiunto appunto NullCPUPowerManagement preso dalla sezione downloads del sito, rimosso il quirk DummyPowerManagement, rimosso SSDT-EC
  20. The battery alert problemi is not present by the way I'm going to attach the DSDT table here, I think some patches are required to get around this issue DSDT.aml.zip Even with the latest EFI and SSDT-AmdRtc.aml I'm not able to boot EFI_Asus_TUF_v2.zip Traduzione Unica differenza con il resto degli errori è che l'ultimo non è presente Allego il DSDT, secondo me servono delle patch acpi DSDT.aml.zip Anche con questa EFI che ha SSDT-AmdRtc.aml nel config non riesce a superare quell'errore EFI_Asus_TUF_v2.zipEFI_Asus_TUF_v2.zip
  21. @Shaneee am I missing something? Any updates on this issue from 01-02-2020? EFI folder attached here, stuck at the same error Also above those lines getting: VirtalSMC efend @ authenticated restart support is unavailable HID: Legacy shim 2 RTC: Only single RAM bank (128 bytes) HPET: map device registers failed RTC: lost battery power - time may be invalid I may try to add Gengik84's SSDT-AMD-RTC Traduzione Manca qualcosa in merito? Ci sono aggiornamenti da quando è stato postato quel topic? Allego la EFI e l'errore è (quello postato sopra) Aggiungo nel frattempo l'ssdt RTC che mi aveva dato Gengik, vediamo come cambia la situazione EFI_Asus_TUF.zip
  22. Ecco sul forum amd-osx.com lo stesso identico blocco, ma sembra che sia passato in cavalleria https://amd-osx.com/forum/viewtopic.php?t=9967
  23. Don't worry, non c'è problema Buona notizia: il laptop è stato spedito il 28/03/2020, penso che arriverà entro una settimana o due circa Quindi estrarrò tutto appena arriverà, che tool mi consigli di usare per rimanere solo su OpenCore? Quelli che mi vengono in mente per ora sono solo acpidump da linux, ce ne sono altri per UEFI shell specifici per opencore
  24. Aggiornamenti in merito al supporto Ice Lake da Khronokernel (source) Yup, 10.15.4 beta 6 supports it, couple small problems: * Clover no longer boots for many users(beta 6 issue) - this was fixed in 5107 * intel added memory protection to the firmware which takes up 2GB of the memory map First issue is fixed by either waiting for Slice to fix clover *again* or use OpenCore which has OOB support. Second one is solved with OpenCore again, version 0.5.7 adds a new quirk called ProtectUefiServices which gets around the memory protection issue. Problem is 0.5.7 is still being worked on and won't be officially released until start of April(but you can build it yourself) Other thing I'd be worried about is iGPU support, atm we only know the following are supported(as the new MacBookAir uses them): * Iris Plus G7 * Iris Plus G4 I'm most guessing because Apple's an ass and won't release exact models. So have to go by what's been released. Traduzione Sì, 10.15.4 beta 6 lo supporta, con piccoli problemi: * Clover non si avvia più per molti utenti (problema beta 6) - questo problema è stato risolto nel 5107 * Intel ha aggiunto una protezione della memoria al firmware che occupa 2 GB della mappa di memoria Il primo problema viene risolto aspettando che Slice ripari nuovamente Clover oppure utilizzi OpenCore con supporto OOB (out of the box - nativo). Il secondo è di nuovo risolto con OpenCore, la versione 0.5.7 aggiunge un nuovo Quirk chiamato ProtectUefiServices che aggira il problema di protezione della memoria. Il problema è che 0.5.7 è ancora in fase di sviluppo e non verrà rilasciato ufficialmente fino all'inizio di aprile (ma puoi fare il build da solo). Un'altra cosa di cui mi preoccuperei è il supporto iGPU, al momento sappiamo solo che sono supportati solo i seguenti (poiché il nuovo MacBookAir li usa): * Iris Plus G7 (in utilizzo sul i7 1065G7 appunto) * Iris Plus G4 Sto solo supponendo poiché purtroppo Apple non rilascerà modelli esatti (se userà iGPU differenti), quindi la scelta migliore sarà andare con i modelli esatti (G4 e G7)
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.